Opened 4 years ago

Closed 4 years ago

#763 closed defect (worksforme)

DVD boot fails with "Unable to mount root fs on unknown-block(1,0)" - CentOS 6.5

Reported by: mg-thomas Owned by: bruno
Priority: normal Milestone: 3.2.1
Component: mindi-kernel Version: 3.0.4
Severity: normal Keywords:
Cc:

Description

Boot of recovery DVDs created by mondoarchive

  • mondo-3.0.4-1.rhel6.x86_64.rpm
  • mindi-2.1.7-1.rhel6.x86_64.rpm
  • mindi-busybox-1.21.1-1.rhel6.x86_64.rpm)

fails with kernel panic:

...
md: Waiting for all devices to be available before autodetect
md: If you don't use raid, use raid=noautodetect
md: Autodetecting RAID arrays.
md: Scanned 0 and added 0 devices.
md: autorun ...
md: ... autorun DONE.
List of partitions:
No filesystem could mount root, tried: iso9660
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(1,0)
Pid: 1, com: swapper Not tainted 2.6.32-431.el6.x86_64 #1
Call trace:
 [<ffffffff815271fa>] ? panic+0xa7/0x16f
 [<ffffffff81c274bb>] ? mount_block_root+0x29f/0x2cb
 [<ffffffff81002930>] ? bstat+0x2b0/0x980
 [<ffffffff81c2753d>] ? mount_root+0x56/0x5a
 [<ffffffff81c276b1>] ? prepare_namespace+0x170/0x1a9
 [<ffffffff81c2692a>] ? kernel_init+0x2e1/0x2f7
 [<ffffffff8100c20a>] ? child_rip+0xa/0x20
 [<ffffffff81c26649>] ? kernel_init+0x0/0x2f7
 [<ffffffff8100c200>] ? child_rip+0x0/0x20

Details of the panic, and notes of two RPM conflict problems encountered when installing and running mondoarchive, are given at the top of the first attached file.

Attached files:

Mondo_install_and_use.txt
Kernel panic details & full description of the installation of mondoarchive;
mondorescue.org_installed.ls.txt
Directory listing of packages installed for mondrescue;
spconfig_clean-mondoarchive.log
/var/log/mondoarchive.log from the archive ISOs creation process;
spconfig_clean-mindi.log
/var/log/mindi.log from the archive ISOs creation process;
spconfig_clean-mondoverify.log
/var/log/mondoarchive.log from archive ISOs verification.

Attachments (5)

Mondo_install_and_use.txt.tar.gz (8.4 KB) - added by mg-thomas 4 years ago.
Details of the bug, including installation of mondoarchive
mondorescue.org_installed.ls.txt.tar.gz (1.3 KB) - added by mg-thomas 4 years ago.
Directory listing of downloaded and installed RPM packages
spconfig_clean-mondoarchive.log.tar.gz (148.7 KB) - added by mg-thomas 4 years ago.
mondoarchive.log from archive creation
spconfig_clean-mindi.log.tar.gz (6.2 KB) - added by mg-thomas 4 years ago.
mindi.log from archive creation
spconfig_clean-mondoverify.log.tar.gz (37.5 KB) - added by mg-thomas 4 years ago.
mondoarchive.log from archive ISOs verification

Download all attachments as: .zip

Change History (8)

Changed 4 years ago by mg-thomas

Details of the bug, including installation of mondoarchive

Changed 4 years ago by mg-thomas

Directory listing of downloaded and installed RPM packages

Changed 4 years ago by mg-thomas

mondoarchive.log from archive creation

Changed 4 years ago by mg-thomas

mindi.log from archive creation

Changed 4 years ago by mg-thomas

mondoarchive.log from archive ISOs verification

comment:1 Changed 4 years ago by mg-thomas

See Mondo_install_and_use.txt.tar.gz for full details. This described the problem, and gives complete details of the installation of mondoarchive atop CentOS 6.5.

Had two problems during installation & running of mondoarchive:

  1. pusk & rpmbootstrap packages from mondoarchive.org FTP site have conflicting /usr/bin/rpmbootstrap script;
  2. mindi & mindi-busybox disagree about the location of .../rootfs/[usr/]bin/busybox.

One or both might be the cause of the problem in the Linux kernel installed on the ISOs.

comment:2 Changed 4 years ago by bruno

You should respect the compatibilty matrix of versions. Your mindi-busybox one is wrong for your mondo version. Cf: http://trac.mondorescue.org/wiki/FAQ#Q38Whichversionsofmindiandmondoarecompatible

comment:3 Changed 4 years ago by bruno

  • Resolution set to worksforme
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.