Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#764 closed defect (fixed)

New version of mondo v3.2.0-r3332 cause a segmentation fault on debian 7

Reported by: GVR Owned by: Bruno Cornec
Priority: highest Milestone: 3.2.1
Component: mondo Version: 3.2.0
Severity: blocker Keywords: segmentation fault
Cc:

Description

Hi all

The latest version of mondo for debian 7 installed from "deb ftp://ftp.mondorescue.org//debian 7 contrib" failed with a segmentation fault in mondoarchive :

/usr/sbin/mondoarchive -K 5 -OV -G -N -i -d /tmp -s10000m -I "/home" -3 -T /tmp -S /tmp -p mbackup_LX8_full_150123_1512 See /var/log/mondoarchive.log for details of backup run. Checking sanity of your Linux distribution Done. Segmentation fault

Version:

Paquet libmondorescue-perl : 3.2.0-1 Paquet mindi : 3.0.0-1 Paquet mindi-busybox : 1.21.1-1 Paquet mondo : 3.2.0-1

Linux lx8 3.2.0-4-amd64 #1 SMP Debian 3.2.65-1+deb7u1 x86_64 GNU/Linux

/var/log/mindi.log and /var/log/mondoarchive.log attached

With previous version, above command and others daily backup run fine everyday on many Debian box : Paquet mindi : 2.1.7-1 Paquet mindi-busybox : 1.18.5-3 Paquet mondo : 3.0.4-1

Seems to be the same problem reported here : http://mondorescue-mailing-list.679749.n3.nabble.com/Re-Mondo-devel-Segmentation-error-running-mondoarchive-v3-2-0-r3332-tp4026464.html

Regards,

Joel

Attachments (2)

mondoarchive.log (6.4 KB) - added by GVR 5 years ago.
mindi.log (21.8 KB) - added by GVR 5 years ago.

Download all attachments as: .zip

Change History (5)

Changed 5 years ago by GVR

Attachment: mondoarchive.log added

Changed 5 years ago by GVR

Attachment: mindi.log added

comment:1 Changed 5 years ago by Bruno Cornec

Priority: normalhighest
Severity: normalblocker
Status: newassigned

I can also reproduce your error with my Mageia 4 and I'm digging to find the root cause.

comment:2 Changed 5 years ago by Bruno Cornec

Resolution: fixed
Status: assignedclosed

Fixed in rev [3334]. Will be in 3.2.1. The issue is with the usage of -I which is broken in 3.2.0. A work around is to exclude all the other irs or wait for 3.2.1.

comment:3 Changed 5 years ago by GVR

Thanks for your help and reply Bruno,

How long approximately for version 3.2.1 ?

Regards,

Joel

Note: See TracTickets for help on using tickets.