Opened 9 years ago

Closed 9 years ago

#439 closed defect (fixed)

mondoarchive hangs during backup (due to /opt/jboss-5.1.0.GA/docs/licenses)

Reported by: kritzenthaler Owned by: bruno
Priority: normal Milestone: 2.2.9.5
Component: mondo Version: 2.2.9.4
Severity: normal Keywords:
Cc:

Description

The following command-line always hangs ("waiting for storer" blocked forever in "mondoarchive.log") at around 12% during the backup-phase on RHEL5.5:

mondoarchive -OVi -N -d /home/backup -E /home/backup -s 4480m -z

It was working perfectly on RHEL5.4 but it seems to behave differently with RHEL5.5, even if the RPM packages used are the same ones.

I have tried both our previous mondo version we were using on RHEL5.4 (mondo-2.2.9.2) and the newest version (mondo-2.2.9.4) but without success.

It seems that the backup does not hang if I remove the -z flag so the issue might be SELINUX related.

The issue looks similar to an existing one which make use of the -z flag also (ticket#400 "mondoarchive hangs during backup to DVD size ISO").

This is a blocker for us since our customer will move to RHEL5.5 in the September/October? timeframe and we do not have a working mondo version (with SELINUX support/-z) for RHEL5.5 at the moment.

Another thing to mention, my RHEL5.5 is installed on DL380G7 which is a new Proliant HW. I doubt it is related to our issue but I thought it'd be worth mentioning.

Attachments (4)

mondoarchive.log.tar.gz (22.5 KB) - added by kritzenthaler 9 years ago.
filelist.22 (31.0 KB) - added by kritzenthaler 9 years ago.
xattr_list.22.gz (4.0 KB) - added by kritzenthaler 9 years ago.
problematic_files_under__opt-jboss-5.1.0.GA-docs-licenses.tar.gz (78.8 KB) - added by kritzenthaler 9 years ago.

Download all attachments as: .zip

Change History (11)

Changed 9 years ago by kritzenthaler

comment:1 Changed 9 years ago by kritzenthaler

I have done the test with a DL380G6 and was not able to reproduce the issue with mondo-2.2.9.2.

There is a higher chance that the issue is DL380G7 specific since I did not see the log "waiting for storer" in "mondoarchive.log" on DL380G6.

comment:2 Changed 9 years ago by kritzenthaler

  • Priority changed from highest to normal
  • Severity changed from blocker to major
  • Summary changed from mondoarchive hangs during backup (RHEL5.5 and -z flag) to mondoarchive hangs during backup (due to something under /opt/jboss-5.1.0.GA)

After making additional tests and analyzing the issue a bit deeper, it does not seem that the issue is related to RHEL5.5 nor G7 nor the version of mondo...

It seems to be related with something in "fileset.22" (all files are located under "/opt/jboss-5.1.0.GA") that does not make the backup-phase happy.

It is confirmed as well in the "mondoarchive.log" where we see nothing after "EXATing 22...", whereas we would have expected "archiving 22" and "archived 22 OK" logs as well.

Please have a look in the attached files "filelist.22"/"xattr_list.22.gz"/"acl_list.22.gz" to determine if the culprit can be identified with those at the time of the HANG.

Thus, I will not consider this issue as a blocker anymore since the work-around is easy and I will decrease severity as well.

If I exclude the whole directory "/opt/jboss-5.1.0.GA" from my backup, the backup runs fine on my RHEL5.5/G7:

mondoarchive -OVi -N -d /home/backup -E "/home/backup /opt/jboss-5.1.0.GA" -s 4480m -z

Changed 9 years ago by kritzenthaler

Changed 9 years ago by kritzenthaler

comment:3 Changed 9 years ago by kritzenthaler

"acl_list.22.gz" is empty so I did not attach it ...

comment:4 Changed 9 years ago by kritzenthaler

  • Severity changed from major to normal

I have further identified the problematic files ... They are located under "/opt/jboss-5.1.0.GA/docs/licenses".

Please find them attached.

Those files contain white spaces " ".

Could it be related with Changeset 2676 (http://trac.mondorescue.org/changeset/2676) ? If yes, will it be included in 2.2.9.5 ?

comment:5 Changed 9 years ago by kritzenthaler

  • Summary changed from mondoarchive hangs during backup (due to something under /opt/jboss-5.1.0.GA) to mondoarchive hangs during backup (due to /opt/jboss-5.1.0.GA/docs/licenses)

comment:6 Changed 9 years ago by bruno

  • Status changed from new to assigned

This problem should be fixed in the latest beta version available at ftp://ftp.mondorescue.org/test Please test and report back. TIA.

comment:7 Changed 9 years ago by bruno

  • Resolution set to fixed
  • Status changed from assigned to closed

Should be fixed with 2.2.9.5 official. Please reopen if it's not the case.

Note: See TracTickets for help on using tickets.