Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#440 closed defect (fixed)

New package location for dependency parted in gentoo portage

Reported by: Francesco Owned by: bruno
Priority: normal Milestone: 2.2.9.5
Component: mondo Version: 2.2.9.4
Severity: normal Keywords:
Cc:

Description (last modified by bruno)

Parted has been moved from sys-apps/parted to sys-block, please update the ebuild accordingly.

BTW the version is actually newer than 2.2.9, but the current naming scheme breaks "gentoo standards", anyway that's another issue.

--- /usr/local/portage/standard/app-backup/mondo-rescue/mondo-rescue-2.2.9.ebuild	2010-08-22 09:01:45.000000000 +0200
+++ /usr/local/portage/standard/app-backup/mondo-rescue/mondo-rescue-2.2.9.ebuild~	2009-09-11 19:58:24.000000000 +0200
@@ -26,7 +26,7 @@
 	>=sys-apps/mindi-2.0.7
 	>=dev-libs/newt-0.50
 	>=sys-libs/slang-1.4.1
-	sys-block/parted
+	sys-apps/parted
 	>=sys-boot/syslinux-1.52"
 
 S="${WORKDIR}/${PN/-rescue/}-${PV}"

Change History (7)

comment:1 Changed 9 years ago by Francesco

The same goes for mindi

comment:2 Changed 9 years ago by bruno

  • Description modified (diff)
  • Milestone set to 2.2.9.5
  • Status changed from new to assigned
  • Version set to 2.2.9.4

comment:3 Changed 9 years ago by bruno

  • Resolution set to invalid
  • Status changed from assigned to closed

Seems to me it's already correct at http://trac.project-builder.org/browser/projects/mondorescue/pbconf/branches/2.2.9/mondo/ebuild/mondo-rescue.ebuild

So I don't know why you still get that old version. (the delivered version seems ok too: ftp://ftp.mondorescue.org/gentoo/nover/mondo-2.2.9.4-1.ebuild)

comment:4 Changed 9 years ago by Francesco

  • Resolution invalid deleted
  • Status changed from closed to reopened

Both the counterexamples provided list parted as sys-apps/parted, but is no more there, I sync every day the portage tree and an error came up Sunday because parted was "moved". The last edit to the ebuild is (according

to the date in FTP folder listing) 09/06/2010.

Mondo ebuilds still have the old location, and that gives an error (even if mondo is already installed) when a check is done to see if are there packages to upgrade. The issue is open, see at the bottom of the following text, the location parted is reported to reside in is different from the one written in the ebuilds.

[yolk@shell:~]$ wget ftp://ftp.mondorescue.org/gentoo/nover/mondo-2.2.9.4-1.ebuild --2010-08-24 08:52:15-- ftp://ftp.mondorescue.org/gentoo/nover/mondo-2.2.9.4-1.ebuild

=> “mondo-2.2.9.4-1.ebuild”

Resolving ftp.mondorescue.org... 213.30.161.23 Connecting to ftp.mondorescue.org|213.30.161.23|:21... connected. Logging in as anonymous ... Logged in! ==> SYST ... done. ==> PWD ... done. ==> TYPE I ... done. ==> CWD (1) /gentoo/nover ... done. ==> SIZE mondo-2.2.9.4-1.ebuild ... 1732 ==> PASV ... done. ==> RETR mondo-2.2.9.4-1.ebuild ... done. Length: 1732 (1.7K) (unauthoritative)

100%[===================================================================================================================================================================================================>] 1,732 --.-K/s in 0.04s

2010-08-24 08:52:16 (41.3 KB/s) - “mondo-2.2.9.4-1.ebuild” saved [1732]

[yolk@shell:~]$ grep parted mondo-2.2.9.4-1.ebuild

sys-apps/parted

[yolk@shell:~]$ eix parted$ [I] sys-block/parted

Available versions: 2.3{tbz2} {+debug device-mapper nls readline selinux} Installed versions: 2.3{tbz2}(10:04:18 22/08/2010)(debug device-mapper nls readline -selinux) Homepage: http://www.gnu.org/software/parted Description: Create, destroy, resize, check, copy partitions and file systems

comment:5 Changed 9 years ago by Francesco

Sorry, I should have used wiki formatting

[yolk@shell:~]$ wget ftp://ftp.mondorescue.org/gentoo/nover/mondo-2.2.9.4-1.ebuild
--2010-08-24 08:52:15--  ftp://ftp.mondorescue.org/gentoo/nover/mondo-2.2.9.4-1.ebuild
           => “mondo-2.2.9.4-1.ebuild”
Resolving ftp.mondorescue.org... 213.30.161.23
Connecting to ftp.mondorescue.org|213.30.161.23|:21... connected.
Logging in as anonymous ... Logged in!
==> SYST ... done.    ==> PWD ... done.
==> TYPE I ... done.  ==> CWD (1) /gentoo/nover ... done.
==> SIZE mondo-2.2.9.4-1.ebuild ... 1732
==> PASV ... done.    ==> RETR mondo-2.2.9.4-1.ebuild ... done.
Length: 1732 (1.7K) (unauthoritative)

100%[===================================================================================================================================================================================================>] 1,732       --.-K/s   in 0.04s   

2010-08-24 08:52:16 (41.3 KB/s) - “mondo-2.2.9.4-1.ebuild” saved [1732]


[yolk@shell:~]$ grep parted mondo-2.2.9.4-1.ebuild 
	sys-apps/parted

[yolk@shell:~]$ eix ^parted$
[I] sys-block/parted
     Available versions:  2.3{tbz2} {+debug device-mapper nls readline selinux}
     Installed versions:  2.3{tbz2}(10:04:18 22/08/2010)(debug device-mapper nls readline -selinux)
     Homepage:            http://www.gnu.org/software/parted
     Description:         Create, destroy, resize, check, copy partitions and file systems

comment:6 Changed 9 years ago by bruno

  • Resolution set to fixed
  • Status changed from reopened to closed

Sorry, I looked at the patch, more than I read your text. In fact your patch does the reverse that what you say ! So I've modified now the file accordingly. Cf: http://trac.project-builder.org/changeset/1084

Will be in next 2.2.9.5 for gentoo builds. Thanks for your feedback !

comment:7 Changed 9 years ago by Francesco

D'oh :), my report was misleading. I was surprised by the reply, now it makes sense. Thanks Bruno

Note: See TracTickets for help on using tickets.