Opened 12 years ago

Closed 12 years ago

#96 closed defect (fixed)

mondorestore seg fault + grep errors

Reported by: bruno Owned by: bruno
Priority: high Milestone: 2.2.3
Component: mondo Version: 2.2.0
Severity: critical Keywords:
Cc: alfred.chua@…

Description

I saw the error message "grep invalid options --wPATTERN [FILEs...]" each time mondorestore went through a partitioning of my hard disks. Then, when it got to formatting the swap disk, it crashed out with a segmentation fault. (From "Chua, Alfred" <alfred.chua_at_hp.com>)

Change History (10)

comment:1 Changed 12 years ago by bruno

  • Cc alfred.chua@… added
  • Status changed from new to assigned

grep -w errors are fixed in rev [909]. Will be in 2.2.1

comment:2 Changed 12 years ago by bruno

The seg fault maybe related to debianBTS(379938)?

comment:3 Changed 12 years ago by jsoff

This error also appears on the comparing files screen while comparing from the booted up mondorescue disk.

grep invalid option --x

comment:4 Changed 12 years ago by bruno

Could you use the latest 2.2.1 version of mondo (+ 1.2.1 for mindi and 1.2.2 for mindi-busybox) and report back ?

comment:5 Changed 12 years ago by Chua, Alfred

Hi,

Sorry to have missed your email but I'm out of office from 26-Dec-2006 through 2-Jan-2007 for the holiday season (2 January, 2007 is a public holiday in Singapore). I have limited access to my email and voicemail during this period so please expect slower than normal response times. Thank you for your patience.

HP offices in Singapore will be closed for the holidays from December 26 to 29, 2006. 

In this time of great joy and celebration, I wish you a blessed Christmas and joyous New Year. Happy holidays!

Best wishes for the year 2007,
Alfred Chua

comment:6 Changed 12 years ago by seekgzl

World Of Warcraftwow goldwow goldgold wow aidscheap hotelhealth servicescoins and edalsbar code ccdskannerz bar codes wireless bar code readerbuy bar codebar code scanning systemsap bar codewhich barcode scanner should i buy? Aristo Halifaxgod of war unlockable videos A Secret Revealeddiscounts furniturewalleye worm harnessgold of war cheatsworld warcraft power levelingwrought iron stair railingsValerie confectionsmore than words lyricsstudy abroadsuperman tattoowow power levelingrod iron wall decorbuy wow gold staircase ironStar Tattoossuperman tribal tattooHuge Bedding & Bath Discounts wow gold contrastiron gate in california for saleiron gate in california for salereally cheap wow goldatlanta wrought iron doorswow europe Powerlevelingcomputer deskscheap wow gold word listedwrought iron stair railingsileusautomatic gateseurope wow goldpowerlevelingcheap gold for wowcheap american gold coinscalifornia gold rush stories hangingsForeign stuffdiscounts furniture Study Abroad in Japan Call Centerconstipation treadmillsupermanspiderman?3cheap car insurance companycheap female car insuranceairline tickets for cheapcheap air tickets to londoncheap hotelscheap hotel majorcacheap hotels in paphoscheap hotel niagaracheap reno hotelscheap hotels palm springscheap hotel romenew york cheap hotelvoip conference phonemedical insuranceprojector lamphair lossdna testingCEREBRAL PALSYforeign languagetattooshearing aidsreally cheap wow golddiabetes951054007呼叫中心蜘蛛人一号通中国

comment:7 Changed 12 years ago by bruno

  • Milestone changed from 2.2.1 to 2.2.2

Should be fixed in rev [1294] (for the grep issue at least)

comment:8 Changed 12 years ago by bruno

Now that 2.2.2 is officially published on ftp://ftp.mondorescue.org could you check again if this has been solved for good.

comment:9 Changed 12 years ago by bruno

  • Milestone changed from 2.2.2 to 2.2.3

Now that 2.2.3 is officially published on ftp://ftp.mondorescue.org could you check again if this has been solved for good or not ? I'd like to close the bug asap. (Do not use 2.2.2 it has a nasty bug on bzip2 compression)

comment:10 Changed 12 years ago by bruno

  • Resolution set to fixed
  • Status changed from assigned to closed

This part of the bug is now solved

Note: See TracTickets for help on using tickets.