Opened 6 months ago

Closed 2 months ago

#847 closed defect (worksforme)

mismatch between filelist and afio files

Reported by: Bruno Cornec Owned by: Bruno Cornec
Priority: normal Milestone: 3.3.0
Component: mondo Version: 3.2.2
Severity: normal Keywords:
Cc: guthrie@…

Description

I did a mondo/mindi backup of a linux system, and copied the .iso image to a Windows server on the network.

I'd like to be able to access some files from the archive from a Windows development machine.

I saw an article on how to do this (http://kennywest.blogspot.com/2010/12/restoring-files-manually-from-mondo.html), But it doesn't seem to work with a current backup.

When I grep got my file in filelist's, I find the name in filelist.202, but then opening 202.afio.bz2 is a different set of files.

Change History (2)

comment:1 Changed 6 months ago by Bruno Cornec

Status: newassigned

Would be good to have log files for this (/var/log/mondoarchive.log at least)

comment:2 Changed 2 months ago by Bruno Cornec

Resolution: worksforme
Status: assignedclosed

I'm not able to reproduce that issue with the nbackup I just created with the beta of 3.3.0:

$ grep yss225_registers.bin /mnt/archives/filelist.14*
/mnt/archives/filelist.141:/lib/firmware/yamaha/yss225_registers.bin
$ afio -tv /mnt/archives/141.afio.gz | grep yss225_registers.bin
-rw-r--r--  1 root     root         2912 Apr 16 15:55:50 2018 lib/firmware/yamaha/yss225_registers.bin.z

So the file is indeed at the place where it should be.

Note: See TracTickets for help on using tickets.