Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#752 closed defect (fixed)

opensuse 13.1 does not build

Reported by: fschuett Owned by: bruno
Priority: normal Milestone: 3.0.4
Component: mondo Version: 3.0.4
Severity: normal Keywords:
Cc:

Description

Hallo, I am using mondorescue with openSUSE Linux 13.1. I do still use the 12.3 version, as the 13.1 version is not there. I assume it does not build.

Change History (6)

comment:1 Changed 5 years ago by bruno

  • Milestone changed from 3.2.0 to 3.0.6
  • Status changed from new to assigned

There is indeed currently a build issue:

[opensuse-13.1-x86_64] Problem: newt-devel-0.52.14-9.1.2.x86_64 requires python-devel, but this requirement cannot be provided
[opensuse-13.1-x86_64]   uninstallable providers: python-devel-2.7.5-8.3.1.x86_64[openSUSE-13.1-1.10]
[opensuse-13.1-x86_64]                    python-devel-2.7.5-8.3.1.i586[repo-oss]
[opensuse-13.1-x86_64]                    python-devel-2.7.5-8.3.1.x86_64[repo-oss]
[opensuse-13.1-x86_64]                    python-devel-2.7.6-8.10.1.i586[repo-update]
[opensuse-13.1-x86_64]                    python-devel-2.7.6-8.6.1.i586[repo-update]
[opensuse-13.1-x86_64]                    python-devel-2.7.6-8.10.1.x86_64[repo-update]
[opensuse-13.1-x86_64]                    python-devel-2.7.6-8.6.1.x86_64[repo-update]
[opensuse-13.1-x86_64]  Solution 1: deinstallation of patterns-openSUSE-minimal_base-conflicts-13.1-13.6.1.x86_64
[opensuse-13.1-x86_64]  Solution 2: do not install newt-devel-0.52.14-9.1.2.x86_64
[opensuse-13.1-x86_64]  Solution 3: do not install newt-devel-0.52.14-9.1.2.x86_64
[opensuse-13.1-x86_64]  Solution 4: break newt-devel-0.52.14-9.1.2.x86_64 by ignoring some of its dependencies
[opensuse-13.1-x86_64] 
[opensuse-13.1-x86_64] Choose from above solutions by number or cancel [1/2/3/4/c] (c): c

comment:2 Changed 5 years ago by fschuett

From how I understand the pattern system, Solution 1 should be the way to go since you need python-devel and python is blocked by the patterns-openSUSE-minimal_base-conflicts.

comment:3 Changed 5 years ago by bruno

  • Milestone changed from 3.0.6 to 3.2.0
  • Resolution set to fixed
  • Status changed from assigned to closed

Used solution 1 and now indeed mondo is able to build, so you have a test version for 3.2.0 available.

comment:4 Changed 5 years ago by bruno

Both x86_64 and i386 versions have been now made.

comment:5 Changed 5 years ago by bruno

  • Milestone changed from 3.2.0 to 3.0.4

And I have also made stable version available for 3.0.4 (and mindi 2.1.6)

comment:6 Changed 5 years ago by fschuett

Thank you very much. Right now I'm testing 3.0.4 and it runs fine.

Note: See TracTickets for help on using tickets.