Ticket #751 (closed defect: fixed)

Opened 3 years ago

Last modified 15 months ago

SL4540 / Proliant dl360 GEN8 ---> Smartarray b120i closed drivers not working with mondorescue

Reported by: nicolasroyo Owned by: bruno
Priority: normal Milestone: 3.2.2
Component: mondo Version: 3.0.4
Severity: normal Keywords: proliant mondorescue b120i
Cc:

Description

Hi there!

We have many proliant servers and mondorescue was proposed as a bare-metal backup solution.

After reading and knowing a bit more about mondorescue, I install last versions of mondorescue and started working: mondo-3.0.4-1.rhel6.x86_64 mindi-busybox-1.18.5-3.rhel6.x86_64 mindi-2.1.7-1.rhel6.x86_64

As you may know OS is RH 6.4.

The problem is.........the smartarray controller

this servers have two controllers: P420 (p series controller) ----> 12 disks for data raid B120i (e series controllers) ------> 2 disks for OS raid

P420 is a very solid controller and uses kernel's hpsa drivers (even cciss)

However, B120i (OS disks) uses some kind of 'closed' driver (hpvsa) which is not letting me nor buld it as a module nor with the kernel itself into mindi.

Therefore, mindi won´t see the raid (it will only see 2 disks individually, not one logicall unit).

Backup is doing it fine, the problem comes with the restore, the only possible procedure that is working is setting to AHCI/SATA mode (software raid) and installing it on single disks, rather than on hardware raid. If I make the attempt to restore ir on raid mode, kernel with panic with some 'tainted kernel' error messages, relating to this proprietary driver not being accepted by the new kernel.

Has anyone every had performed a full restore on this b120i controller series with mondorescue?

I hope you can point me in the right direction, since im totally clueless of what to do to restore into raid mode (and nor into ahci/sata mode).

Thanks for your time! Nicolas.-

References: RH not supporting drivers:  https://access.redhat.com/articles/118133

HP drivers:  http://h20566.www2.hp.com/portal/site/hpsc/template.PAGE/public/psi/swdHome/?sp4ts.oid=5293151&spf_p.tpst=swdMain&spf_p.prp_swdMain=wsrp-navigationalState%3DswEnvOID%253D4103%257CswLang%253D%257Caction%253DlistDriver&javax.portlet.begCacheTok=com.vignette.cachetoken&javax.portlet.endCacheTok=com.vignette.cachetoken

Attachments

mondoarchive.log Download (293.3 KB) - added by nicolasroyo 3 years ago.
mondorestore.log Download (94.2 KB) - added by nicolasroyo 3 years ago.

Change History

comment:1 Changed 3 years ago by bruno

  • Status changed from new to assigned

Try to edit /etc/mindi/mindi.conf and add a line:

FORCE_MODS="hpvsa"

and let us know if that solves your issue. I'll then add it to the least of supported modules for HDD.

comment:2 Changed 3 years ago by nicolasroyo

Hi Bruno,

Thanks for your time! After adding the module hpvsa to mindi.conf, rebulding boot iso again, and launched it again (Bios settings for using smart array) im still seeing that fdisk its showing them as, again, 2 individual units (and not 1 logical unit). Ive confirmed with lsmod that 'hpvsa' is being loaded.

On another test, Ive tried building mindi.iso not with 'hpvsa' module, but with the rpm drivers for b120i --->  http://h20565.www2.hp.com/portal/site/hpsc/template.PAGE/public/psi/swdDetails/?sp4ts.oid=5293151&spf_p.tpst=swdMain&spf_p.prp_swdMain=wsrp-navigationalState%3Didx%253D%257CswItem%253DMTX_68917eeb12fe4d2d940836dc90%257CswEnvOID%253D4103%257CitemLocale%253D%257CswLang%253D%257Cmode%253D%257Caction%253DdriverDocument&javax.portlet.begCacheTok=com.vignette.cachetoken&javax.portlet.endCacheTok=com.vignette.cachetoken

However, with both tests on mindi, the disks are still not being showed as 1 logical unit.

What else do you think I can try? Thank! Nicolas Ernesto Royo

comment:3 Changed 3 years ago by bruno

In order for us to help, we'd need the 2 log files (mondoarchive.log and mondorestore.log) in order to understand better what happens.

Changed 3 years ago by nicolasroyo

Changed 3 years ago by nicolasroyo

comment:4 Changed 3 years ago by nicolasroyo

Hi Bruno, Im attaching: mondorestore.log ---> taken from the server where i tried to restore it (successful restore, unable to boot) mondoarchive ---> taken from the server, where it was created the backup.

Ive got dmesg and messages logs just in case.

Thanks again.-

comment:5 Changed 2 years ago by bruno

Sorry for the late answer.

So the driver is indeed loaded at restore time. So maybe we miss a configuration file or somethign similar to have it configure the system correctly.

Could you provide the content of rpm -ql hpvsa ? I'd like to see if other files are provided that I should backup and restore as well to make it work properly.

comment:6 Changed 2 years ago by Atonner

Bruno:

hpvsa rpm includes /etc/depmod.d/hpvsa.conf

root@<sanitized> modprobe.d]# yum list installed |grep hpvsa
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
kmod-hpvsa.x86_64                    1.2.8-160.rhel6u4                  @anaconda-DD-0/6.4
[root@<sanitized> modprobe.d]# rpm -q --list kmod-hpvsa.x86_64
/etc/depmod.d/hpvsa.conf
/lib/modules/2.6.32-358.el6.x86_64
/lib/modules/2.6.32-358.el6.x86_64/extra
/lib/modules/2.6.32-358.el6.x86_64/extra/hpvsa
/lib/modules/2.6.32-358.el6.x86_64/extra/hpvsa/hpvsa.ko
[root@<sanitized> modprobe.d]# more /etc/depmod.d/hpvsa.conf
override hpvsa 2.6.32-* weak-updates/hpvsa
[root@<sanitized> modprobe.d]# 

For the record, I'm injecting ONLY hpvsa.ko into initrd on a kickstart disk (not the depmod.d file) - and when I force the load in %pre the module loads, correctly displaying only one disk (this is on SL4540G8, 15x3 nodes) - issue is ++ YOU MUST blacklist ahci in the kernel init line in (grub/lilo/efiboot) -- if ahci loads first you will get the split view.

Last edited 18 months ago by bruno (previous) (diff)

comment:7 Changed 18 months ago by bruno

  • Milestone changed from 3.0.5 to 3.2.1

So the original reporter should try to disable the load of ahci by using DENY_MODS="ahci" in his /etc/mindi/mindi.conf file.

I have also added /etc/depmod.d/hpvsa.conf as part of minimal.conf in rev [3355] as it may provide additional info at the driver required at restore time.

Nicolas, could you try with the 3.2.1 version just out today.

comment:8 Changed 15 months ago by bruno

  • Status changed from assigned to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.