Opened 4 years ago

Closed 4 years ago

Last modified 3 weeks ago

#718 closed defect (fixed)

USB keyboard, usb stick not working - missing driver - HP ML Server

Reported by: stefanbauer Owned by: bruno
Priority: highest Milestone: 3.0.5
Component: mondo Version: 3.0.4
Severity: critical Keywords: hp ml, usb problem, keyboard
Cc:

Description

With recent hardware - usb devices are not working in the restore process.

Right after the initramfs and kernel is loaded, usb is gone. We've discovered this issue on a HP ML310e Gen8 server in our lab.

Problem is the missing xhci-hcd module in the initramfs. A fix is to add xhci-hcd to /usr/sbin/mindi in the USB_MODS variable.

Please include this in the next release!

cheers

stefan

Change History (3)

comment:1 Changed 4 years ago by bruno

  • Resolution set to fixed
  • Status changed from new to closed

Thanks for your feedback, this is fixed in rev [3198]. Will be in next mindi.

Last edited 4 years ago by bruno (previous) (diff)

comment:2 Changed 4 years ago by bruno

in rev [3245] for branch 3.0 and [3198] for branch 3.2 to allow for a 3.0.5 if needed.

comment:3 Changed 6 months ago by bruno

This problem has also been seen on a DL 380 Gen9 running MondoRescue? 3.0.4 where without loading xhci-hcd, the server wasn't recognizing the Virtual Media CD at restore time (which wasn't the case with a DL 380 Gen8).

Adding that driver to the list solved the issue.

So it seems that the new generation is attaching the iLO virtual media to another HUB than what was done on the previous generation.

Workaround for 3.0.4 line, add xhci-hcd to the USB_MODS line in mindi or to the FORCE_MODS line in mindi.conf.

Last edited 3 weeks ago by bruno (previous) (diff)
Note: See TracTickets for help on using tickets.