Opened 5 years ago

Closed 3 years ago

#653 closed defect (worksforme)

mondorestore: error while loading shared libraries: libnewt.so.0.52 on booting from CD

Reported by: asari Owned by: bruno
Priority: normal Milestone: 3.0.5
Component: mondo Version: 3.0.2
Severity: normal Keywords:
Cc:

Description (last modified by bruno)

I'm trying mondorescue and mondorestore on Ubuntu Linux 10.04.2 LTS (x86_64).

Successfully created an .iso file, but after booting using the .iso (expert mode), I get following error message:

# mondorestore
mondorestore: error while loading shared libraries: libnewt.so.0.52: cannot open shared object file: No such file or directory

It looks like that /usr/bin/mondorestore should have built with static linking against libnewt.a but has not, or, the .iso file should have included /usr/lib/libnewt.so.0.52 (and other shared libraries) but has not.

# ldd /usr/bin/mondorestore
	linux-vdso.so.1 => (0x00007fff2b9ff000)
	libnewt.so.0.52 => not found
	libpthread.so.0 => /lib/libpthread.so.0 (0x00007f3e5bef000)
	libc.so.6 => /lib/libc.so.6 (0x00007f3e586b000)
	/lib64/ld-linux-x86-64.so.2 (0x00007f3eb5e14000)
#
# find / -name *newt*
# ( no output lines )

Attachments (3)

mondoarchive.log (309.9 KB) - added by asari 5 years ago.
mondorestore.log (40.9 KB) - added by asari 5 years ago.
deps.log (31.5 KB) - added by asari 5 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 Changed 5 years ago by bruno

which versions are you using ? Please follow the recommandations of the web site and attach your log files (archive and restore) for any help.

Changed 5 years ago by asari

Changed 5 years ago by asari

comment:2 Changed 5 years ago by asari

Thanks bruno,

I believe I was using 3.0.2 from ftp://ftp.mondorescue.org/ubuntu/10.04/ . ( I can find "deb ftp://ftp.mondorescue.org//ubuntu 10.04 contrib" in /etc/apt/sources.list . )

Attached log files.

comment:3 Changed 5 years ago by bruno

  • Description modified (diff)

comment:4 Changed 5 years ago by bruno

  • Status changed from new to assigned

Strange as mindi does find the deps for mondorestore as per the log file, especially the newt libs:

/usr/sbin/mondorestore
/usr/lib/libnewt.so.0.52
/usr/lib/libnewt.so.0.52
/usr/lib/libnewt.so.0.52.10
/lib/libpthread.so.0
/lib/libpthread.so.0
/lib/libpthread-2.11.1.so
/lib/libc.so.6
/lib/libc.so.6
/lib/libc-2.11.1.so
/lib/libslang.so.2
/lib/libslang.so.2
/lib/libslang.so.2.2.2
/lib64
/lib/ld-linux-x86-64.so.2
/lib/ld-linux-x86-64.so.2
/lib/ld-2.11.1.so
/lib/libdl.so.2
/lib/libdl.so.2
/lib/libdl-2.11.1.so
/lib/libm.so.6
/lib/libm.so.6
/lib/libm-2.11.1.so

Are the newt libs indeed locate there on your Ubuntu LTS ? generally these libs come with mondorestore as part of the second step of the boot, once the MondoRecue? media is mounted.

I'm afraid this is linked to modifications on your distro wrt /lib64 symlinks and maybe /usr/lib hosting formely libs under /lib no ? (this is a known issue reported on Fedora 17 which may affect distros that are moving from /lib to /usr/lib). However I'd expext a stable LTS to NOT do that, so I'm really unsure.

Ubuntu 10.04 has been working for a long time normally.

could your run:

/usr/sbin/mindi --locatedeps /usr/sbin/mondorestore

and give me the result. And also

sh -x /usr/sbin/mindi --locatedeps /usr/sbin/mondorestore 2>&1 /tmp/deps.log

and send to me the /tmp/deps.log

Thanks in advance.

Changed 5 years ago by asari

comment:5 Changed 5 years ago by asari

Thanks bruno (again).

I didn't know the "/lib -> /usr/lib" problem, but I don't think that such a movement has happend. Both /lib and /usr/lib exist and each of them has its contents.

$ ls -ld /lib /lib64 /usr/lib /usr/lib64
drwxr-xr-x 14 root root 12288 2011-07-01 16:36 /lib
lrwxrwxrwx  1 root root     4 2011-05-30 16:04 /lib64 -> /lib
drwxr-xr-x 65 root root 20480 2012-10-24 00:33 /usr/lib
lrwxrwxrwx  1 root root     3 2011-05-30 16:04 /usr/lib64 -> lib

and libnewt.so found (I think) normally:

$ sudo find / -name "libnewt.so*" -ls
1056095    0 lrwxrwxrwx   1 root     root           18 May 30  2011 /usr/lib/libnewt.so.0.52 -> libnewt.so.0.52.10
1056091   88 -rw-r--r--   1 root     root        89752 Feb 24  2010 /usr/lib/libnewt.so.0.52.10

Anyway I ran some deps commands.

$ sudo /usr/sbin/mindi --locatedeps /usr/sbin/mondorestore
/usr/lib/libnewt.so.0.52
/usr/lib/libnewt.so.0.52
/usr/lib/libnewt.so.0.52.10
/lib/libpthread.so.0
/lib/libpthread.so.0
/lib/libpthread-2.11.1.so
/lib/libc.so.6
/lib/libc.so.6
/lib/libc-2.11.1.so
/lib/libslang.so.2
/lib/libslang.so.2
/lib/libslang.so.2.2.2
/lib64
/lib/ld-linux-x86-64.so.2
/lib/ld-linux-x86-64.so.2
/lib/ld-2.11.1.so
/lib/libdl.so.2
/lib/libdl.so.2
/lib/libdl-2.11.1.so
/lib/libm.so.6
/lib/libm.so.6
/lib/libm-2.11.1.so

... and attached deps.log . Note that I used bash instead of sh to avoid some errors ( like "SIGTERM: bad trap" ).

By the way, I found from my bash history that my command lines were below:

$ sudo env SSH_AUTH_SOCK=$SSH_AUTH_SOCK sshfs asari@HOST.EXAMPLE.ORG:PATH/TO/MONDO /tmp/test
$ sudo mondoarchive -Oi -L -N -p EXAMPLE -d /tmp/test -E /tmp -s 4200m
$ sudo mondoarchive -v
mondoarchive v3.0.2-r3018
See man page for help

comment:6 Changed 4 years ago by bruno

I have made some changed recently that could help with your issue. Would you mind testing the new beta under ftp://ftp.mondorescue.org/test for mondo 3.0.4 and mindi 2.1.6 and report back agaib please ?

comment:7 Changed 3 years ago by bruno

Seems similar to #754

comment:8 Changed 3 years ago by bruno

  • Resolution set to worksforme
  • Status changed from assigned to closed

Closing as I'm unable to reproduce it. Feel free to reopen if this is still blocking.

Note: See TracTickets for help on using tickets.