Opened 7 years ago

Closed 7 years ago

#630 closed defect (fixed)

Exclusion are not validated

Reported by: presta.systeme Owned by: Bruno Cornec
Priority: highest Milestone: 3.0.2
Component: mondo Version: 3.0.1
Severity: blocker Keywords:
Cc:

Description

Hello,

we encounter a problem with mondorescue. whe launch this command : /root/admin/lnx_mondo_bkp_system.sh -m i -serv pmk1tec10 -e /sybase /usr/local/sybase154/IQ-15_4/logfiles /usr/local/userdata /iq_backup /iq_temp /iq_data

or this : /root/admin/lnx_mondo_bkp_system.sh -m i -serv pmk1tec10 -e /sybase /usr/local/sybase154/IQ-15_4/logfiles /usr/local/userdata /dev/mapper/VG_CCISS_IQ-LV_IQ_BKP /dev/mapper/VG_CCISS_IQ_2-LV_IQ_TEMP /dev/mapper/VG_SAN_PFR1SIQ4_2-LV_IQ_DATA

or this : /root/admin/lnx_mondo_bkp_system.sh -m i -serv pmk1tec10 -e /sybase /usr/local/sybase154/IQ-15_4/logfiles /dev/mapper/VG_CCISS_IQ_2-LV_IQ_TEMP /dev/mapper/mpathk /dev/mapper/mpathd /dev/mapper/mpathj

The problem is : exclusion are not taken :(

Versions:

afio-2.5-1.rhel6.x86_64 buffer-1.19-4.rhel6.x86_64 mindi-busybox-1.7.3-2.rhel6.x86_64 mindi-2.1.2-1.rhel6.x86_64 mondo-3.0.1-1.rhel6.x86_64

OS : RHEL 6.2 with multipath. (no error on other OS)

Attachments (2)

lnx_mondo_bkp_system.sh (6.4 KB) - added by presta.systeme 7 years ago.
mondoarchive.log (815.7 KB) - added by presta.systeme 7 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 7 years ago by Bruno Cornec

Version: 3.0.1

1/ you shoud use mindi-busyboe 1.18.5 to be coherent 2/ you should use mondo 3.0.2 for the same reason 3/ without the log, nor the script, it's difficult to be sure, but I think you need to re-read the man page of mondoarchive, as the separator for exclude dirs changed and is now '|'.So retry using it between your dirs:

-e /sybase|/usr/local/sybase154/IQ-15_4/logfiles|/dev/mapper/VG_CCISS_IQ_2-LV_IQ_TEMP|/dev/mapper/mpathk|/dev/mapper/mpathd|/dev/mapper/mpathj

comment:2 Changed 7 years ago by presta.systeme

Hi,

I upgraded versions and same problem :( See enclosed files (log + custom script to call mondorescue).

Changed 7 years ago by presta.systeme

Attachment: lnx_mondo_bkp_system.sh added

Changed 7 years ago by presta.systeme

Attachment: mondoarchive.log added

comment:3 Changed 7 years ago by Bruno Cornec

Milestone: 3.0.2
Resolution: fixed
Status: newclosed

So with the log, I'm now sure:

you need to re-read the man page of mondoarchive, as the separator for exclude dirs changed and is now '|'.So retry using it between your dirs:

-e /sybase|/usr/local/sybase154/IQ-15_4/logfiles|/dev/mapper/VG_CCISS_IQ_2-LV_IQ_TEMP|/dev/mapper/mpathk|/dev/mapper/mpathd|/dev/mapper/mpathj
Note: See TracTickets for help on using tickets.