Opened 7 years ago

Closed 6 years ago

#602 closed defect (fixed)

Mondo recovery problem from ISOes archive on OEL 5.4

Reported by: mkproper Owned by: bruno
Priority: highest Milestone: 3.0.3
Component: mondo Version: 3.0.1
Severity: normal Keywords: OEL 5.4
Cc:

Description

Hello All,

I need your assist to do the recovery data procedure using mondo & mindi.

I have IBM blade center connected to disk shelf via sas. I installed the OEL 5.4: -bash-3.2# rpm -qf /etc/redhat-release enterprise-release-5-0.0.20

-bash-3.2# cat /etc/redhat-release Red Hat Enterprise Linux AS release 4 (Nahant Update 1)

-bash-3.2# cat /etc/issue Enterprise Linux Enterprise Linux Server release 5.4 (Carthage) Kernel \r on an \m

Linux XXXXXXXXXXXXXXXXXX.ru 2.6.18-164.el5 #1 SMP Thu Sep 3 04:15:13 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux

I tried to install o lot of stable versions and its combination. I do mondoarchive not any problem. BUT when I try to recovery in boot phase I got " sh: applet not found Please press Enter to activate this console" After that this message did not help any my activities for activate console

I corrected the follow parameters in any case:

  1. MINDI_ADDITIONAL_BOOT_PARAMS in /etc/mindi/mindi.conf file

MINDI_ADDITIONAL_BOOT_PARAMS="devfs=nomount noresume selinux=0 barrier=off udevtimeout=10 acpi=off"

  1. FORCE_MODS in /usr/sbin/mindi file

FORCE_MODS="diskdumplib diskdump mptbase mptscsi mptspi mptsas mptscsih ata_piix crc32 mii pcnet32 sunrpc nfs nfs_scl lockd loop"

When I install beta version rpm -qa | grep -e afio -e buffer -e mindi -e mondo mindi-2.1.1-0.20120124180454.rhel5 buffer-1.19-4.rhel5 afio-2.5-1.rhel5 mondo-3.0.1-0.20120124180454.rhel5 mindi-busybox-1.18.5-1.rhel5

I do mindi.iso and try to boot from it I see another messages (see attached file) but in during boot phase server do not stop and after some messages reboot itself. Mindi.log file in attachment for undestanding

regards,

Dmitry

Pls help me to solve this problem.

Attachments (4)

mindi.log (175.4 KB) - added by mkproper 7 years ago.
booting screen only (beta version).docx (427.3 KB) - added by mkproper 7 years ago.
booting screen for any stable versions.docx (153.2 KB) - added by mkproper 7 years ago.
mondoarchive.7z (176.3 KB) - added by mkproper 7 years ago.
the mondoarchive log file (dc -07 Apr 2012)

Download all attachments as: .zip

Change History (16)

Changed 7 years ago by mkproper

Changed 7 years ago by mkproper

Changed 7 years ago by mkproper

comment:1 Changed 7 years ago by mkproper

I tried to leave less loading modules like this

FORCE_MODS="mptbase mptscsi mptspi mptsas mptscsih ata_piix"

return to latest stable version

mondo-3.0.1-1.rhel5 mindi-busybox-1.18.5-1.rhel5 mindi-2.1.1-1.rhel5

and I got the same error when I try to boot from first ISO disk

sh: applet not found Please press Enter to activate this console …..

comment:2 Changed 7 years ago by mkproper

anybody helps me or clarify what I do not correct or something else. Thanks for quick responce

comment:3 Changed 7 years ago by bruno

Do not use acpi=off

Provide your log file /var/log/mondoarchive.log, and best the /var/log/mondorestore.log file if you can.

It seems there is an issue with your busybox env, but can't comment more without the archive log file.

comment:4 Changed 7 years ago by mkproper

Thank in advance Bruno I did not get the any responce.

I need to solve my problem ASAP I used mondo many times and I know that it works but I've not met yet.

I return to latest stable version: -bash-3.2# rpm -qa | grep -e mindi -e mondo -e buffer -e afio

mindi-busybox-1.18.5-1.rhel5 mondo-3.0.1-0.20120124180454.rhel5 afio-2.5-1.rhel5 mindi-2.1.1-0.20120124180454.rhel5 buffer-1.19-4.rhel5

and I got the error message in booting phase and not more ......." sh: applet not found Please press Enter to activate this console"

I do not continue to booting after this message. I expect to solve this problem faster that a lot of problem for beta version. I try to take a part "/usr/sbin/mindi" and I'm going to execute the building mindi.iso step by step because I think this file cause of my problems. if i undestand right the boot scripts could not sh find command am I right ? Have you find this messages yet ? What do you suggest to me ? I tried to install mindi-busybox-1.7.3 and got same message.

Changed 7 years ago by mkproper

the mondoarchive log file (dc -07 Apr 2012)

comment:5 Changed 7 years ago by mkproper

Hello Bruno,

I done mondoarchive backup again and uploaded the new mondo archive file (see mondoarchive.7z attachment). I saw the follow messages in the end of backup

............. ---evalcall---1--- Running mkisofs to make ISO #10 ---evalcall---2--- TASK: [] 98% done; 0:10 to go ---evalcall---E--- ---evalcall---1--- Running mkisofs to make ISO #10 ---evalcall---2--- TASK: [] 99% done; 0:05 to go ---evalcall---E--- Call to mkisofs to make ISO (ISO #10) ...OK Done. Done. Backup and/or verify ran to completion. Everything appears to be fine. /var/cache/mindi/mondorescue.iso, a boot/utility CD, is available if you want it Data archived OK. Mondoarchive ran OK. See /var/log/mondoarchive.log for details of backup run. Execution run ended; result=0 Type 'less /var/log/mondoarchive.log' to see the output log You have mail in /var/spool/mail/root

I remind to you that I use follow command:

#!/bin/sh MONDO=/usr/sbin/mondoarchive BackupName?=fb_hostname -s_date +%Y'-'%m'-'%d'_'%H'-'%M # mondoarchive -O -i -H -N -0 -s 20g \ -d /mnt/backup_nfs/mondo/images \ -p $BackupName? \ -S /mnt/backup_nfs/mondo/scratch \ -T /mnt/backup_nfs/mondo/tmp \ -I / \ -E "/u01 /u02 /u03 /u04 /u05 /mnt /var /tmp" \

and I'd like to give the link to mondoarchive.iso that you can checked included files in iso disk and you seen youself this messages "sh: applet not found"

http://files.mail.ru/DTK1WD

I'm looking forward to wait to any ideas to solve it problem. thank in advance

regards,

Dmitry

comment:7 Changed 7 years ago by mkproper

Bruno,

I add that I corrected MINDI_ADDITIONAL_BOOT_PARAMS as you said ...

-bash-3.2# cat /etc/mindi/mindi.conf # # Example of mindi configuration file # # $Id$ #

FORCE_MODS="mptbase mptsas mptscsih" DENY_MODS="hpsa"

# # EXTRA_SPACE=80152 # increase if you run out of ramdisk space # BOOT_SIZE=32768 # size of the boot disk

MINDI_ADDITIONAL_BOOT_PARAMS="devfs=nomount noresume selinux=0 barrier=off udevtimeout=10"

BUT it'did not solve my problem

regards,

Dmitry

comment:8 Changed 7 years ago by bruno

Stable version are not the one under the test directories with dates in their names.

please use: ftp://ftp.mondorescue.org/rhel/5/x86_64/mindi-2.1.1-1.rhel5.x86_64.rpm ftp://ftp.mondorescue.org/rhel/5/x86_64/mindi-busybox-1.18.5-1.rhel5.x86_64.rpm ftp://ftp.mondorescue.org/rhel/5/x86_64/mondo-3.0.1-1.rhel5.x86_64.rpm

Then remak a full cycle, and attach again the log files (archieve + backup) if the problem is still there.

Be aware of #600.

comment:9 Changed 7 years ago by mkproper

ear Bruno,

I expect any responce but NOT this. I hope you can help me to find problem not as IT staff from the 1st line support from India :-(

P.S. I check again the statement my system:

-bash-3.2# date Wed Apr 11 22:24:47 GMT-4 2012 -bash-3.2# rpm -qa | grep -e "mindi" -e "mondo" mindi-debuginfo-2.1.1-1.rhel5 mindi-busybox-debuginfo-1.18.5-1.rhel5 mindi-busybox-1.18.5-1.rhel5 mondo-3.0.1-1.rhel5 mindi-2.1.1-1.rhel5

and I see the follow message " sh: applet not found Please press Enter to activate this console" in case use stable version as you said

Regards,

Dmitry

comment:10 Changed 7 years ago by bruno

I'm sorry to sound like that, but if you read this bug report and understand something, then fine for you. However, I don't. As I'm the one maintaining the tool, if I don't understand your BR, there is 0 chance it will be fixed.

You have *not* read the documentation correctly, because for example you use a wrong -E option syntax (you should use '|' to separate directories to exclude).

Read the mailing list before posting, and you'll know that the -I option is *not* to be used.

You mindi env is strange anyway:

./bin:
total 18468
-rw-r--r--   1 root root        0 Apr  7 23:41 ˆW@@àŒ@8@@@@@@ÀÀ@@@@ŽgŽg
drwxr-x---   2  601 users    2048 Apr  7 23:42 .
drwxr-x---  15  601 users    1024 Apr  7 23:42 ..

also under /usr/bin, you have lots of files with the same strange size:

./usr/bin:
total 30055
drwxr-x---   2  601 users   3072 Apr  7 23:42 .
drwxr-x---   7  601 users   1024 Apr  7 23:42 ..
lrwxrwxrwx   1  601 users     17 Apr  7 23:41 [ -> ../../bin/busybox
lrwxrwxrwx   1 root root      17 Apr  7 23:41 [[ -> ../../bin/busybox
-rwxr-xr-x 124 root root  431136 Apr  7 23:41 add-shell
lrwxrwxrwx   1 root root      17 Apr  7 23:41 ar -> ../../bin/busybox
-rwxr-xr-x 124 root root  431136 Apr  7 23:41 arping
lrwxrwxrwx   1 root root      14 Apr  7 23:42 awk -> ../../bin/gawk
lrwxrwxrwx   1  601 users     17 Apr  7 23:41 basename -> ../../bin/busybox
-rwxr-xr-x 124 root root  431136 Apr  7 23:41 beep
lrwxrwxrwx   1  601 users     17 Apr  7 23:41 bunzip2 -> ../../bin/busybox
-rwxr-xr-x 124 root root  431136 Apr  7 23:41 bzcat
lrwxrwxrwx   1 root root      17 Apr  7 23:41 bzip2 -> ../../bin/busybox
-rwxr-xr-x 124 root root  431136 Apr  7 23:41 cal
-rwxr-xr-x 124 root root  431136 Apr  7 23:41 chat
-rwxr-xr-x 124 root root  431136 Apr  7 23:41 chpst
-rwxr-xr-x 124 root root  431136 Apr  7 23:41 chrt
lrwxrwxrwx   1  601 users     17 Apr  7 23:41 chvt -> ../../bin/busybox
lrwxrwxrwx   1 root root      17 Apr  7 23:41 cksum -> ../../bin/busybox
lrwxrwxrwx   1  601 users     17 Apr  7 23:41 clear -> ../../bin/busybox
lrwxrwxrwx   1  601 users     17 Apr  7 23:41 cmp -> ../../bin/busybox
-rwxr-xr-x 124 root root  431136 Apr  7 23:41 comm
-rwxr-xr-x 124 root root  431136 Apr  7 23:41 crontab
-rwxr-xr-x 124 root root  431136 Apr  7 23:41 cryptpw
lrwxrwxrwx   1  601 users     17 Apr  7 23:41 cut -> ../../bin/busybox
-rwxr-xr-x 124 root root  431136 Apr  7 23:41 dc
lrwxrwxrwx   1  601 users     17 Apr  7 23:41 deallocvt -> ../../bin/busybox
lrwxrwxrwx   1 root root      17 Apr  7 23:41 diff -> ../../bin/busybox
lrwxrwxrwx   1  601 users     17 Apr  7 23:41 dirname -> ../../bin/busybox
lrwxrwxrwx   1 root root      17 Apr  7 23:41 dos2unix -> ../../bin/busybox
lrwxrwxrwx   1  601 users     17 Apr  7 23:41 du -> ../../bin/busybox
-rwxr-xr-x 124 root root  431136 Apr  7 23:41 dumpleases
lrwxrwxrwx   1  601 users     17 Apr  7 23:41 env -> ../../bin/busybox
-rwxr-xr-x 124 root root  431136 Apr  7 23:41 envdir
-rwxr-xr-x 124 root root  431136 Apr  7 23:41 envuidgid
-rwxr-xr-x 124 root root  431136 Apr  7 23:41 ether-wake
-rwxr-xr-x 124 root root  431136 Apr  7 23:41 expand
lrwxrwxrwx   1  601 users     17 Apr  7 23:41 expr -> ../../bin/busybox
lrwxrwxrwx   1 root root      17 Apr  7 23:41 fdformat -> ../../bin/busybox
lrwxrwxrwx   1 root root      17 Apr  7 23:41 fgconsole -> ../../bin/busybox
lrwxrwxrwx   1  601 users     17 Apr  7 23:41 find -> ../../bin/busybox
lrwxrwxrwx   1 root root      17 Apr  7 23:41 flock -> ../../bin/busybox
-rwxr-xr-x 124 root root  431136 Apr  7 23:41 fold
lrwxrwxrwx   1  601 users     17 Apr  7 23:41 free -> ../../bin/busybox
-rwxr-xr-x 124 root root  431136 Apr  7 23:41 ftpget
-rwxr-xr-x 124 root root  431136 Apr  7 23:41 ftpput
-rwxr-xr-x 124 root root  431136 Apr  7 23:41 fuser
lrwxrwxrwx   1 root root      14 Apr  7 23:42 gawk -> ../../bin/gawk
-rwxr-xr-x 124 root root  431136 Apr  7 23:41 hd
lrwxrwxrwx   1  601 users     17 Apr  7 23:41 head -> ../../bin/busybox
-rwxr-xr-x 124 root root  431136 Apr  7 23:41 hexdump
lrwxrwxrwx   1  601 users     17 Apr  7 23:41 hostid -> ../../bin/busybox
lrwxrwxrwx   1  601 users     17 Apr  7 23:41 id -> ../../bin/busybox
-rwxr-xr-x 124 root root  431136 Apr  7 23:41 ifplugd
-rwxr-xr-x 124 root root  431136 Apr  7 23:41 install
-rwxr-xr-x 124 root root  431136 Apr  7 23:41 ipcrm
-rwxr-xr-x 124 root root  431136 Apr  7 23:41 ipcs

they seem to be herd linked to each other. And you have such hard links all over the place. So I highly doubt that your original env is clean.

or maybe we have a bg somewhere preventing us to create a correct boot media on OEL.

As for the nature of my answer, consider I do all that on my free time, so as I don't have time to pass on badly reported problems, it may take a lot of time to fix this one.

If you want timely answer, buy a support contract. We have reference for firms delivering it on our Web site. If you use Oracle, you probably have ressources to do so.

Last edited 7 years ago by bruno (previous) (diff)

comment:11 Changed 7 years ago by mkproper

Bruno,

First of all I'd like to say many thank. "-E" option is artefact :-). I try to check all yours ideas. Note when I need to make fist backup of my system very quicly and I have to analyze the structure mindi/mondorescue files in ISO image. The fist step of booting is correct (initrd.img/syslinux) my problem is located on second stage of booting (after executing init/linuxrc script and mount root with rw option in ram disk). I take Linux Lite distro include busybox move all mondo scripts to it and It works only this case, not execute mondoaarchive script which run mindi script for making easy booting distro. But I'd like to do using mondorescue script w/o any additional work only in future.

BRs,

Dmitry

P.S.

I see that you work as full altruist. You are one of best and i'm sure that your previous phase was not yours,

comment:12 Changed 6 years ago by bruno

  • Milestone changed from 3.0.2 to 3.0.3

PLease check that your problem is fixed with 3.0.2

comment:13 Changed 6 years ago by bruno

  • Resolution set to fixed
  • Status changed from new to closed

Please reopen if not fixed with 3.0.2

Note: See TracTickets for help on using tickets.