Opened 6 years ago

Closed 6 years ago

#525 closed defect (fixed)

Nuke failure on Ubuntu 10.04LTS

Reported by: richardder Owned by: bruno
Priority: normal Milestone: 3.0.0
Component: mondo Version: 2.2.9.7
Severity: normal Keywords:
Cc:

Description

Hi, I have installed Mondo on Ubuntu 10.04 LTS (Asus M4A78LT-M LE) and have backed up to 3 DVDs. I have then installed an identical blank drive (1TB) and attempted to restore by 'nuke'. It seems to read DVD #1 although there is no HD light activity and eventually fails with 'out of memory: kill process 8075 (mondorestore) score 450 or a [newline] ild'.

Any guidance would be appreciated

Bug refiled as requested with archive log. Restore log is not possible as nothing gets written to new HD.

Attachments (5)

mondoarchive.log.tar.gz (102.6 KB) - added by richardder 6 years ago.
Mondo Archive log
mindi.log.tar.gz (34.6 KB) - added by richardder 6 years ago.
16.12.11.mindi.log.tar.gz (35.8 KB) - added by richardder 6 years ago.
16.12.11.mondoarchive.log.tar.gz (45.5 KB) - added by richardder 6 years ago.
16.12.11.mondorestore.log.tar.gz (40.3 KB) - added by richardder 6 years ago.

Download all attachments as: .zip

Change History (13)

comment:1 Changed 6 years ago by bruno

Could you try with the beta of 3.0 please ? It's available at ftp://ftp.mondorescue.org/test/ubuntu/10.04

comment:2 Changed 6 years ago by richardder

I have updated Mondo, Mindi & Busybox as suggested and the recovery failed in a different place but with out of memory problem. Again I could see no HD activity at all throughout the recovery phase. I end up in busybox. I attach the latest archive log.

Changed 6 years ago by richardder

Mondo Archive log

Changed 6 years ago by richardder

comment:3 Changed 6 years ago by bruno

THanks for trying :-(

Could you at least provide a screen shot of the failure ?

It's the first time I have such a report, and it's very difficult to know the root cause without more details.

Could you launch in the second restore shell (ALT-F2) a top command to monitor the mondorestore job, and check if it grows in memory consuption ?

How much memory has your system ? Is it fullly detected at restore time ?

comment:4 Changed 6 years ago by richardder

Top shows mondorestore (nuke -Z) is steady at 1% mem. Total mem is 4Gb. Swap does not appear.

As mondorestore continues available memory decreases until the system is halted with out of memory.

I think that the problem lies with non-access to the disk. Although mondorestore reports that partitions are created and formatted there is no disk light activity and swap does not seem to be working, hence the out of memory problem. fdisk -l reports:

/dev/sda1 * 1 120378 966934528 83 Linux
/dev/sda2    120379 121602 9825281 5 Extended
Partition 2 does not start on a physical sector boundary
/dev/sda5    120379 121602 9825280 82 Linux swap/Solaris
Last edited 6 years ago by bruno (previous) (diff)

comment:5 Changed 6 years ago by richardder

Thanks for the help particularly alt-F2!

I have tried mondorestore in interactive mode and tried to manually partition the drive. This has created a couple of partitions but no swap. This time there WAS disk activity and partitioning and formatting seems to have taken place with much disk light activity.

Could you please suggest the correct entry in 'editing mountlist' to create the swap partition.

comment:6 Changed 6 years ago by bruno

Could you try to get the /var/log/mondorestore.log file so that I can see why at restore time it doesn't play correctly with your HDD and uses RAM instead !

It may be linked to a driver which wasn't handled by mondo and seems loaded in your case (pata_atiixp). You may want to apply the patch [2916] to mindi and test again.

There is also a problem with the analysis of your mountlist:

Your mountlist will look like this:
-----------------------------------
        DEVICE          MOUNTPOINT      FORMAT          SIZE (MB)       LABEL/UUID     

Unable to open sda1

Unable to open sda5
Your mountlist.txt file content is:
-----------------------------------
-----------------------------------

But this is because your fstab is very strange for me:

proc            /proc           proc    nodev,noexec,nosuid 0       0
sda1     /               ext4    errors=remount-ro 0       1
swap    sw              0       0
sda5     none            swap    sw              0       0

Replace sda1 by /dev/sda1 and also for sda5.

For swap, you should have somathing like this in the mountlist:

/dev/sda7       swap            swap           3992

comment:7 Changed 6 years ago by richardder

Thanks for the help. I tried the swap entry in interactive mode and this did not work so I then added /dev to sda1 and sda5 in fstab and ran mondoarchive again. This time the disk light came on when running mondorestore and the backup completed successfully. I attach the logs.

This confirms that a faulty fstab file is not being flagged up as an error at restore time. Ought it also to be flagged up at archive time?

Changed 6 years ago by richardder

Changed 6 years ago by richardder

Changed 6 years ago by richardder

comment:8 Changed 6 years ago by bruno

  • Resolution set to fixed
  • Status changed from new to closed

mindi now exits with errors in case an entry analyzed is not a real device file with rev [2917]. Will be in final 3.0.0.

Note: See TracTickets for help on using tickets.