Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#485 closed defect (fixed)

Segmentation fault in the latest versions of Mondo on Ubuntu 10.04

Reported by: mbab Owned by: bruno
Priority: normal Milestone: 2.2.9.7
Component: mondo Version: 2.2.9.7
Severity: critical Keywords:
Cc:

Description (last modified by bruno)

Running mondoarchive with command line options results very quickly in a segmentation violation. This critical bug can be reproduced every time using the too latest stable mondo/mindi packages from the ftp-server as well as the newest testing package of mondo/mindi for Ubuntu 10.04.

Output of mondoarchive:

"Initializing...
See /var/log/mondoarchive.log for details of backup run.
Checking sanity of your Linux distribution

WARNING: GPT (GUID Partition Table) detected on '/dev/sdb'! The util fdisk doesn't support GPT. Use GNU Parted.


WARNING: GPT (GUID Partition Table) detected on '/dev/sdc'! The util fdisk doesn't support GPT. Use GNU Parted.

Done.
Archiving only the following file systems on /dev/sda5:
==> /||
Not archiving the following file systems:
==> /kalinka/storage/edelweiss|/kalinka/storage/katrin|/boot|/home|/kalinka/home
Segmentation fault"

mondoarchive-log appended

Configuration System: Ubuntu 10.04 LTS Device: /dev/sda hardware RAID using the Areca ARC-1220 RAID Controller Partition: /dev/sda5 which is in the extended partition /dev/sda4 Used Packages: Mondo: 2.2.9.7-0.20110421135204, Mindi 2.0.7.8-0.20110421135204 but also the latest stable versions Used command:

sudo mondoarchive -OVN -i -I /dev/sda5 -d /home/admin/backup/mondobackup

Attachments (1)

mondoarchive-log.txt (6.9 KB) - added by mbab 8 years ago.
/var/log/mondoarchive.log

Download all attachments as: .zip

Change History (7)

Changed 8 years ago by mbab

/var/log/mondoarchive.log

comment:1 Changed 8 years ago by bruno

  • Description modified (diff)
  • Status changed from new to assigned

Hello,

You should not use the -I /dev/sda5 (of course that should not core dump either !! So I keep the BR open to fix that)

Just exclude what you do not want. -I is mostly for testing purposes.

comment:2 Changed 8 years ago by mbab

Thanks bruno omitting the -I flag did work. The resulting command needs some more exclude flags:

sudo mondoarchive -OVN -i -E "/boot|/home|/kalinka/home|/kalinka/storage|/mnt/old_kalinka" -d /home/admin/backup/mondo -s 4400M -S /home/admin/temp/mondo/scratch/ -T /home/admin/temp/mondo/tmp/

I think the -I flag is quite useful in this case but if its not intended for normal use a short warning in the documentation would be helpful.

By the way the mondoarchive wizard is not capable using so many excludes (the input line is too short) and its seems not to be possible to "scroll" if you enter the text manually. But this is such a small problem not worth opening a ticket.

comment:3 Changed 8 years ago by bruno

-I should work, and I now have a way to reproduce the problem so will fix it anyway.

I think it's already documented:

-I “path ...”
                    Include  paths(s)  in  backup.  The  paths should be separated with a pipe and surrounded by quotes.  This
                    option is mainly use to perform tests in order to reduce the time taken by the archiving  operation.   The
                    default  backup  path is “/” but you may specify alternatives, e.g. -I “/home|/etc” to override that.  You
                    may also specify full disk device to this option as with -I “/dev/sda|/dev/cciss/c0d0”  N.B.:  When  using
                    the  -I  option  with  the -E option, the -E content should be subdirectories of those mentioned in the -I
                    only, as -I takes precedence.

Let me know if you think some more details should be added.

For the scrolling issue, there is already a bug report for it: http://trac.mondorescue.org/ticket/231 which in fact concerns all newt fields. Not before 2.2.10 (or wahtever name it will have).

comment:4 Changed 8 years ago by bruno

  • Milestone changed from 2.2.10 to 2.2.9.7
  • Resolution set to fixed
  • Status changed from assigned to closed

Core dumped with -I should be fixed by rev [2836].

comment:5 Changed 8 years ago by bruno

Could you check with the version available at: ftp://ftp.mondorescue.org/test/ubuntu/10.04 (tag: 20110421135204)

comment:6 Changed 8 years ago by mbab

Great the -I flag is working flawlessly now. Thanks bruno!

Note: See TracTickets for help on using tickets.