Opened 7 years ago

Closed 3 months ago

Last modified 3 months ago

#471 closed enhancement (fixed)

calculate EXTRA_SIZE and BOOT_SIZE values before assigning them

Reported by: MC Owned by: bruno
Priority: normal Milestone: 3.3.0
Component: mindi Version: 2.2.9.5
Severity: normal Keywords: EXTRA_SPACE BOOT_SIZE initrd.img bootdisk
Cc:

Description

EXTRA_SPACE and BOOT_SIZE variables in /usr/sbin/mindi have fixed values. Sometimes, in some systems, it is necessary to increment them to avoid a crash. If mindi crashes because of this, some messages jump in to the screen,

......Failed to copy /tmp/mindi.HoaDLhll8l/initrd.img to /tmp/mindi.HoaDLhll8l/mountpoint.19653
cat: /tmp/mindi.HoaDLhll8l/mtpt.19653: No such file or directory
Please unload some of your modules and try again.
Cannot incorporate initrd.img in bootdisk (kernel / modules too big?)
FATAL ERROR. Sorry, your kernel is too big for your image

and /var/log/mindi.log would get a message like this:

copying /tmp/mindi.HoaDLhll8l/initrd.img to /tmp/mindi.HoaDLhll8l/mountpoint.19653/initrd.img...
cp: writing «/tmp/mindi.HoaDLhll8l/mountpoint.19653/initrd.img»: No space left on device
Failed to copy /tmp/mindi.HoaDLhll8l/initrd.img to /tmp/mindi.HoaDLhll8l/mountpoint.19653
Please unload some of your modules and try again.
Cannot incorporate initrd.img in bootdisk (kernel / modules too big?)
...--
Kernel size = 2000 K
Ramdisk free = 0 K
FATAL ERROR. Sorry, your kernel is too big for your image

I think this is not a bug, but for a first time user, this can be a "horror movie".

I think an easier approach to implement in a short term, could be adding a message telling the user to try to increment values in those variables editing /usr/sbin/mindi. This can lead to prevent users from repeating the same questions in the mailing list.

In a second phase, implement an algorithm that could "guess" which values would be assigned to the variables. This would save the user to undesirable crashes, and would be a better solution in my opinion.

Change History (3)

comment:1 Changed 7 years ago by bruno

  • Milestone changed from 2.2.9.6 to 2.2.10
  • Status changed from new to assigned

Short term done in [2773]. Rest postponed in 2.2.10.

comment:2 Changed 5 years ago by bruno

  • Milestone 3.1.0 deleted

Milestone 3.1.0 deleted

comment:3 Changed 3 months ago by bruno

  • Milestone set to 3.3.0
  • Resolution set to fixed
  • Status changed from assigned to closed

In 3.3 version, only EXTRA_SPACE remains to have a bit of extra room for the additional tools that are put in the boot media in addition to all the others whose size is now automatically computed (which is the majority).

Setup as 20 MB, which should be really enough (CentOS 7 tests ok which were requiring more than 400 MB before).

Considered now fixed.

Last edited 3 months ago by bruno (previous) (diff)
Note: See TracTickets for help on using tickets.