Opened 12 years ago

Closed 11 years ago

#296 closed defect (fixed)

Problem Running Mondoarchive 2.2.7 on a Fedora 2 system

Reported by: kaplan71 Owned by: Bruno Cornec
Priority: normal Milestone: 2.2.8
Component: mondo Version: 2.2.7
Severity: normal Keywords:
Cc:

Description

I am trying to run version 2.2.7-r2045 on a Fedora Core 2 system, and the backup process either takes a very long time to complete or hangs during execution. The backup in question is an NFS backup, and the syntax that is used is shown below:

/usr/sbin/mondoarchive -9 -N -O -s 4812m -p mondorescue -n rorecovery.mgh.harvard.edu:/rtp51

Initially the problem appeared to be with the version of tar, 1.13, that came bundled with the operating system. That was corrected by upgrading tar to the newer 1.15 version. Once that was done, mondoarchive would commence with the backup.

The first problem that I encountered was that mondo would take upwards to eight hours to complete, and create twenty 4.7 gigabyte iso images for a thirty gigabyte local hard drive. This would occur even though the –N option was used at the command line.

To get around the first problem, all NFS mounts were unmounted with the exception of the destination where the iso images would be created. During the fileset creation process, mondoarchive would get to ninety-eight percent completion, and then hang for no apparent reason.

I have enclosed the mindi and mondoarchive logs with this e-mail. I checked for any failed references, and the following entries appeared in the mondoarchive.log file:

mindi --makemountlist mondo.tmp.G0Uket/mountlist.txt.test failed for some reason. Failed. [Main] libmondo-tools.c->pre_param_configuration#810: Your distribution did not pass Mondo's sanity test.

[Main] newt-specific.c->fatal_error#296: Fatal error received - 'Pre-param initialization phase failed. Please review the error messages above, make the specified changes, then try again. Exiting...'

Can someone lend a hand on this? Thanks.

Attachments (7)

mindi.log (12.4 KB) - added by kaplan71 12 years ago.
mondoarchive.log (20.4 KB) - added by kaplan71 12 years ago.
1.zip (166 bytes) - added by kaplan71 12 years ago.
mindi.zip (4.5 KB) - added by kaplan71 12 years ago.
2.zip (6.1 KB) - added by kaplan71 12 years ago.
Replacement for existing 2.zip file
1 (91 bytes) - added by kaplan71 12 years ago.
Updated "1" file
mondolatest.tar (50.0 KB) - added by kaplan71 12 years ago.
latest log files

Download all attachments as: .zip

Change History (16)

Changed 12 years ago by kaplan71

Attachment: mindi.log added

Changed 12 years ago by kaplan71

Attachment: mondoarchive.log added

comment:1 Changed 12 years ago by Bruno Cornec

Status: newassigned

Not sure yet of what is happening here.

Could you run the following:

mindi --makemountlist /tmp/1 2>&1 | tee /tmp/2

And send me compressed the files /tmp/1, /tmp/2 and /var/log/mindi.log please.

comment:2 Changed 12 years ago by kaplan71

Per your request, I am uploading the 1.zip, 2.zip, and mindi.zip files.

Changed 12 years ago by kaplan71

Attachment: 1.zip added

Changed 12 years ago by kaplan71

Attachment: mindi.zip added

comment:3 Changed 12 years ago by Bruno Cornec

My mistake. Ok, what I need is:

sh -x mindi --makemountlist /tmp/1 2>&1 | tee /tmp/2

and only the /tmp/2 file.

Thanks.

comment:4 Changed 12 years ago by kaplan71

Hi there --

I ran the command syntax you requested, and the file in question, which has been zipped, has been uploaded as well.

Changed 12 years ago by kaplan71

Attachment: 2.zip added

Replacement for existing 2.zip file

comment:5 Changed 12 years ago by Bruno Cornec

Well this time, mindi finishes its run without issue (return code 0) and prints the correct content. So you seem to not be able to reproduce it which is weird.

Don't know how I can help from here :-( Does that command now works ? mindi --makemountlist /tmp/1

If it doesn't then run it just after again preceding it with sh -x. But your last file for that was OK.

Changed 12 years ago by kaplan71

Attachment: 1 added

Updated "1" file

Changed 12 years ago by kaplan71

Attachment: mondolatest.tar added

latest log files

comment:6 Changed 12 years ago by kaplan71

Hi there -- I uploaded another "1" file that was the output of the mindi --makemountlist /tmp/1 command.

The only other thing that I have been able to reproduce is mondoarchive hanging at the same location during its run. I have tarred the latest log directory, and have uploaded it as well.

comment:7 Changed 12 years ago by Bruno Cornec

I found a new idea lookig at your ogs. It seems that your /boot isn't mounted, which could prevent mindi to work with your kernel. Could be the cause.

comment:8 Changed 11 years ago by kaplan71

Hi there --

I'm sorry about the delay in getting back to you, and I hope you had a great Thanksgiving holiday. Anyway, I took your advice, and once the /boot filesystem was mounted, I ran the mondoarchive command, and I was able to create a 4.7GB iso image on the remote NFS mount. I had several follow questions:

  1. I noticed that mondoarchive did not automatically exit when the job was done, and it was necessary for me to manually kill the process. Is this by design, or is there something else that needs to be done?
  1. There was a mondorescue.iso file created in the /var/cache/mindi directory when the backup job was running. Is this image meant to be burned onto media and used as an emergency boot cd that will enable the administrator to automatically mount the remote NFS mount where the other iso image is created during the archive?
  1. Is the iso image created on the NFS mount such that it can be burned onto dvd media? After that, can the DVD be subsequently inserted into the DVD drive of the system and used as a bootable medium to do a restoration of the system?

Thanks.

comment:9 in reply to:  8 Changed 11 years ago by Bruno Cornec

Resolution: fixed
Status: assignedclosed

Replying to kaplan71:

Hi there --

I'm sorry about the delay in getting back to you, and I hope you had a great Thanksgiving holiday.

No thanksgiving on this side of the atlantic, but Christmas is approaching ;-)

  1. I noticed that mondoarchive did not automatically exit when the job was done, and it was necessary for me to manually kill the process. Is this by design, or is there something else that needs to be done?

This is not by design. Maybe an error occurred somewhere. It should have finished alone. Again the log is valuable for me to help detect what happened.

  1. There was a mondorescue.iso file created in the /var/cache/mindi directory when the backup job was running. Is this image meant to be burned onto media and used as an emergency boot cd that will enable the administrator to automatically mount the remote NFS mount where the other iso image is created during the archive?

This image is the mindi image corresponding to your hardware. You should rather burn the other ISO images made by mondo on the NFS share if you want backups on media as well. Remember with 2.2.7 to mount your share read-only when restoring. Cf: #291

  1. Is the iso image created on the NFS mount such that it can be burned onto dvd media?

Yes.

After that, can the DVD be subsequently inserted into the DVD drive of the system and used as a bootable medium to do a restoration of the system?

Yes.

Note: See TracTickets for help on using tickets.