Opened 12 years ago

Closed 10 years ago

#170 closed defect (fixed)

restore disk brings up my scsi as /dev/sdb when original was /dev/sda, messes up loader

Reported by: rhel4now Owned by: bruno
Priority: normal Milestone: 2.2.8
Component: mondo Version: 2.2.3
Severity: normal Keywords:
Cc:

Description

my original system disk is on /dev/sda and when trying to restore to a new disk, the 'nuke' restore fails because it brings up a ramdisk as /dev/sda and allows access to my new disk as /dev/sdb. It tries to restore to the 'tiny' ramdisk and even says it's trying to restore to a 'tiny' disk. It asks if you want to go to the interactive mode but, that defeats the -H mode I ran it in in the first place. Also the interactive mode seems to mess up the installing of the GRUB loader correctly. I'm using mondo 2.2.3-1 and mindi 1.2.3-1.

Many thanks for you help

Change History (3)

comment:1 Changed 12 years ago by rhel4now

I found the cause of the /dev/sdb coming up as a 'tiny' disk is due to the server I'm working with has a small 64MB ramdisk setup with USB/scsi emulation. So when mondorestore comes up, it sees the little ramdisk first and gives it /dev/sda and then the bit 73GB scsi disk and gives it /dev/sdb, which blows things since the big disk on the source system was of course the /dev/sda device. What is funny is the bios brings up the big disk on it's Scsi1 channel and the little ramdisk on it's Scsi2 channel so you would think mondorestore would see the big disk first and assign it to /dev/sda, like the RHEL4U2 o/s does. Is this a configurable parameter that can be overridden so I can still use the -H save option to make the nuke restore work without operator intervention?

comment:2 Changed 12 years ago by bruno

  • Milestone 2.2.4 deleted

Do you have something on the original system "special" in your boot line ?

Could you give us the result of cat /proc/cmdline ?

Did you use the running kernel or another one ? You didn't provide any log so help is more difficult :-(

comment:3 Changed 10 years ago by bruno

  • Milestone set to 2.2.8
  • Resolution set to fixed
  • Status changed from new to closed

2.2.8 should help fix that + the addition of the sub= boot param.

Note: See TracTickets for help on using tickets.