Opened 11 years ago

Closed 9 years ago

#169 closed defect (fixed)

Support for RHAS 2.1

Reported by: bruno Owned by: bruno
Priority: normal Milestone: 2.2.8
Component: mondo Version: 2.2.3
Severity: blocker Keywords:
Cc:

Description

There are some problems to support RHAS 2.1:

  • readlink has to be a dependency
  • initrd support in mindi doesn't work anymore (automatic detection functions based on strings)

Change History (10)

comment:1 Changed 11 years ago by bruno

readlink on AS2.1 is in tetex !!!: # rpm -qlp tetex-1.0.7-38.4.i386.rpm | grep readlink /usr/bin/readlink /usr/share/man/man1/readlink.1.gz

comment:2 Changed 11 years ago by bruno

THere is also an issue with grep and sed version (need at least grep 2.5 from RH7.3)

comment:3 Changed 11 years ago by bruno

  • Status changed from new to assigned

For AS2.1 we need to use grep from rh7.3. Just installs fine. Cf: ftp://ftp.mondorescue.org/rhel/2.1/grep-2.5.1-1.i386.rpm

For the readlink problem, the one provided by tetex doesn't support option -f. So you need to use the script available here and put it in /bin/readlink so that it works better. Cf: ftp://ftp.mondorescue.org/rhel/2.1/readlink

For sed, the problem is that mindi uses issue.net, which it should as it may contain char such as \m in AS2.1 which confuses sed. Should be replaced later on.

comment:4 Changed 11 years ago by bruno

The readlink script is replaced in fact by a binary which is the result of compiling coreutils on RHAS2.1 and taking the readlink binary produced. Same link: ftp://ftp.mondorescue.org/rhel/2.1/readlink

comment:5 Changed 11 years ago by bruno

  • Milestone changed from 2.2.4 to 2.2.5

The new kernel detection in mindi doesn't work for AS2.1 and show that it may also cause issues for other kernel versions. Still unable to restore via PXE the RHAS2.1 in test due to dynamic libraries issues.

comment:6 Changed 10 years ago by bruno

  • Milestone changed from 2.2.5 to 2.2.6

comment:7 Changed 10 years ago by bruno

  • Milestone changed from 2.2.6 to 2.2.7

comment:8 Changed 9 years ago by bruno

  • Milestone changed from 2.2.7 to 2.2.8

comment:10 Changed 9 years ago by bruno

  • Resolution set to fixed
  • Status changed from assigned to closed

The current mindi version seems to work. Would need feedback for mondo in itself. Closing for now. Feel free to reopen if something is wrong

Note: See TracTickets for help on using tickets.