Opened 12 years ago

Closed 10 years ago

#108 closed defect (fixed)

/dev fills up to 100% and stops

Reported by: d3acon Owned by: bruno
Priority: high Milestone: 2.2.9
Component: mondo Version: 2.2.0
Severity: blocker Keywords:
Cc:

Description (last modified by bruno)

I started mondoarchive from the commandline on an openSuSE 10.1 x86 system (dual core). -> NFS mount -> 4400 MB as filesize <br> The progressbar showed up - but it filled up the /dev instead of my mounted nfs drive.

du -sm /dev/* | sort
341     /dev/mondo.scratch.27361
93      /dev/tmp.mondo.8514
1       /dev/shm
....

Following processes were running, when I tried to stop it:

[15:47] root@ucl01121:~# ps -ef|grep mondo
root     13524 11910 14 15:20 pts/2    00:04:05 mondoarchive
root     21087 13524  0 15:45 pts/2    00:00:00 sh -c gzip -c1 > /dev/tmp.mondo.8514/xattr_list.45.gz
root     24939 13524  0 15:45 pts/2    00:00:00 sh -c afio -o -b 131072 -M 16m -Z -P bzip2 -G 9 -T 3k -E /usr/share/mondo/do-not-compress-these /dev/tmp.mondo.8514/tmpfs/46.afio.bz2 < /dev/tmp.mondo.8514/filelist.46 2>> /var/log/mondo-archive.log
root     24941 24939  0 15:45 pts/2    00:00:00 afio -o -b 131072 -M 16m -Z -P bzip2 -G 9 -T 3k -E /usr/share/mondo/do-not-compress-these /dev/tmp.mondo.8514/tmpfs/46.afio.bz2

Cheers

Robert

Change History (9)

comment:1 Changed 12 years ago by Bruno Cornec

On Tue, Nov 21, 2006 at 03:04:12PM -0000, MondoRescue wrote:
>  341     /dev/mondo.scratch.27361
>  93      /dev/tmp.mondo.8514
>  1       /dev/shm

Could you provide the log file /var/log/mondo-archive.log please and
attach it.

Bruno.

comment:2 follow-up: Changed 12 years ago by d3acon

The problem is, I started mondoarchive again to see what I selected, when I wrote that error ticket. At the moment I try to reproduce that failure. Now it seems to work. But yesterday filesystem / was almost full, today I have 2,5GB free. Does it choose the filesystem with the most free space for writing the temp files? Because in my case that would have been /dev yesterday and / today.

comment:3 Changed 12 years ago by Bruno Cornec

MondoRescue said on Wed, Nov 22, 2006 at 09:18:40AM -0000:

>  Does it
>  choose the filesystem with the most free space for writing the temp files?
>  Because in my case that would have been /dev yesterday and / today.

Yes, this is the case. I'm not sure it's a good idea BTW, so it will 
probably change in the future, to let to the user the choice.

Bruno.
-- 
Linux Profession Lead EMEA  / Open Source Evangelist \        HP C&I EMEA IET
http://www.mondorescue.org / HP/Intel Solution Center \  http://hpintelco.net
Des infos sur Linux?  http://www.HyPer-Linux.org      http://www.hp.com/linux
La musique ancienne?  http://www.musique-ancienne.org http://www.medieval.org

comment:4 Changed 12 years ago by bruno

  • Milestone set to 2.2.2
  • Status changed from new to assigned

comment:5 Changed 12 years ago by bruno

  • Description modified (diff)
  • Milestone changed from 2.2.2 to 3.0.0

comment:6 in reply to: ↑ 2 Changed 10 years ago by cdaly

Replying to d3acon:

The problem is, I started mondoarchive again to see what I selected, when I wrote that error ticket. At the moment I try to reproduce that failure. Now it seems to work. But yesterday filesystem / was almost full, today I have 2,5GB free. Does it choose the filesystem with the most free space for writing the temp files? Because in my case that would have been /dev yesterday and / today.

Hi,

You can use the '-T' and '-S' switches with mondoarchive to specify where it should put the temp files.

Conor

comment:7 Changed 10 years ago by Chucky

I also had this problem. Function sensibly_set_tmpdir_and_scratchdir() selects on OpenSuse? (10.3 and 11.1) tmpdir to /dev. I removed " sed 's/ /devdev/' | tr -s '\t' ' ' | " from line in libmondo-devices.c:2207 (2.2.8) and it seems to work. Later used awk can hadle both spaces and tabs as whitespace, therefore I don't think this is necessary.

df -m -P -x nfs -x nfs4 -x vfat -x ntfs -x ntfs-3g -x smbfs -x smb -x cifs -x afs -x gfs -x ocfs -x ocfs2 -x mvfs -x nsspool -x nssvol -x iso9660:

Filesystem 1048576-blocks Used Available Capacity Mounted on /dev/sda3 223897 127994 84530 61% / udev 1513 1 1513 1% /dev

df -m -P -x nfs -x nfs4 -x vfat -x ntfs -x ntfs-3g -x smbfs -x smb -x cifs -x afs -x gfs -x ocfs -x ocfs2 -x mvfs -x nsspool -x nssvol -x iso9660 | sed 's/ /devdev/' | tr -s '\t' ' ':

Filesystem 1048576-blocks Used Available Capacity Mounted on /dev/sda3devdev223897 127995 84529 61% / udevdevdev 1513 1 1513 1% /dev

df -m -P -x nfs -x nfs4 -x vfat -x ntfs -x ntfs-3g -x smbfs -x smb -x cifs -x afs -x gfs -x ocfs -x ocfs2 -x mvfs -x nsspool -x nssvol -x iso9660 | sed 's/ /devdev/' | tr -s '\t' ' ' | grep -vE "none|Filesystem|/dev/shm" | awk '{printf "%s %s\n", $4, $6;}':

61% 1513 /dev

comment:8 Changed 10 years ago by Chucky

I apologize.

df -m -P -x nfs -x nfs4 -x vfat -x ntfs -x ntfs-3g -x smbfs -x smb -x cifs -x afs -x gfs -x ocfs -x ocfs2 -x mvfs -x nsspool -x nssvol -x iso9660:

Filesystem         1048576-blocks      Used Available Capacity Mounted on
/dev/sda3                  223897    127994     84530      61% /
udev                         1513         1      1513       1% /dev

df -m -P -x nfs -x nfs4 -x vfat -x ntfs -x ntfs-3g -x smbfs -x smb -x cifs -x afs -x gfs -x ocfs -x ocfs2 -x mvfs -x nsspool -x nssvol -x iso9660 | sed 's/                  /devdev/' | tr -s '\t' ' ':

Filesystem 1048576-blocks Used Available Capacity Mounted on
/dev/sda3devdev223897 127995 84529 61% /
udevdevdev 1513 1 1513 1% /dev

df -m -P -x nfs -x nfs4 -x vfat -x ntfs -x ntfs-3g -x smbfs -x smb -x cifs -x afs -x gfs -x ocfs -x ocfs2 -x mvfs -x nsspool -x nssvol -x iso9660 | sed 's/                  /devdev/' | tr -s '\t' ' ' | grep -vE "none|Filesystem|/dev/shm" | awk '{printf "%s %s\n", $4, $6;}':

61%
1513 /dev

comment:9 Changed 10 years ago by bruno

  • Milestone changed from 3.0.0 to 2.2.9
  • Resolution set to fixed
  • Status changed from assigned to closed

Thanks for reporting. I also found that bug on my side, but didn't read your report before that :-(.

Anyway. Been fixed in rev [2347] same way you proposed, for the same reason ;-), and will be in 2.2.9 final.

Note: See TracTickets for help on using tickets.