Opened 4 years ago

Last modified 4 years ago

#867 new defect

Failed mondo recover

Reported by: John S Owned by: Bruno Cornec
Priority: normal Milestone: 3.3.0
Component: mondo Version: 3.2.2
Severity: normal Keywords:


I am trying to clone a Centos5.6 server. I have run MondoArchive which has created 2 .iso files. I have created a blank VM and mounted the first iso and launched it. I get error:

'Could not find kernel image: linux'

If I try '/vmlinuz initrd=/initrd.img' I get:

'Loading Invalid or corrupt kernel image'

I have mounted the iso file on another machine and I can browse around the directories and the files seem to be where they should be.

Is there anything I can do to get this working please?

Attachments (1)

mondoarchive.log (342.3 KB ) - added by John S 4 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 by Bruno Cornec, 4 years ago

Mounting the ISO doesn't give you a view on the boot part of the ISO :-( So what you're browsing is NOT what is booted.

What could help debug the issue is to provide the /var/log/mondoarchive.log file so I can have a closer look on the boot setup made during the archive run.

by John S, 4 years ago

Attachment: mondoarchive.log added

comment:2 by John S, 4 years ago

Thanks for the reply!

I tried installing a non xen kernel - - and tried again.

This time I still got 'Could not find kernel image: linux' but when I tried '/vmlinuz initrd=/initrd.img' it started to boot but failed on the following error:

'RAMDISK: incomplete write (-28 != 32768) 16777216 VFS: Cannot open root device "<NULL>" or unknown-block(253,3) Please append a correct "root=" boot option Kernel Panic - not syncing'

I tried increasing EXTRA_SPACE=600000 in /usr/sbin/mindi and also made these changes:

But I had the same problem after running mondoarchive again.

I have just done a test run of mondoarchive for a single folder to save time. Again I had the same issue as previously. I have attached the mondoarchive.log

Last edited 4 years ago by John S (previous) (diff)

comment:3 by John S, 4 years ago

OK so I just tried appending the pxe command like so:

/vmlinuz append initrd=/initrd.img load_ramdisk=1 ramdisk_size=2048000 ramdisk_blocksize=1024

And it has now booted into Mondo Rescue.

However, it only loaded the first .iso file, and didn't prompt for the second one.

Any idea why this might be?

Last edited 4 years ago by John S (previous) (diff)

comment:4 by Bruno Cornec, 4 years ago

Normally when you boot the first MondoRescue ISO image, you have the choice between interactive, expert, compare, iso, nuke or isonuke as keyword at the syslinux prompt.

The conf file created then should launch (line 7302 and following of your log file): /vmlinuz append initrd=/initrd.img root=/dev/ram0 rw ramdisk_size=685540 devfs=nomount noresume selinux=0 barrier=off udevtimeout=10 KEYWORD

where KEYWORD is replaced by the choice you made earlier. That should launch the mondorestore command, which will ask for the additional media once at the end of the restore of the first.

Hope that helps. Bruno.

Note: See TracTickets for help on using tickets.