Opened 3 months ago

Closed 2 months ago

#837 closed defect (fixed)

Unable to log after restore of RHEL 7

Reported by: bruno Owned by: bruno
Priority: high Milestone: 3.3.0
Component: mondo Version: 3.2.2
Severity: blocker Keywords:
Cc:

Description (last modified by bruno)

After a restore of RHEL 7, with mondoarchive 3.3.0 beta, it's not possible to log on the system.

Seems that it could be an issue with:

sulogin: failed to execute /bin/bash

Change History (5)

comment:1 Changed 3 months ago by bruno

  • Description modified (diff)

comment:2 Changed 3 months ago by bruno

Even after solving #836, this issue remains valid.

It is related to extended attributes not restored correctly in this version, as /usr/bin/bash had an incorrect _t context e.g. Changing it back to the correct value is however not suffficient

Trying to boot with systemd.shell-debug and typing setenforce 0 in VT 9 allows to login. So now remains to see what is wrong with the ACL/EXATTR in the process in 3.3.0.

comment:3 Changed 2 months ago by bruno

The attr package was missing which is a packaging bug on RHEL 7, as this is part of the deps !

Adding the package to check, and working on the fix.

comment:4 Changed 2 months ago by bruno

Packaging issue fixed with project-builder revision 2340 http://trac.project-builder.org/changeset/2340

comment:5 Changed 2 months ago by bruno

  • Resolution set to fixed
  • Status changed from new to closed

Checked with a full backup/restore on RHEL 7.3.

Note: See TracTickets for help on using tickets.