Opened 3 months ago

Closed 2 months ago

#812 closed task (worksforme)

"DIsk Full?" Error While Restoring P2V

Reported by: cjhsa Owned by: bruno
Priority: normal Milestone: 3.3.0
Component: mondo Version: 3.2.2
Severity: normal Keywords:
Cc:

Description

I'm trying to restore a physical image to a VM. The image is from an HP DL380 G9 running RHEL 7.3. The VM host is running ESX. The VM guest is configured with a 32GB virtual disk and 8GB RAM, and the SCSI controller is set to "LSI Integrated".

When I run mondorestore, for some reason all of the filesystems in the mountlist other than /boot and /dev/sda2 show size 0. I have to modify the mountlist so they are large enough to "fit" the actual filesystem usage.

FYI: There is only one data iso, and it is < 2GB.

mondo-3.2.2-1.rhel7.x86_64 mindi-3.0.2-1.rhel7.x86_64 mindi-busybox-1.21.1-1.rhel7.x86_64

The restore seems to go fine, until the very end when "largefiles" are being recovered. Then I see:

"Working on DVD #1, file X, slice Y full?"

Cannot openout outfile_fname - hard disk full? Errors occurred while data was being restored. You will now edit multipath.conf (really?) Initialize the boot loader y/n? y Re-generate initd? y/n? n Did you change mountlist y/n? n Label partitions y/n? n

Exits to shell. Cannot find mount-me nor grub.

# exit (reboot) "Grub loading stage 1.5

Grub loading please wait

Error 22"

Change History (3)

comment:1 Changed 2 months ago by bruno

If you have LVM (as is std on RHEL), then the FS are shown at 0, becasue the size isn't managed at the FS level but at the LVM level. So you don't need to modify that as mondorestore will take care of it ! Through a file called /tmp/i-want-my-lvm

With large files, you may be restoring scarced files, so I'd recommend you use star instead of afio for backups (-R option) as it supports better this type of files.

Then read the guide at http://www.mondorescue.org/docs/p2v.pdf for the end of the restore and the boot loader aspects.

comment:2 Changed 2 months ago by cjhsa

Thanks Bruno.

I forgot to update my case. I got around this by restoring to a VM with a much larger hard disk. I just used the zero size filesystems as shown in the mountlist and it worked. Pretty cool that we can do P2V using mondo. I've been using the product for 10-years and never knew this could be done.

Thanks!

I have another problem now in that some of my SLES servers are producing mondo isos that are unusable. We are seeing "Could not find kernel image: linux" when we boot from them. If I mount them and look at them, they look ok (syslinux.cfg is there and points to /vmlinuz and /initrd, which exist), but they won't boot a system.

I will open another ticket for that if I can't figure it out.

Craig

comment:3 Changed 2 months ago by bruno

  • Resolution set to worksforme
  • Status changed from new to closed

Yes please do so. And attach your log files so we can really help more.

Note: See TracTickets for help on using tickets.