Opened 6 years ago

Closed 6 years ago

#770 closed defect (duplicate)

Using lzma breaks mondoarchive/mindi communication

Reported by: Bruno Cornec Owned by: Bruno Cornec
Priority: normal Milestone: 3.2.1
Component: mondo Version: 3.2.0
Severity: normal Keywords:
Cc:

Description (last modified by Bruno Cornec)

Using mondo 3.2.0 with -Y option doesn't work.

THe call to mindi is broken in that case whereas it's working with -G e.g.

Relevant mondoarchive.log file:

DBG1: [Main] libmondo-archive.c->call_mindi_to_supply_boot_disks#837: lines_in_filelist = 532389
DBG2: [Main] libmondo-archive.c->call_mindi_to_supply_boot_disks#889: mindi   --custom /tmp/mondo.tmp.TxI0d1 /tmp/mondo.scratch.nP6tjN/images
'/boot/vmlinuz-2.6.32-504.8.1.el6.x86_64' '' '0' '532389' 'no' 'no' '' 'yes' '2070' '12108' '""' 'yes' 'no' 'no' '32768' '0' 'no' 'yes' 2>&1
> iso
DBG3: [Main] libmondo-fork.c->run_external_binary_with_percentage_indicator_NEW#642: command = 'mindi   --custom /tmp/mondo.tmp.TxI0d1
/tmp/mondo.scratch.nP6tjN/images '/boot/vmlinuz-2.6.32-504.8.1.el6.x86_64' '' '0' '532389' 'no' 'no' '' 'yes' '2070' '12108' '""' 'yes' 'no'
'no' '32768' '0' 'no' 'yes' 2>&1 > iso 2>> /var/log/mondoarchive.log'
INFO: Calling MINDI for boot disk
INFO:      Calling MINDI for boot disk
DBG4: [Main] libmondo-fork.c->run_prog_in_bkgd_then_exit#606: sz_command = 'mindi   --custom /tmp/mondo.tmp.TxI0d1
/tmp/mondo.scratch.nP6tjN/images '/boot/vmlinuz-2.6.32-504.8.1.el6.x86_64' '' '0' '532389' 'no' 'no' '' 'yes' '2070' '12108' '""' 'yes' 'no'
'no' '32768' '0' 'no' 'yes' 2>&1 > iso 2>> /var/log/mondoarchive.log'
[...]
------------- mindi logfile included -------------------------
mindi v3.0.0-r3332
x86_64 architecture detected
mindi called with the following arguments:
--custom /tmp/mondo.tmp.TxI0d1 /tmp/mondo.scratch.nP6tjN/images /boot/vmlinuz-2.6.32-504.8.1.el6.x86_64  0 532389 no no  yes 2070 12108 ""
yes no no 32768 0 no yes
Start date : Wed Feb 25 12:38:52 EST 2015
-----------------------------
[...]
Using modules for kernel: 2.6.32-504.8.1.el6.x86_64
INFO: kernelname = 2.6.32-504.8.1.el6.x86_64
INFO: kernelpath = /boot/vmlinuz-2.6.32-504.8.1.el6.x86_64
INFO: You are using Mindi-Linux v3.0.0-r3332 to make boot+data disks
Mindi-BusyBox v1.21.1-r3332 (2014-12-24 02:04:25 CET) multi-call binary.
DIFFERENTIAL = 0
INTERNAL TAPE BLOCK SIZE = 32768
NOT_BOOT = 'yes'
INFO: Just creating mondorestore.cfg and a small all.tar.gz for Mondo. Nothing else.
[...]

Change History (2)

comment:1 Changed 6 years ago by Bruno Cornec

Description: modified (diff)

comment:2 Changed 6 years ago by Bruno Cornec

Resolution: duplicate
Status: newclosed

This one is a duplicate of #748 and has been fixed with rev [3353]

Note: See TracTickets for help on using tickets.