Opened 13 years ago

Closed 10 years ago

#74 closed defect (fixed)

Mondo hangs at at libmondo-devices.c:1631 in mount_CDROM_here

Reported by: ugob Owned by: Bruno Cornec
Priority: normal Milestone: 2.2.7
Component: mondo Version: 2.0.9
Severity: normal Keywords:
Cc:

Description (last modified by Bruno Cornec)

I run Mondo on several servers daily. This probably is mostly seen on one server, but I've seen it on another server too.

The first symptom of the problem is that /var is filling up. Why? Because since I run mondo via cron, the output is sent by e-mail. So a very big file can be found in /var/spool/clientmqueue.

If I check the content of this big file, I find this:

---promptstring---1--- CD-ROM device
---promptstring---2--- Please enter your CD-ROM's /dev device
---promptstring---Q---
--> ASSERTION FAILED: `device[0]!='\0''
at libmondo-devices.c:1631 in mount_CDROM_here

(I)gnore, ignore (A)ll, (D)ebug, a(B)ort, or (E)xit? Invalid choice.
Invalid choice.
Invalid choice.
Invalid choice.
Invalid choice.
Invalid choice.
Invalid choice.

In /var/log/message, there is:

Sep 13 02:01:07 bibitte kernel: attempt to access beyond end of device
Sep 13 02:01:08 bibitte kernel: loop0: rw=0, want=1230356, limit=82328
Sep 13 02:01:09 bibitte kernel: Buffer I/O error on device loop0,
logical block 307588
Sep 13 02:01:10 bibitte kernel: attempt to access beyond end of device
Sep 13 02:01:13 bibitte kernel: loop0: rw=0, want=1230360, limit=82328
Sep 13 02:01:13 bibitte kernel: Buffer I/O error on device loop0,
logical block 307589
Sep 13 02:01:14 bibitte kernel: attempt to access beyond end of device
Sep 13 02:01:16 bibitte kernel: loop0: rw=0, want=1230236, limit=82328
Sep 13 02:01:17 bibitte kernel: Buffer I/O error on device loop0,
logical block 307558
Sep 13 02:01:17 bibitte kernel: attempt to access beyond end of device
Sep 13 02:01:17 bibitte kernel: loop0: rw=0, want=1230240, limit=82328
Sep 13 02:01:17 bibitte kernel: Buffer I/O error on device loop0,
logical block 307559
Sep 13 02:01:17 bibitte kernel: cdrom: open failed.
Sep 13 02:01:17 bibitte kernel: cdrom: open failed.

The command line is:

mondoarchive -e -Oi -9 -F -d /data/images/daily/`date +%A` -E "/data"

I also verify afterwards with:

/usr/sbin/mondoarchive -e -Vi -d /data/images/daily/`date +%A`

I have tried:

-adding the -e switch to avoid ejection -upgraded mondo and mindo to the latest release (.09).

The problem is still there...

Change History (7)

comment:1 Changed 13 years ago by Bruno Cornec

Description: modified (diff)

comment:2 Changed 13 years ago by Bruno Cornec

You have a problem with your loop device here. Maybe a FS full ? In any case could you try again with the latest versions available mondo 2.2.1 + mindi 1.2.1 + mindi-busybox 1.2.2

comment:3 Changed 11 years ago by Bruno Cornec

Milestone: 2.2.7
Resolution: fixed
Status: newclosed

comment:4 in reply to:  description ; Changed 10 years ago by Patrick Corrigan

Resolution: fixed
Status: closedreopened

Replying to ugob:

I am having a similar problem. I am running Mondo as a cron job on CentOS 5.2. I end up with a 171 GB file in /var/spool/clientmqueue. The mondorescue iso file is only 822 MB, so I don't know how this huge file is getting generated.

During verify mondoarchive.log shows the following:

[Main] libmondo-verify.c->verify_a_tarball#506: afio -r -P bzip2 -Z /tmp/mondo/mondo.tmp.zZXNjS/cdrom/archives/98.afio.bz2 >> /tmp/mondo/mondo.tmp.zZXNjS/afio.log 2>> /tmp/mondo/mondo.tmp.zZXNjS/afio.log '/tmp/mondo/mondo.tmp.zZXNjS/cdrom/archives/98.afio.bz2' - differences found afio: /var/spool/clientmqueue/dfo4I1KnC0003500

"dfo4I1KnC0003500" is the name of the large file.

Here is my cron command:

/usr/sbin/mondoarchive -OVn nfs://orp-pdx-backup:/vol1/pbx_backup -N -E /media/usb -S /tmp/mondo -T /tmp/mondo -s 4480m

I run Mondo on several servers daily. This probably is mostly seen on one server, but I've seen it on another server too.

The first symptom of the problem is that /var is filling up. Why? Because since I run mondo via cron, the output is sent by e-mail. So a very big file can be found in /var/spool/clientmqueue.

If I check the content of this big file, I find this:

---promptstring---1--- CD-ROM device
---promptstring---2--- Please enter your CD-ROM's /dev device
---promptstring---Q---
--> ASSERTION FAILED: `device[0]!='\0''
at libmondo-devices.c:1631 in mount_CDROM_here

(I)gnore, ignore (A)ll, (D)ebug, a(B)ort, or (E)xit? Invalid choice.
Invalid choice.
Invalid choice.
Invalid choice.
Invalid choice.
Invalid choice.
Invalid choice.

In /var/log/message, there is:

Sep 13 02:01:07 bibitte kernel: attempt to access beyond end of device
Sep 13 02:01:08 bibitte kernel: loop0: rw=0, want=1230356, limit=82328
Sep 13 02:01:09 bibitte kernel: Buffer I/O error on device loop0,
logical block 307588
Sep 13 02:01:10 bibitte kernel: attempt to access beyond end of device
Sep 13 02:01:13 bibitte kernel: loop0: rw=0, want=1230360, limit=82328
Sep 13 02:01:13 bibitte kernel: Buffer I/O error on device loop0,
logical block 307589
Sep 13 02:01:14 bibitte kernel: attempt to access beyond end of device
Sep 13 02:01:16 bibitte kernel: loop0: rw=0, want=1230236, limit=82328
Sep 13 02:01:17 bibitte kernel: Buffer I/O error on device loop0,
logical block 307558
Sep 13 02:01:17 bibitte kernel: attempt to access beyond end of device
Sep 13 02:01:17 bibitte kernel: loop0: rw=0, want=1230240, limit=82328
Sep 13 02:01:17 bibitte kernel: Buffer I/O error on device loop0,
logical block 307559
Sep 13 02:01:17 bibitte kernel: cdrom: open failed.
Sep 13 02:01:17 bibitte kernel: cdrom: open failed.

The command line is:

mondoarchive -e -Oi -9 -F -d /data/images/daily/`date +%A` -E "/data"

I also verify afterwards with:

/usr/sbin/mondoarchive -e -Vi -d /data/images/daily/`date +%A`

I have tried:

-adding the -e switch to avoid ejection -upgraded mondo and mindo to the latest release (.09).

The problem is still there...

comment:5 in reply to:  4 Changed 10 years ago by Patrick Corrigan

Replying to phcorrigan: I forgot to mention that I am running Mondo Archive v2.2.9.2-r2575 on on x86_64.

Replying to ugob:

I am having a similar problem. I am running Mondo as a cron job on CentOS 5.2. I end up with a 171 GB file in /var/spool/clientmqueue. The mondorescue iso file is only 822 MB, so I don't know how this huge file is getting generated.

During verify mondoarchive.log shows the following:

[Main] libmondo-verify.c->verify_a_tarball#506: afio -r -P bzip2 -Z /tmp/mondo/mondo.tmp.zZXNjS/cdrom/archives/98.afio.bz2 >> /tmp/mondo/mondo.tmp.zZXNjS/afio.log 2>> /tmp/mondo/mondo.tmp.zZXNjS/afio.log '/tmp/mondo/mondo.tmp.zZXNjS/cdrom/archives/98.afio.bz2' - differences found afio: /var/spool/clientmqueue/dfo4I1KnC0003500

"dfo4I1KnC0003500" is the name of the large file.

Here is my cron command:

/usr/sbin/mondoarchive -OVn nfs://orp-pdx-backup:/vol1/pbx_backup -N -E /media/usb -S /tmp/mondo -T /tmp/mondo -s 4480m

I run Mondo on several servers daily. This probably is mostly seen on one server, but I've seen it on another server too.

The first symptom of the problem is that /var is filling up. Why? Because since I run mondo via cron, the output is sent by e-mail. So a very big file can be found in /var/spool/clientmqueue.

If I check the content of this big file, I find this:

---promptstring---1--- CD-ROM device
---promptstring---2--- Please enter your CD-ROM's /dev device
---promptstring---Q---
--> ASSERTION FAILED: `device[0]!='\0''
at libmondo-devices.c:1631 in mount_CDROM_here

(I)gnore, ignore (A)ll, (D)ebug, a(B)ort, or (E)xit? Invalid choice.
Invalid choice.
Invalid choice.
Invalid choice.
Invalid choice.
Invalid choice.
Invalid choice.

In /var/log/message, there is:

Sep 13 02:01:07 bibitte kernel: attempt to access beyond end of device
Sep 13 02:01:08 bibitte kernel: loop0: rw=0, want=1230356, limit=82328
Sep 13 02:01:09 bibitte kernel: Buffer I/O error on device loop0,
logical block 307588
Sep 13 02:01:10 bibitte kernel: attempt to access beyond end of device
Sep 13 02:01:13 bibitte kernel: loop0: rw=0, want=1230360, limit=82328
Sep 13 02:01:13 bibitte kernel: Buffer I/O error on device loop0,
logical block 307589
Sep 13 02:01:14 bibitte kernel: attempt to access beyond end of device
Sep 13 02:01:16 bibitte kernel: loop0: rw=0, want=1230236, limit=82328
Sep 13 02:01:17 bibitte kernel: Buffer I/O error on device loop0,
logical block 307558
Sep 13 02:01:17 bibitte kernel: attempt to access beyond end of device
Sep 13 02:01:17 bibitte kernel: loop0: rw=0, want=1230240, limit=82328
Sep 13 02:01:17 bibitte kernel: Buffer I/O error on device loop0,
logical block 307559
Sep 13 02:01:17 bibitte kernel: cdrom: open failed.
Sep 13 02:01:17 bibitte kernel: cdrom: open failed.

The command line is:

mondoarchive -e -Oi -9 -F -d /data/images/daily/`date +%A` -E "/data"

I also verify afterwards with:

/usr/sbin/mondoarchive -e -Vi -d /data/images/daily/`date +%A`

I have tried:

-adding the -e switch to avoid ejection -upgraded mondo and mindo to the latest release (.09).

The problem is still there...

comment:6 Changed 10 years ago by Bruno Cornec

If the content of the file changes, it may be not read correctly by afio at archive time. Why not excluding /var/spool/clientmqueue, using the -E option ? Or stoping the mail service during the backup time ?

comment:7 Changed 10 years ago by Patrick Corrigan

Resolution: fixed
Status: reopenedclosed

I'm sorry - my comments apply to a later version.

Note: See TracTickets for help on using tickets.