Opened 6 years ago

Closed 6 years ago

#692 closed defect (wontfix)

backup broken: no inittab file found

Reported by: tux-59 Owned by: tux-59
Priority: high Milestone: 3.0.4
Component: mondo Version: 3.0.3
Severity: major Keywords:
Cc: jerome.ruyssen.jr@…

Description

Hello, I'm facing a problem which prevent me from recovering a server

I have a mondo backup of that machine, with 4 .iso files.

the problem is: I have made these backup with a version of mondo which seems to have a bug. That bug seems to prevent the mondo ISO from booting and that is what I'm exactly facing: I'm stuck while booting the ISO. The last message si "No inittab file found. Enter runlevel. and that's all"

I have seen many post where this problem seems to get solved; BUT my problem is that I can't make a new backup of my server with an upgraded version of mondo (which seems to solve the problem).

I have to use that backup to recover my server, which is curently down.

I tried booting from an other ISO, from a different server (made with an upgraded verison of mondo), and that ISO is booting fine. But it seems that ISO can only restore the backup of the server from which mondoarchive has been run. Unfortunatly that server is not the one I need to recover.

Is it a way to boot from an ISO and to tell it to restore the ISO of another server ?

I hope I'm clear. Thank you very much for your help Tux-59

Change History (2)

comment:1 Changed 6 years ago by bruno

If you boot from the working ISO, you can use a network restoration mode, where you give the other ISO as content. Requires NFS to be setup and work.

Also you could recreate a new ISO taking the ne which is working as the base and replacing the archive content by the one of the older ISO.

comment:2 Changed 6 years ago by bruno

  • Resolution set to wontfix
  • Status changed from new to closed

You can also reinstall the system with your OS and restore your content using afio as described on the wiki http://trac.mondorescue.org/wiki/Documentation#Manualrestoration

Note: See TracTickets for help on using tickets.