Ticket #639 (closed defect: fixed)

Opened 2 years ago

Last modified 15 months ago

mondorestore nfs "protocol not supported"

Reported by: cocampbe Owned by: bruno
Priority: high Milestone: 3.0.3
Component: mindi Version: 3.0.3
Severity: major Keywords:
Cc: vaida.dan@…

Description

Running oel 6.3. Having issue mounting nfs from mondorescue.iso. I select automatic and get his message:

Alert Failed to find config file/archives. Choose another source?

I choose yes, select nfs, yada, yada, yada.

It still fails. I try and mount it manually, but get the "protocol not supported" error. I have tried the -t nfs and -t nfs4, but neither work. The nfs server is running HPUX 11.31 nfsv4. I tried the fsisd=0 as suggested in another ticket. On HPUX the lowest number for fsid is 1. I also set root=ipaddr_of_host. That is the equivalent to no_root_squash form what I can tell. mindi and mindi-busybox version are:

mindi-2.1.3-1.rhel6.x86_64 mindi-busybox-1.18.5-1.rhel6.x86_64

Change History

comment:1 Changed 2 years ago by cocampbe

I am starting to wonder if this is related to another issue I am having. I was trying to scp the mondorestore.log file to another system. I get this error when I try to run scp:

scp: unknown user 0

I then tried to ssh to another server and get this:

You don't exist, go away!

I ran the id command and whoami, neither is able to translate 0 to root. /etc/nsswitch.conf looks fine. The permissions also look fine.

comment:2 Changed 2 years ago by bruno

The "Failed to find config file/archives" means that the CD wasn't found. So the NFS mount didn't succeed. Any other error message on screen you could report related to that ? what gives the relaunch of /sbin/start-netfs ?

comment:3 Changed 2 years ago by kohler

Hi,

had the same problem ('You don't exist, go away!') using sshfs on a RHEL6.3.

Found out, that RHEL6.3 has a newer version of libnss_compat (so.2) which mindi failed to add to the boot environment (all.tar.gz).

Adding

/lib/libnss_compat.so.2 /lib64/libnss_compat.so.2 /lib64/libnss_files.so.2

to /etc/mindi/deplist.d/minimal.conf

resolved the problem.

cheers,

Peter

comment:4 Changed 2 years ago by bruno

  • Status changed from new to closed
  • Resolution set to fixed
  • Component changed from mindi-busybox to mindi

Fixed in rev [3050]. Many thanks for your patch !

comment:5 Changed 16 months ago by dan

  • Status changed from closed to reopened
  • Severity changed from major to critical
  • Cc vaida.dan@… added
  • Version changed from 3.0.2 to 3.0.3
  • Keywords ubuntu, nfs, restore added
  • Resolution fixed deleted

Your NFS server is not the problem.

I am able to reproduce this with Mondo 3.0.3, Mindi 2.1.5 and BusyBox? 1.18.5 on Ubuntu 12.04.2 x86_64.

I checked my /etc/mindi/deplist.d/minimal.conf and I only have these two there: /sbin/mount.nfs /sbin/mount.nfs4

Anything else that needs to be in there ?

Thanks.

comment:6 Changed 15 months ago by bruno

  • Keywords ubuntu, nfs, restore removed
  • Status changed from reopened to closed
  • Resolution set to fixed
  • Severity changed from critical to major

This bug is fixed. Yours is handled in another report (#699), please stick to that one.

Note: See TracTickets for help on using tickets.