Opened 7 years ago

Closed 7 years ago

#503 closed defect (fixed)

mindi tar of udev is not working for lib64, on Ubuntu 64 bits

Reported by: vicgat Owned by: bruno
Priority: normal Milestone: 3.0.0
Component: mindi Version: 2.2.9.7
Severity: normal Keywords: mindi tar lib64
Cc:

Description

Context

Mondo Archive v2.2.9.7-r2846

Mindi v2.0.7.8-r2846

Mindi-BusyBox? v1.18.3-r2846

The problem is with tar, line 2456 of /usr/sbin/mindi :

tar cf - -C / /lib*/udev 2>> $MINDI_TMP/$$.log | tar xf -

It works well on 32 bits GNU/Linux distribs, and on RHEL 64 bits (x86_64), but not on Ubuntu 11.04 64 bits (x86_64).

On the same Ubuntu x86_64, if I execute manually "tar cf - /lib*/udev | tar xf -" it works.

But, on the same Ubuntu x86_64, through mindi it doesn't work for lib64 :

In mondoarchive.log from line 878 to line 920

Making 32768KB boot disk...............udev device manager found
tar: lib/udev/pcmcia-check-broken-cis: Cannot hard link to `lib64/udev/pci-db': Invalid cross-device link
...
tar: lib/udev/usb_modeswitch: Cannot hard link to `lib64/udev/path_id': Invalid cross-device link
tar: Exiting with failure status due to previous errors
Problem in /lib/udev analysis

In another mondoarchive.log, on a french server : from line 848 to line 1021

Making 32768KB boot disk...............udev device manager found
tar: lib/udev/iphone-set-info : impossible de créer un lien physique vers «lib64/udev/iphone-set-info»: Lien croisé de périphéque invalide
...
tar: lib/udev/usb-db : impossible de créer un lien physique vers «lib64/udev/collect»: Lien croisé de périphéque invalide
tar: Arrêt avec code d'échec à cause des erreurs précédentes
Problem in /lib/udev analysis

Some other people have the same problem, on Debian, example:

http://mondorescue-mailing-list.679749.n3.nabble.com/Mondo-devel-mondorestore-2-2-9-7-no-LVM-w-Debian-Sid-td3126179.html

Maybe the problem doesn't occur with RHEL6 64 bits because /lib64 is not soft linked to /usr, as it is on Ubuntu 64 bits...

Attachments (1)

logs-etc.zip (99.9 KB) - added by vicgat 7 years ago.
Ubuntu 11.04 mondoarchive logs, etc.

Download all attachments as: .zip

Change History (5)

Changed 7 years ago by vicgat

Ubuntu 11.04 mondoarchive logs, etc.

comment:1 Changed 7 years ago by vicgat

There is a "bug" in my last phrase...the right one is :

Maybe the problem doesn't occur with RHEL6 64 bits because /lib64 is not soft linked to /lib, as it is on Ubuntu 64 bits...

comment:2 Changed 7 years ago by bruno

  • Status changed from new to assigned

Thanks Victor for the report and analysis.

This should be handled better as rev [2895]. I remade ubuntu 11.04 x86_64 version for you to test. If you could report if indeed I fixed it correctly, that would help !

comment:3 Changed 7 years ago by vicgat

I checked mondoarchive (same context, but with mindi rev 2895) and I don't get anymore the tar udev errors in mondoarchive.log.

Thanks Bruno, well done !

comment:4 Changed 7 years ago by vicgat

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.