Opened 8 years ago

Closed 8 years ago

#490 closed defect (fixed)

several bugs in mondorestore

Reported by: guruguy Owned by: bruno
Priority: normal Milestone: 3.0.0
Component: mondo Version: 2.2.9.7
Severity: normal Keywords: explicit list ignored, iso unmounts
Cc:

Description

using under - Linux version 2.6.18-6-amd64 Debian - following: ii mindi 2.0.7.8-1 ii mindi-busybox 1.18.3-3 ii mondo 2.2.9.7-1

topology/scenario: backup destination is a usb hard drive attached (and mounted) to another debian system. backup destination is mounted locally via sshfs. mondoarchive was performed with -i -s 2g; although in this case only 1 iso was needed for backup.

during attempt to restore a single file, have noted following apparent mis-behavior's: 1) using: mondorestore -p name -i -J "/root/j" -d "/mnt/nfs/VMs/_VMhost-name/_name"

  • mondo appears to ignore -J & -d options and presents interactive mode
  • in interactive mode - no way to select anything below top level directory (probly not a bug :)

2) using: mondorestore -p name -i -J "/root/j" (and select /usr directory, restore to alternate location)

  • mondo again ignores -J option
  • almost every time a new tarball # ticked by - mondo DISMOUNTED the iso from /mnt/cdrom!!!! then asks "please insert iso....."

--- name:/usr/local/bin# cat j /usr/local/bin/image_host name:/usr/local/bin# ---

Attachments (1)

mondorestlog.7z (8.6 KB) - added by guruguy 8 years ago.
mondorestore.log

Download all attachments as: .zip

Change History (3)

Changed 8 years ago by guruguy

mondorestore.log

comment:1 Changed 8 years ago by bruno

-J option is not supported, but that wasn't mentioned in the man page up to now explicitely. Done in rev [2853].

Other points are valid and I'll look at them (-d and umount of devices which is due to recent modifications - you may try with 2.2.9.5 to see another behaviour)

comment:2 Changed 8 years ago by bruno

  • Resolution set to fixed
  • Status changed from new to closed

For mondorestore the -d option doesn't mean where to restore the content, but where to find the iso, as per the man page.

The other problem related to asking multiple times the NFS image wrongly has been fixed, and will be available in 2.2.9.8

Note: See TracTickets for help on using tickets.