Opened 8 years ago

Closed 8 years ago

#488 closed enhancement (wontfix)

How to replace a folder without formating/erasing the partitions

Reported by: jploaiza Owned by: bruno
Priority: high Milestone: 3.0.0
Component: mondo Version: 2.2.9.7
Severity: normal Keywords:
Cc:

Description

I'm backing up some system folders in order to protect the system in a backup process. As not all the folders change in this process I'm only backing up the important ones.

This is the command I'm using now: mondoarchive -ONV -I "/bin /boot /etc /lib /lib64 /root /sbin /usr /var/lib" -p hostname -S $mpoint/storage/hostname/iso -T $mpoint/storage/hostname/temp -n nfs://192.168.36.31:/linux/images

The problem is when I restore the system. I need to get folders like /etc replaced, to delete any new file modify/added by the update process, but instead of that, I only get the replacement of the existing files.

I really don't want to backup the whole disk/partition as there is a bunch of user stuff and things that are not need to be update, I have checked the manuals and search for any information on the page, but I found nothing like this.

I know this could be a good feature for mondo, whenever you restore a folder you can choose if you want to replace the folder or just restore the files inside the folders.

Change History (1)

comment:1 Changed 8 years ago by bruno

  • Resolution set to wontfix
  • Status changed from new to closed

Mondorescue is NOT a backup tool, but rather a GPL Disaster Recovery Solution.

-I should NOT be used, except for tests. In particular, not having / in your list is probably a source of problem. And having it in the -I list means you include everything.

I recommend creating an exclude list and using -E to handle it instead.

Note: See TracTickets for help on using tickets.