Opened 9 years ago

Closed 8 years ago

#435 closed defect (fixed)

tar buffer overflow

Reported by: chucky Owned by: bruno
Priority: normal Milestone: 2.2.9.6
Component: mindi-busybox Version: 2.2.9.4
Severity: critical Keywords: tar overflow
Cc:

Description

When booting from DVD on OpenSuse? 11.3, after "Installing additional tools..." tar crashes with:

*** buffer overflow detected ***: tar terminated

Probably busybox's tar has some bugs on newer versions of gcc (-U_FORTIFY_SOURCE=2 ?).

It can be solved by adding system's /bin/tar to /etc/mindi/deplist.txt.

Change History (6)

comment:1 Changed 9 years ago by chucky

Actually, adding /bin/tar to deps can't solve this. This error message is printed by this statement in install-additional-tools:77

  tar cf - $liste | (cd / ; tar xf -)

When this fails, no files from all.tar.gz are copied to /, so restore is terminated. I fixed my own mondo fork by this

  cp -prf . /
  rm * 2>/dev/null >dev/null
  rm /bin/awk
  ln -s /bin/gawk /bin/awk
  #tar cf - $liste | (cd / ; tar xf -)
  #rm -fr $liste

Awk is relinked because in 11.3 awk is symlink to /etc/alternatives/awk, and from this symlink is linked to /bin/gawk.

comment:2 Changed 8 years ago by bruno

  • Status changed from new to assigned

From mailing list reports, it seems that a more recent busybox can fix this issue.

comment:3 Changed 8 years ago by bruno

Could you check that the new mindi-busybox made from version 1.18.3 is fixing the issue ?

i'm in process of deliveing the packages for the various distributions, you should have it soon.

comment:4 Changed 8 years ago by bruno

  • Milestone changed from 2.2.9.5 to 2.2.9.6

comment:5 Changed 8 years ago by chucky

I can confirm that on OpenSuse? 11.4 this version don't have tar issue (2.0.7.6 + 1.18.3 + 2.2.9.5). Nevertheless there are two new issues:

  • /sbin/blkid was added to busybox, and that cause udev to be using that command. Blkid threads are crashing (and udev writes annoying messages to newt restore screen). Also, whole system is significantly slowed down. I added rm /sbin/blkid and killall -9 blkid to init script and it works well now.
  • reboot command is missing

comment:6 Changed 8 years ago by bruno

  • Resolution set to fixed
  • Status changed from assigned to closed

blkid is solved in rev [2746] reboot is solved in rev [2747]

Note: See TracTickets for help on using tickets.