Opened 11 years ago

Closed 11 years ago

#262 closed defect (fixed)

mondorestore fails on Debian etch + softraid due to mindi error

Reported by: arneb Owned by: bruno
Priority: normal Milestone: 2.2.7
Component: mindi Version: 2.2.6
Severity: normal Keywords:
Cc:

Description

i tried to backup my server (debian etch with a softraid-1) with Mondo 2.2.6/Mindi 2.02 Creating the isos suceeded, but i was not able to restore with the iso and the nuke command due to a broken mountlist. So i tried to reproduce this mountlist by running: lnx1:~# mindi --makemountlist /tmp/mountlist

lnx1:sbin# ./mindi.orig --makemountlist /tmp/mountlist Your mountlist will look like this: Analyzing LVM...

DEVICE MOUNTPOINT FORMAT SIZE (MB) LABEL/UUID /dev/md0 / ext3 19077 /dev/md1 /var/share ext3 152586 /dev/hda5 /tmp ext3 9538 /dev/hda2 swap swap 972 /dev/hdc2 swap swap 972 /dev/hda3 swap swap 972 /dev/hdc3 swap swap 972 /dev/hda1 swap swap 972 /dev/hdc1 swap swap 972

The entries for hda3/hdc3 and hda1/hda3 are wrong, these partitions are in a raid-1 set and NO swap.

After doing some testing i found out that the problem is, that the name of the current partition is not resettet while running in the main loop for all fileystems in mindi. If finding the partition does not suceed str_to_find_fmt_with is not changed and stays on the partition name of the last partition which is, in my case, one of type swap. The following patch fixes this:

--- mindi.orig 2008-06-19 16:16:14.000000000 +0200 +++ mindi 2008-06-09 14:20:25.000000000 +0200 @@ -1231,6 +1231,9 @@

# Needs to handle the recent OpenSUSE fancy way of dealing with fstab :-( # they use symlinks in fstab unrelated to what is shown in mount ! if [ _"$partition_mountpt" = _"" ]; then

+ # set default in case we dont't find it + str_to_find_fmt_with=$current_partition +

for tmpp in tr -s '\t' ' ' < $MY_FSTAB | /bin/grep -Ev "^#" | $AWK '{print $1}'; do

if [ _"readlink -f $tmpp" = _"$current_partition" ]; then

str_to_find_fmt_with=$tmpp

With this, everything is ok:

Your mountlist will look like this: Analyzing LVM...

DEVICE MOUNTPOINT FORMAT SIZE (MB) LABEL/UUID /dev/md0 / ext3 19077 /dev/md1 /var/share ext3 152586 /dev/hda5 /tmp ext3 9538 /dev/hda2 swap swap 972 /dev/hdc2 swap swap 972 /dev/hda3 raid raid 152586 /dev/hdc3 raid raid 152586 /dev/hda1 raid raid 19077 /dev/hdc1 raid raid 19077

Attachments (1)

mindi.diff (684 bytes) - added by arneb 11 years ago.

Download all attachments as: .zip

Change History (3)

comment:1 Changed 11 years ago by arneb

Seems like formatting is broken...

i attach the patch

Changed 11 years ago by arneb

comment:2 Changed 11 years ago by bruno

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in rev [1986]

Note: See TracTickets for help on using tickets.