Opened 12 years ago

Closed 11 years ago

#234 closed enhancement (fixed)

by-id support

Reported by: heinkonijn Owned by: bruno
Priority: normal Milestone: 2.2.8
Component: mindi Version: 2.2.4
Severity: normal Keywords:
Cc:

Description (last modified by bruno)

Hi,

My /etc/fstab looks like:

/dev/disk/by-id/scsi-SATA_SAMSUNG_HM120JIS09GJ30LB01772-part2 /       ext3    acl,user_xattr 1 1
/dev/disk/by-id/scsi-SATA_SAMSUNG_HM120JIS09GJ30LB01772-part3 /home   reiserfs defaults,acl 1 2
/dev/disk/by-id/scsi-SATA_SAMSUNG_HM120JIS09GJ30LB01772-part1 swap swap    defaults 0 0

But mini doesn't seem to support by-id, when I try to run mindi it cannot find all my partitions. When I change my /etc/fstab to /dev/sda1 etc it can find it, but then I loose the flexibility of by-id.

Hope this will be enhanced in the next version. You can mail me at heinkonijn_at_myrealbox.com

Thanks, Hein

Attachments (3)

mindi.log (5.0 KB) - added by Firebar 11 years ago.
mindi log for mindi --makemountlist command
mondoarchive.log (216.2 KB) - added by Firebar 11 years ago.
Mondoarchive log
mondorestore.log (151.2 KB) - added by Firebar 11 years ago.
mondorestore - successful restore

Download all attachments as: .zip

Change History (14)

comment:1 Changed 12 years ago by bruno

  • Milestone changed from 2.2.5 to 2.2.6
  • Status changed from new to assigned

comment:2 Changed 11 years ago by bruno

  • Description modified (diff)
  • Milestone changed from 2.2.6 to 2.2.7

comment:3 Changed 11 years ago by bruno

Could you try with the latest 2.0.2 version of mindi please and give your /var/log/mindi.log file resulting from that. Also running

mindi --makemountlist /tmp/1

and giving screen output and log file again would be useful.

Which distribution are you running ?

comment:4 Changed 11 years ago by bruno

Any news ?

comment:5 Changed 11 years ago by bruno

  • Description modified (diff)
  • Milestone changed from 2.2.7 to 2.2.8

Changed 11 years ago by Firebar

mindi log for mindi --makemountlist command

Changed 11 years ago by Firebar

Mondoarchive log

comment:6 Changed 11 years ago by Firebar

Using SLES10 SP2. Everything appears to go find during a restore, I then edit /etc/fstab at the end and check it over. However, upon reboot the old by-id entries appear again - checking /etc/fstab from rescue mode shows old entries added to the top of the file (with MondoRescue?'s entries still there below them).

This may not be specific to mindi.

Once I'm back in front of my machine I'll try to upload an updated mindi.log and would be happy to assist with anything you'd like me to test.

comment:7 follow-up: Changed 11 years ago by bruno

So what the initial reporter gave as feedback doesn' seem to be tru with you. mindi is indeed working and mondoarchive goes up to the end.

Even from what you said, the restore is OK.

So what is not working exactly ? Is it the bootloader part, the fstab content only ?

Could you then, as restore is mostly working, join your /var/log/restore.log so that I could see what doesn't work in it.

comment:8 in reply to: ↑ 7 ; follow-up: Changed 11 years ago by Firebar

Hi Bruno,

Having had a chance to look at it, the issue is infact different to that in this ticket.

The problem encountered is that SLES doesn't have a symlink for /boot/grub/menu.lst in the form of /etc/grub.conf. MondoRestore? opens up /etc/grub.conf for editing (I guess assuming that grub.conf is symlinked) and so the system boots with the following kernel options still intact, as an example:

KERNEL-HERE root=/dev/by-id/disk-XXXXX

....rather than by device name.

This means the boot process sits there waiting for the device by that id to appear. When it doesn't, it dumps back to a shell prompt.

Attached is my restore log.


Unlike heinkonijn, Mindi finds all my partitions and changes to device name. Perhaps he is requesting that udev be set to have fresh rules for then new disks @ restore time.... ?

Changed 11 years ago by Firebar

mondorestore - successful restore

comment:9 in reply to: ↑ 8 Changed 11 years ago by bruno

Replying to Firebar:

The problem encountered is that SLES doesn't have a symlink for /boot/grub/menu.lst in the form of /etc/grub.conf. MondoRestore? opens up /etc/grub.conf for editing (I guess assuming that grub.conf is symlinked) and so the system boots with the following kernel options still intact, as an example:

KERNEL-HERE root=/dev/by-id/disk-XXXXX

....rather than by device name.

This means the boot process sits there waiting for the device by that id to appear. When it doesn't, it dumps back to a shell prompt.

Revision [2095] should fix that as mondo will now only use /boot/grub/menu.lst So will be fixed in 2.2.8

comment:10 Changed 11 years ago by Firebar

Excellent stuff. When I can get hold of a machine I'll give it some testing :)

Have left this ticket open for the OP.

comment:11 Changed 11 years ago by bruno

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.