Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#218 closed defect (wontfix)

installing grub fails

Reported by: klausade Owned by: bruno
Priority: normal Milestone: 2.2.5
Component: mondo Version: 2.2.0
Severity: normal Keywords:
Cc:

Description

Running mondo on debian etch and debian testingm both fails installing grub. I'm running mondoarchive and mondorestore on the very same machine, and it does have /dev/hda.

Here is the grub part from mondo-restore.log on a debian etch machine:

[Main] mondo-rstr-tools.c->run_grub#1634: Yay! grub-MR found... [Main] mondo-rstr-tools.c->run_grub#1636: command = grub-MR /dev/hda /tmp/mountlist.txt Running GRUB...

[Main] mondo-rstr-tools.c->run_grub#1683: mondo-rstr-tools.c, run_grub, 1683: grub-MR /dev/hda /tmp/mountlist.txt

Now I'll use grub-install grub-install returned 1 Trying a hack

device (hd0) /dev/hda

root (hd0,-1) setup (hd0) quit

Probing devices to guess BIOS drives. This may take a long time.

GNU GRUB version 0.97 (640K lower / 3072K upper memory)

[ Minimal BASH-like line editing is supported. For

the first word, TAB lists possible command completions. Anywhere else TAB lists the possible completions of a device/filename. ]

grub> device (hd0) /dev/hda

Error 15: File not found grub> grub> root (hd0,-1)

Error 11: Unrecognized device string grub> setup (hd0)

Error 12: Invalid device requested grub> quit /mondo/grub-MR: /mondo/grub-MR: 185: try_grub_Hack: not found

device (hd1) /dev/hda

root (hd1,-1) setup (hd1) quit

Probing devices to guess BIOS drives. This may take a long time.

GNU GRUB version 0.97 (640K lower / 3072K upper memory)

[ Minimal BASH-like line editing is supported. For

the first word, TAB lists possible command completions. Anywhere else TAB lists the possible completions of a device/filename. ]

grub> device (hd1) /dev/hda

Error 15: File not found grub> grub> root (hd1,-1)

Error 11: Unrecognized device string grub> setup (hd1)

Error 12: Invalid device requested grub> quit /mondo/grub-MR: /mondo/grub-MR: 185: try_grub_Hack: not found

device (hd2) /dev/hda

root (hd2,-1) setup (hd2) quit

Probing devices to guess BIOS drives. This may take a long time.

GNU GRUB version 0.97 (640K lower / 3072K upper memory)

[ Minimal BASH-like line editing is supported. For

the first word, TAB lists possible command completions. Anywhere else TAB lists the possible completions of a device/filename. ]

grub> device (hd2) /dev/hda

Error 15: File not found grub> grub> root (hd2,-1)

Error 11: Unrecognized device string grub> setup (hd2)

Error 12: Invalid device requested grub> quit /mondo/grub-MR: /mondo/grub-MR: 185: try_grub_Hack: not found Hack returned res=127 Now I'll use grub-install.patched grub-install.patched returned 1 Trying to use the existing grub.conf file in batch mode Grub.conf approach returned 2 grub-MR returned res=2 running: grub-MR /dev/hda /tmp/mountlist.txt > /tmp/mondo-run-prog-thing.tmp 2> /tmp/mondo-run-prog-thing.err


Alright then. .............Cool. You shouldn't call /sbin/grub-install. Please call /usr/sbin/grub-install instead!

/dev/hda: Not found or not a block device. BusyBox? v1.2.1 (2006.08.30-12:07+0000) multi-call binary

Usage: cp [OPTION]... SOURCE DEST

chroot: cannot execute grub-install.patched: No such file or directory /mondo/grub-MR: /mondo/grub-MR: 202: cannot open /mnt/RESTORING/etc/grub.conf: No such file


...ran with res=512 Because of bugs in GRUB's own installer, GRUB was not installed properly. Please install the boot loader manually now, using this chroot()'ed shell prompt. Type 'exit' wh en you have finished. Thank you. Failed. GRUB ran w/error(s). See /tmp/mondo-restore.log for more info. [Main] mondo-rstr-tools.c->run_grub#1698: Type:- [Main] mondo-rstr-tools.c->run_grub#1699: mount-me [Main] mondo-rstr-tools.c->run_grub#1700: chroot /mnt/RESTORING [Main] mondo-rstr-tools.c->run_grub#1701: mount /boot [Main] mondo-rstr-tools.c->run_grub#1702: grub-install '(hd0)' [Main] mondo-rstr-tools.c->run_grub#1703: exit [Main] mondo-rstr-tools.c->run_grub#1704: unmount-me [Main] mondo-rstr-tools.c->run_grub#1706: If you're really stuck, please e-mail the mailing list. Your boot loader returned an error

Change History (4)

comment:1 Changed 12 years ago by bruno

  • Resolution set to wontfix
  • Status changed from new to closed
  • Version changed from 2.2.4 to 2.2.0

I think that problem should be reported to Debian, rather than upstream, as the version used, is already a bit old now, and the upcoming 2.2.5 should solve all these issues, at least that's what I'm working on right now.

So it won't be fixed in 2.20 by upstream, maybe by andree.

comment:2 Changed 12 years ago by klausade

Do you know what the problem is? If 2.2.5 has this solved, maybe I can backport it.

comment:3 Changed 12 years ago by klausade

Trying to work around the problem, I discovered that I didn't have any devices in /dev, so I couldn't run grub even from the chroot system at the end of mondorestore, but running: cd /dev;MAKEDEV hda produces the needed devices in /dev, and after that I could run grub in the chroot.

But, seems the real bug whas that I had included /dev in the exclude list, removing /dev from the exclude list solved the problem with grub not installing itself automatically in mondorestore.

Funny thing is that excluding /dev on Sarge worked just fine, I just love /dev.

So, now I have a truckload of HP servers just waiting for mondo....

comment:4 Changed 12 years ago by bruno

So I think we can consider it as closed.

Note: See TracTickets for help on using tickets.