Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#200 closed defect (fixed)

Unable to use mondo on RHEL4U4

Reported by: Jean-Laurent Owned by: Bruno Cornec
Priority: normal Milestone: 2.2.5
Component: mindi Version: 2.2.1
Severity: blocker Keywords:
Cc:

Description

I have downloaded and installed successfully theses packages : ftp://ftp.mondorescue.org/rhel/4/U4/

I'm running RHEL4U4 on a Core Duo architecture.

The mindi command generate a bootable CDROM, but the module installation fails. I've tried earlier version of mindi / mindi-busybox packages and I obtained the same behavior.

I've tried Q2 and Q4 tips of the Mondo Rescue FAQ, with no change neither.

Here is an extract of the generated CDROM boot sequence, I can also provide the entire log :

Extracting /ataraid.tgz... Extracting /ida.tgz... Extracting /rd.tgz... Extracting /raw.tgz... Extracting /cciss.tgz... Extracting /nst.tgz... Extracting /dm.tgz.ata_piix: Unknown symbol ata_scsi_ioctl ata_piix: Unknown symbol ata_std_bios_param ata_piix: Unknown symbol ata_tf_read ata_piix: Unknown symbol ata_tf_load ata_piix: Unknown symbol ata_bmdma_start ata_piix: Unknown symbol ata_std_postreset

If you have any idea about the cause of this problem, please let me know,

thanks, Jean-Laurent

Attachments (4)

mindo_error.log (33.4 KB) - added by Jean-Laurent 12 years ago.
Here is an entire log of my boot sequence (old version of mindi, but same behavior with those provided here : ftp://ftp.mondorescue.org/rhel/4/U4/mindi-1.2.1-1.rhel4.i586.rpm )
mindi.log (4.4 KB) - added by Jean-Laurent 12 years ago.
attached is mindo log file.
Mindi-1.2.5_bootlog.txt (59.8 KB) - added by Jean-Laurent 12 years ago.
Boot Log of mindi 1.2.5 generated image
mindi-1.2.5.log (32.9 KB) - added by Jean-Laurent 12 years ago.
mindi 1.2.5 generation log

Download all attachments as: .zip

Change History (12)

Changed 12 years ago by Jean-Laurent

Attachment: mindo_error.log added

Here is an entire log of my boot sequence (old version of mindi, but same behavior with those provided here : ftp://ftp.mondorescue.org/rhel/4/U4/mindi-1.2.1-1.rhel4.i586.rpm )

comment:1 Changed 12 years ago by Bruno Cornec

Could you also provide your /var/log/mindi.log please (on the original system)

Changed 12 years ago by Jean-Laurent

Attachment: mindi.log added

attached is mindo log file.

comment:2 Changed 12 years ago by Jean-Laurent

Milestone: 2.2.52.2.1

If there's a way to enable a verbose mode to know what's wrong, just let me know.

In the initrd I found that the modules were located in the appropriate directory /lib/modules/uname -r directory. It looks like the insmod command fails loading the modules. Is it possible that there's something wrong between the busybox implementation of insmod and the compiled modules ?

NOTE : Don't get confused with the RHEL4U3... RHEL4U5 partitions. I'm really using RHEL4U4 but I also have these grub entries to be able to boot on the other RHEL versions.

comment:3 Changed 12 years ago by Bruno Cornec

Ok, please try with more recent versions. There are just upper on the ftp site. 2.2.5 is still beta but should have fixes for your problem. Your mindi.log is incomplete as run with makemountlist param.

Changed 12 years ago by Jean-Laurent

Attachment: Mindi-1.2.5_bootlog.txt added

Boot Log of mindi 1.2.5 generated image

Changed 12 years ago by Jean-Laurent

Attachment: mindi-1.2.5.log added

mindi 1.2.5 generation log

comment:4 Changed 12 years ago by Jean-Laurent

Hi Bruno,

I have attached my new log and generation files. It looks like the error messages concerning unknown symbol have not disappeared but I'm able to have a prompt.

I probably have to customize the initrd to add the missing files and libs.

I've only tested the mindi command for now.

Once this phase is ok, I'll do some extra testing with mondo for a complete disaster recovery backup.

thanks for you feedback,

comment:5 Changed 12 years ago by Bruno Cornec

From your log files, it seems you're booting using a USB CD-ROM drive with the mindi CD in it. Is that also the environment you had at backup time ?

If not, please mount your USB CD also at backup time, or use the FORCE_MODS variable in mindi code to force the right drivers to be part of your backup.

comment:6 Changed 12 years ago by Jean-Laurent

You're right, I only plugged the CDROM to boot on the Mindi generated CDROM

comment:7 Changed 12 years ago by Bruno Cornec

Milestone: 2.2.12.2.5
Resolution: fixed
Status: newclosed

I think that issue is then fixed. If not, please re-open

comment:8 Changed 12 years ago by Jean-Laurent

Hi Bruno,

I didn't have time to check that the global mondorescue is working, but mindi seems ok. You can leave the ticket closed. I'll let if I'm facing new troubles.

Thanks for your feedback, Jean-Laurent

Note: See TracTickets for help on using tickets.