Opened 12 years ago

Closed 12 years ago

#180 closed defect (fixed)

build2pkg fails because of /etc/gentoo-release

Reported by: marcelser Owned by: bruno
Priority: normal Milestone: 2.2.5
Component: mondo Version: 2.2.3
Severity: normal Keywords: build2pkg
Cc:

Description

Hi, I just checked out the newest branches/2.2.4 and branches/2.2.5 from svn as described in http://www.mondorescue.org/cgi-bin/trac.cgi/wiki/DistributionPackaging.

After installeing jadetex and docbook2ps I could run "tools/svn2build" and it created the tar and zip files for mondo-doc mindi mindiy-busybox and mondo.

But I could not use "tools/build2pkg" and so I began debugging and found out that build2pkg tries to extract files for gentoo-1.12 from the .tar.gz, but of course the files in the .tar.gz where are named gentoo-1.6. After more debugging I found out that the distro-env read the gentoo version is from /etc/gentoo-release.

Problem is, that in newer baselayouts this file gets updated with the current baselayout number which is at the moment baselayout-1.12.9-r2 which writes the following into /etc/gentoo-release

Gentoo Base System release 1.12

So, I changed this to

Gentoo Base System release 1.6

and then build2pkg worked perfectly. The problem is that this file will be overwritte when the next baselayout is released with the next baselayout version. So, build2pkg must somehow be updated to use the version 1.6 (the version which is in the svn tree) on gentoo systems and not what's written in /etc/gentoo-release.

Change History (4)

comment:1 Changed 12 years ago by anonymous

  • Milestone 2.2.4 deleted

Milestone 2.2.4 deleted

comment:2 Changed 12 years ago by bruno

  • Milestone set to 2.2.5
  • Status changed from new to assigned

Is there any other file in Gentoo giving the overall release of the running gentoo version. I mean something that is more stable than what I used ;-) For RHEL I use /etc/redhat-release, which only changes with major releases of RedHat?. Anything similar for Gentoo ?

comment:3 Changed 12 years ago by bruno

Would it be safer to consider that all these are Gentoo v1 ? and not make the distinction with what is behind the dot ?

I guess gentoo being the only self compiled distro, global version do not really have the same meaning. And I'd prefer to maintain only one VM if possible.

comment:4 Changed 12 years ago by bruno

  • Resolution set to fixed
  • Status changed from assigned to closed

Ok I made gentoo nover, and have adapted my new build process with project-builder.org to build again ebuilds. Latest are under ftp://ftp.mondorescue.org/gentoo/nover/test

Note: See TracTickets for help on using tickets.