Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#175 closed defect (duplicate)

mindi iso created image fails to boot with RHEL Kernel 2.6.9-55

Reported by: usda Owned by: bruno
Priority: normal Milestone:
Component: mindi Version: 2.2.3
Severity: major Keywords:
Cc:

Description

After updating the RedHat? kernel to version 2.6.9-55, a new Mindi boot image no longer works when booting on identical hardware. This used to work just fine with the 2.6.9-42 kernel and it still does when I use the images created with the older kernel version. The symptoms are similar to ticket #172.

This is on the Compaq Proliant DL-580 line of servers running RHEL v.4. I've updated to the latest versions of Mondo/Mindi?, but same results. I have the mindi log if needed.

It has something to do with the EIP, here is the message from the boot attempt:

EIP: 0060: [<00000000>] Not tainted VLI EFLAGS: 00010202 (2.6.9-55.ELsmp) EIP is at 0x0 eax:dfe8ae00 ebx:f4d5517c ecx:f5161f6c exd:f4d5517c esi:f5161f6c edi:f4f04a74 ebp:c0333640 esp:f5161ef0 ds:007b es:007b ss:0068 Process find-and-mount (pid: 960, threadinfo=f5161000 task=dfc67930)

Stack: c0162dc4 dfe8ae00 00000000 f5161f6c 08140334 f5161000 c0162f0f f4d5517c

dfe8ae00 0000000e 0000000b c52510b0 00000001 00000001 00000000 f5161f90 00030002 f4f8f45c 00000282 f4f8f45c c0125a0d c5255130 c505dde0 f4fa0380

Call Trace: [<c0162dc4>] vfs_getattr64+0x3f/0xc0 [<c0162f0f>] vfs_stat64+0x28/0x39 [<c0125a0d>] do_wait+0x297/0x449 [<c016353a>] sys_stat64+0xf/0x23 [<c011e7cb>] default_wake_function+0x0/0xc [<c0121ce0>] do_fork+0x108/0x175 [<c011e7cb>] default_wake_function+0x0/0xc [<c011ae6d>] do_page_fault+0x0/0x5c6 [<c0269dcb>] error_code+0x2f/0x38 [<c02d5ee3>] syscall_call+0x7/0xb

Code: Bad EIP Value <0>fatal exception: panic in 5 seconds Kernel panic – not syncing: fatal exception

Attachments (1)

mindi.log (37.4 KB) - added by usda 12 years ago.

Download all attachments as: .zip

Change History (3)

Changed 12 years ago by usda

comment:1 Changed 12 years ago by bruno

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #172

comment:2 Changed 12 years ago by anonymous

  • Milestone 2.2.4 deleted

Milestone 2.2.4 deleted

Note: See TracTickets for help on using tickets.