Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#173 closed defect (fixed)

mindi cannot copy files - reports that maybe it ran out if disk space but I still have disk space and inodes left

Reported by: marcelser Owned by: bruno
Priority: high Milestone: 2.2.4
Component: mindi Version: 2.2.3
Severity: blocker Keywords:
Cc:

Description (last modified by bruno)

I'm a very long time mondo user (since hugo rabson wrote it) but since a week mindi failes with a message that it cannot copy the file /usr/X11R6/bin/afio to tmp.mondo.17319/tmp.mondo.24604/bigdir and reports - did you run out of disk space ?

I checked and I have plenty of space left on the device and I also checked the inodes usage with df -i and it says: Filesystem Inodes IUsed IFree IUse% Mounted on /dev/hda3 0 0 0 - / udev 95860 1476 94384 2% /dev /dev/hda1 10040 57 9983 1% /boot none 95860 1 95859 1% /dev/shm

strange thing is that /dev/hda3 (where mondo creates its files) has no inodes listed, is that normal?

However I don't see why mindi stopped working and also installing the newest mindi 1.2.4 does not help.

However here is the full mindi.log + mondoarchive.log

Attachments (2)

mindi.log (14.7 KB) - added by marcelser 12 years ago.
mondoarchive.log (45.2 KB) - added by marcelser 12 years ago.

Download all attachments as: .zip

Change History (14)

comment:1 Changed 12 years ago by marcelser

I'm a very long time mondo user (since hugo rabson wrote it) but since a week mindi failes with a message that it cannot copy the file /usr/X11R6/bin/afio to tmp.mondo.17319/tmp.mondo.24604/bigdir and reports - did you run out of disk space ?

I checked and I have plenty of space left on the device and I also checked the inodes usage with df -i and it says:

Filesystem            Inodes   IUsed   IFree IUse% Mounted on
/dev/hda3             0       0       0    -  /
udev                   95860    1476   94384    2% /dev
/dev/hda1              10040      57    9983    1% /boot
none                   95860       1   95859    1% /dev/shm

strange thing is that /dev/hda3 (where mondo creates its files) has no inodes listed, is that normal?

However I don't see why mindi stopped working and also installing the newest mindi 1.2.4 does not help.

Changed 12 years ago by marcelser

Changed 12 years ago by marcelser

comment:2 Changed 12 years ago by bruno

  • Status changed from new to assigned

Which version of fileutils are you running ? The command which fails is :

cp --parents -Rdf /usr/X11R6/bin/afio //tmp.mondo.17319/tmp.mondo.24604/bigdir

Could you try that manually ? (after creating a temp dir in the same FS) Could it be a lack of inodes ?

comment:3 Changed 12 years ago by bruno

Your df -i line looks strange to me. Could it be a problem on gentoo itelf ?

comment:4 Changed 12 years ago by bruno

Could you try the following:

mkdir toto
cp --parents -Rdf /usr/X11R6/bin/afio /tmp/toto

and report back (and Your df -i line looks strange to me. Could it be a problem on gentoo itelf ?)

(rewritten as the mail server had an issue)

comment:5 Changed 12 years ago by marcelser

I tried the copy command and I get: cp: failed to get attributes of `/usr/X11R6': Not a directory

so I did a "ls -l" on "/usr/X11R6" and found out that it's a soft link which points to "../usr" and "/usr/bin/afio" exists. So the problem seems to be that mindi tries to copy files through a soft linked directory but failes in doing so. So, I think mindi should either detect that /usr/X11R6 is a soft link and try other directories like /usr/bin or mindi should be able to copy the needed files also in a soft linked directory.

Meanwhile I could make mindi work by adding /usr/bin to every program which is located in /usr/X11R6 which mindi tries to copy so my "ESSENTIAL" section in /etc/mindi/deplist.txt now looks like this

#-------------------------------- ESSENTIAL -----------------------------------
fstab raidtab modules.conf conf.modules mondorestore modules.conf.local
/usr/bin/afio star ntfsclone parted ms-sys /usr/bin/file getfattr setfattr getfacl setfacl
/usr/bin/buffer
/usr/bin/gawk
bzip2 bunzip2 /usr/bin/lzop
ctrlaltdel
# Do not remove as they need to be aligned with the kernel
insmod lsmod
hosts host.conf resolv.conf hosts.allow hosts.deny
klogd sysklogd
fdisk hdparm parted arch
loadkeys
mount
devfsd burnBX burnK6 burnK7 burnMMX burnP5 burnP6 lucifer tiobench tiotest bonnie++ mprime ide-smart

I also found a file called "rootfs/etc/ld.so.conf" in the directory where mindi is installed. The file seems to be a list of directories where mindi tries to locate files in the deplist.txt. But the "/usr/bin" directory is missing. Maybe the most elegant solution would be to add this directory on top of /usr/X11R6 for gentoo systems for the next release and to skip directories which are soft links.

What do you think?

comment:6 Changed 12 years ago by bruno

I think the main problem is probably because your path has /usr/X11R6/bin before /usr/bin (which in your case is useless as those are the same dir).

If you change that you should be able to work around the issue. Of course, I still need to fix mindi in irder to handle correctly those type of issues.

rootfs/etc/ld.so.conf is used at restore time by ld.so the dyn. linker so it's useless to change it (and /usr/bin is in std part of the exploration is does).

I really think the issue is your PATH variable.

comment:7 Changed 12 years ago by marcelser

When I do a "echo $PATH" I only get "/sbin:/bin:/usr/sbin:/usr/bin" so "/usr/X11R6" is not on my $PATH variable.

also a "which afio" shows "/usr/bin/afio", I don't know why mindi tries to copy afio from the "/usr/X11R6" path. Also, I don't want to remove that softlink because my system is setup with the "x11-server" package which includes only light-weight server, I think this setup causes "/usr/X11R6" to be a softlink. I suspect if I remove that softlink the light weight server will stop working.

So, I guess I'll have to wait for an update to mindi which either handles the copying over softlinks or correctly locates the programs (maybe using the 'which' command). Or do you have any other ideas why mindi think that "/usr/X11R6" is the correct directory?

comment:8 Changed 12 years ago by bruno

I think this bug is linked to another one remorted on the ML. You could try to see if rev [1526] fixes your problem

At least it solved the issue on my tests gentoo 64 VM.

comment:9 Changed 12 years ago by marcelser

Hi Bruno,

I checked out version 2.2.5 (which is revision 1533) and I tried to generate a tar.gz for my gentoo system with svn2build but it always stops because it tries to use docbook2ps which is not part of the docbook-sgml-utils on gentoo. So the problem is that I can't try if revision 1526 would fix my mindi problems because I'm unable to build a tar.gz file for gentoo.

Can you please build it for me (cause it seems like you're able to generate gentoo .tar.gz files) and tell me the download location? If that's not possible I have to wait for the 2.2.5 release for gentoo.

Thanks a lot.

Marc

comment:10 Changed 12 years ago by marcelser

  • Resolution set to fixed
  • Status changed from assigned to closed

Hi Bruno,

I finally managed to install docbook2ps and so svn2build worked, however calling build2pkg on my gentoo system fails for 2.2.4 and 2.2.5, maybe it would work the stable branch, but don't know.

But as svn2build created the .tar.gz files I simply copied them into the distfiles directory of portage and used the existing ebuilds for 2.2.4 and installed the most recent 2.2.4 mindi, reverted the deplist.txt back to it's original state and ran mindi. And guess what, it worked! So I closed this ticket as the next release for mindi will solve the problem.

Thanks four your help

comment:11 Changed 12 years ago by anonymous

  • Milestone 2.2.4 deleted

Milestone 2.2.4 deleted

comment:12 Changed 12 years ago by bruno

  • Description modified (diff)
  • Milestone set to 2.2.4
Note: See TracTickets for help on using tickets.