Opened 13 years ago

Closed 12 years ago

Last modified 9 years ago

#140 closed enhancement (fixed)

Fatal error when creating boot disks

Reported by: mbwillma Owned by: bruno
Priority: normal Milestone: 2.2.3
Component: mindi Version: 2.2.1
Severity: normal Keywords: tags$
Cc:

Description

Mindi dies when creating the boot disk. Looks to be a problem with the loop device. Looks like the same issue as #121.

CentOS 4.4 with:

mondo-2.2.1-1.rhel4 mindi-busybox-1.2.2-1.rhel4 mindi-1.2.1-1.rhel4 buffer-1.19-1 afio-2.4.7-1

Clean reboot, then mondoarchive immediately afterward gets the same result.

Attachments (2)

mondo-archive.log (98.2 KB) - added by mbwillma 13 years ago.
Mondo log
mindi.log (23.5 KB) - added by mbwillma 13 years ago.
Mindi log

Download all attachments as: .zip

Change History (39)

Changed 13 years ago by mbwillma

Mondo log

Changed 13 years ago by mbwillma

Mindi log

comment:1 Changed 13 years ago by bruno

Could you check that your kernel follows mondo's requirements (Cf: http://www.mondorescue.org/docs/mondorescue-howto.html#OVERVIEW-SYSRQ-KERNELREQ) This error could be linked to a missing module:

Making 1722KB boot disk...........................mount: wrong fs type, bad option, bad superblock on /dev/loop0,
1690 	       or too many mounted file systems

comment:2 Changed 13 years ago by Philippe.Michel

I have the same problem with the same versions on a few CentOS 4.4 or RHEL 4u4 machines.

I don't think this is related to kernels missing some requirements since since it works on other machines and mindi-1.2.0-2.rhel4 / mindi-busybox-1.2.1-2.rhel4 / mondo-2.2.0-2.rhel4 works fine in all cases.

In my sample, the failures happened on machines with relatively little memory (256 Mb or less) while there is no problem on those with 1+ Gb.

comment:3 Changed 13 years ago by unitetech

I am also having the same problem with CentOS. I was hoping the latest update on the 11th would fix it but it didnt. If anyone has any update on this it would be great to share. Thanks Damien

comment:4 Changed 13 years ago by bruno

In summary what you say is:

  • The problem is with mindi
  • It works with mindi 1.2.0
  • It doesn't work with mindi 1.2.1
  • It won't work with mindi 1.2.2 (a preliminary version is available on the ftp site. Check it with the relative mondo 2.2.2 please)

Does mindi run alone exhibit the same ? If yes, could you run it with sh -x mindi 2>&1 > /tmp/mindi.trc and attach that file here ?

comment:5 Changed 13 years ago by unitetech

I uninstalled the mindi 1.2.2 and mondo 2.2.2-1 and installed mindi 1.2.0 and mondo 2.2.0 and it does now seem to be working. The latest version of mindi and mondo was my first attempt at centos. You are a genius bruno. Do you think I may run into problems with the versions above that I changed to or do you think I will be ok? Also do you want me to still post my findings about mindi running. I had tested mindi by its self before and it failed until I went into the configuration file and disabled the section that tells it to make floppy disks. Then mindi ran its test ok. Do you think this has anything to do with my problem. If you still want me to I will run the test you suggested and post. Thanks for your great support.

comment:6 Changed 13 years ago by unitetech

I am responding with my findings. I successfully backed up Centos4.4 using the following packages mondo-2.2.0-2.rhel4.i586.rpm, afio-2.4.7-1.i586.rpm, buffer-1.19-1.i386.rpm, mindi-1.2.0-2.rhel4.i586.rpm and mindi-busybox-1.2.2-2.rhel4.i586.rpm. I was able to run the command “mondoarchive -OVoi -F -d /backup” and the images backed up to the directory /backup. I then used WinSCP3 to access the machine from my windows machine and copy the ISOs from the backup dir. I also had to copy the mondorescue boot ISO from the /root/images/mindi/ dir. This was needed to boot the machine into mondo rescue. I then burned the cds with Nero and booted to the mondorescue boot cd and it gave a failure at first on formatting the drive but I rebooted and it took. I went thru the setup screens with “nuke” automatic option and inserted the iso cds as needed. The whole restore process took about 30 min and when it was done I had a fully functional machine is the exact state as I backed up on a completely fresh drive. Bruno you are a master and I could not of done it without your post. Thank You and Thank you to all the people that made mondo possible. You guys have saved my life with this.

Damien

comment:7 Changed 13 years ago by bruno

  • Component changed from mindi-busybox to mindi
  • Milestone set to 2.2.2
  • Status changed from new to assigned

From all the info posted here I think there is potentially 2 problems, different but exhibiting nearly the same result for you:

1/ Lack of ext2 support in your kernel (Built-in or module). Please check that CentOS 4 kernel includes ext2 (try to mount an ext2 FS manually)

2/ a call to losetup is done wrongly (IMO) in mindi. Could you try to apply the latest modif in rev [1301] to your 2.2.2 instance and report back again.

comment:8 Changed 13 years ago by Philippe.Michel

The last packages, with mindi-1.2.2-1.rhel4, work for me.

comment:9 Changed 13 years ago by bruno

Thanks for the report !

Could the other people who had issues test with the latest version available on the ftp server (still not the final 2.2.2, but near from it)

comment:10 Changed 13 years ago by bruno

Now that 2.2.2 is officially published on ftp://ftp.mondorescue.org could you check again if this has been solved for good.

comment:11 Changed 12 years ago by zlgdgzl

comment:12 Changed 12 years ago by bruno

  • Milestone changed from 2.2.2 to 2.2.3

Now that 2.2.3 is officially published on ftp://ftp.mondorescue.org could you check again if this has been solved for good or not ? I'd like to close the bug asap. (Do not use 2.2.2 it has a nasty bug on bzip2 compression)

comment:13 Changed 12 years ago by unitetech

Good work Bruno, I am now able to use mondo2.2.3-1 and Mindi1.2.3-1 along with the latest versions of afio and buffer for rhel4 on my centos4.4. No failures as before.

Thank You

comment:14 Changed 12 years ago by bruno

  • Resolution set to fixed
  • Status changed from assigned to closed

comment:15 Changed 9 years ago by Oliver18Pansy

  • Keywords tags$ added
  • Type changed from defect to enhancement

All people deserve good life time and <a href="http://lowest-rate-loans.com/topics/home-loans">home loans</a> or just student loan can make it much better. Because freedom is grounded on money state.

comment:16 Changed 9 years ago by GenevieveLowery23

If you try to find locality where you can get <a href="http://www.prime-resume.com">buy resume</a> here is very complete place for you about this good topic, which accommodate examples and gives an chance to learn how make great CV resumes . But this site is more affecting, and more improving.

comment:17 Changed 9 years ago by AISHAFrancis

I really would like to to thank you for your superior outcome just about this post. I opine that you need the help of a professional <a href="http://www.4submission.com">article submission service</a> or the manual article submission to do your topic more famous.

comment:18 Changed 9 years ago by CarterWanda

You will order already written essay about this post, using the support the writing services. You definately will need use <a href="http://www.plagiarismsearch.com">plagiarism detect</a>. Now, you don’t have to worry about getting a failing mark simply because you have been accused of plagiarizing someone else’s work.

comment:19 Changed 9 years ago by Lowe33Thelma

That is no matter how hard you try to complete premium quality <a href="http://www.essaysbank.com/essays/biographies">biographies essays</a>, just because the masters essays writing organizations are able to do that better. Therefore, relax and get <a href="http://www.essaysbank.com">book reports</a>.

comment:20 Changed 9 years ago by WhitneySerrano29

Do you know that it is correct time to receive the <a href="http://bestfinance-blog.com/topics/credit-loans">credit loans</a>, which will help you.

comment:21 Changed 9 years ago by LacySellers

Excellently composed story, if only all bloggers afforded the similar content as you, the internet would be a much preferably place. And it’s well known that It is not daily grinds that dispatch guy, it is worry. Can I approve you a positive place where you can find original buy term papers. Keep the articles appearing!

comment:22 Changed 9 years ago by LilianHAMILTON

Commonly, students suppose to be loaded with essays writing assignments, but some of them are pressured for time and should order the themes essays from the buy research paper service and they seem to be satisfied with results.

comment:23 Changed 9 years ago by Howell25Candy

Busy students can save valuable time purchasing the term paper topics and the custom writing service would be a proper point to detect all required data.

comment:24 Changed 9 years ago by BrightPenelope18

If students are not really sure what to select, research paper or history essays, they will turn to you, because you do really know how to accomplish the awesome topic.

comment:25 Changed 9 years ago by WileyBonnie

People have got at present time very good Internet sources to purchase the thesis proposal or interesting topic associated with this good topic at the trustworthy thesis service.

comment:26 Changed 9 years ago by INES31Noel

Don't opine that famous essay writing company should write for cheap! Quality will not be very cheap! Don't strive to order customized papers for low prices, because these custom academic papers could be copied.

comment:27 Changed 9 years ago by NewtonAvis34

Looking for dissertation service or the custom thesis, a lot of students can not see such kind of intellectual example of thesis just about this topic.

comment:28 Changed 9 years ago by Deborah34PATRICK

Have lots of work to perform but are pressured for time? So, you can to buy custom essay papers.

comment:29 Changed 9 years ago by Yolanda28WASHINGTON

Do you need an academic paper on any discipline? Not a problem! Our custom sample of essay writing company can finish it especially for you. Furthermore, we use a particular technique to every academic writing project! Hence, we offer you to get your essays from us.

comment:30 Changed 9 years ago by Lynn34BEST

this good topic is very good article and I know that one have to buy custom essay papers and essay writing to get know more information only about it from the writing service.

comment:31 Changed 9 years ago by MARIETTALUNA

Lots of guys tell something like: "What for should I use the social bookmarking website?", or "Which way will it help wesite? " The answer is obvious! Bookmarking submission tools provided by specialists can generate more traffic at your website.

comment:32 Changed 9 years ago by Hester30Snider

After glancing this item story I get the hang of a lot on how to comp articles. As a graduate, I have neveraccomplishrd one ordinary paper and always use thesis writing service. What a shame! But now I have courage in writing. Thank you.

comment:33 Changed 9 years ago by MillieSheppard21

The experienced thesis writing services can sell their masters thesis about this post, hence, some students notice the really experienced buy dissertation service and buy thesis theme right there.

comment:34 Changed 9 years ago by CabreraCHASITY28

To write the thesis research related to this topic is not very easy though you cope with it. If any writer is as good as you are, scholars will never have got problems with the dissertation writing.

comment:35 Changed 9 years ago by VeraMCGOWAN

If different people want to have high mark in any field you would buy dissertation handbook and thesis writing. I did this lots of times. I told about dissertation writing in writing services.

comment:36 Changed 9 years ago by Nicole29FULTON

I actually was afraid using professional essays for the first period. Merelynowadays I am orderly clientand tip everybody use them. Custom term papers company is your secret.

comment:37 Changed 9 years ago by ElenaCARVER25

I do know that you did arduous job, finishing your superior outcome just about this topic. Thence, such kind of task students do writing the dissertation or format thesis researching.

Note: See TracTickets for help on using tickets.