Opened 13 years ago

Closed 11 years ago

#11 closed defect (fixed)

Mindi does not find (some) needed kernel modules

Reported by: lauffer@… Owned by: bruno
Priority: normal Milestone: 2.2.7
Component: mindi Version: 1.0.8
Severity: normal Keywords:
Cc:

Description (last modified by bruno)

Mindi has a problem with finding loaded kerne modules:

If the module name is not "like" the module _file_ name (yes, there are differences!), mindi will not load/pack this module to the boot image

Example:
lsmod -> 3w_XXXX
module name -> 3w-XXXX.ko

So at first I've changed mindi like this;

--- mindi-1.06-10 2006-04-26 13:10:03.000000000 +0200
+++ mindi 2006-04-26 13:10:09.000000000 +0200
@@ -1041,3 +1041,7 @@
for module in $module_list $EXTRA_MODS ; do
- r=`find /lib/modules/$kern -type f | grep "/${module}\..*o" | tail -n1`
+ r=`/sbin/modprobe -l $module`
echo "module $module --> $r" >> $LOGFILE

This was good enougth to get mindi finding this module. But in some other functions of mindi the problem with the module name still exists.

So it seems to be more than just this line, I'll open this as a bug here and I'm sure, you'll be faster in fixing it. ;)

Note: this problem is announced to novell under #169688 for their suse linux products, too.

Change History (4)

comment:1 Changed 13 years ago by bruno

  • Description modified (diff)

comment:2 Changed 13 years ago by bruno

  • Component changed from mondo to mindi
  • Status changed from new to assigned
  • Version changed from 2.0.8 to 1.0.8

if you try /sbin/modprobe -l ipw2100 e.g. it will give somany answers, that it's barely usable for mindi.

So the problem is real but we need to find a better solution, and a global one for all the functions impied.

Will come back to it later on.

comment:3 Changed 12 years ago by seekgzl

World Of Warcraftwow goldwow goldgold wow aidscheap hotelhealth servicescoins and edalsbar code ccdskannerz bar codes wireless bar code readerbuy bar codebar code scanning systemsap bar codewhich barcode scanner should i buy? Aristo Halifaxgod of war unlockable videos A Secret Revealeddiscounts furniturewalleye worm harnessgold of war cheatsworld warcraft power levelingwrought iron stair railingsValerie confectionsmore than words lyricsstudy abroadsuperman tattoowow power levelingrod iron wall decorbuy wow gold staircase ironStar Tattoossuperman tribal tattooHuge Bedding & Bath Discounts wow gold contrastiron gate in california for saleiron gate in california for salereally cheap wow goldatlanta wrought iron doorswow europe Powerlevelingcomputer deskscheap wow gold word listedwrought iron stair railingsileusautomatic gateseurope wow goldpowerlevelingcheap gold for wowcheap american gold coinscalifornia gold rush stories hangingsForeign stuffdiscounts furniture Study Abroad in Japan Call Centerconstipation treadmillsupermanspiderman?3cheap car insurance companycheap female car insuranceairline tickets for cheapcheap air tickets to londoncheap hotelscheap hotel majorcacheap hotels in paphoscheap hotel niagaracheap reno hotelscheap hotels palm springscheap hotel romenew york cheap hotelvoip conference phonemedical insuranceprojector lamphair lossdna testingCEREBRAL PALSYforeign languagetattooshearing aidsreally cheap wow golddiabetes951054007呼叫中心蜘蛛人一号通中国

comment:4 Changed 11 years ago by bruno

  • Milestone set to 2.2.7
  • Resolution set to fixed
  • Status changed from assigned to closed

The solution adopted up to now has been to include both modules 3w-xxxx and 3w_xxxx

Note: See TracTickets for help on using tickets.