Opened 13 years ago

Closed 11 years ago

#102 closed defect (fixed)

/dev/shm Problem

Reported by: groups@… Owned by: Bruno Cornec
Priority: normal Milestone: 2.2.7
Component: mondo Version: 2.2.0
Severity: normal Keywords:
Cc:

Description

I'm running Mondo 2.2.0-2 on a modded RH linux 9 box (2.6.17.13 kernel)

For some reason, mondo mounts /dev/shm to a tmp.mondo.[0-9] directory at only 350 megs.

...ran just fine. :-)
Archiving regular files to media
Archiving regular files
                        [TH=5563]
libmondo-archive.c->create_afio_files_in_background#1186:

[5563:0] - EXATing 0...
                        [TH=5563]
libmondo-files.c->find_home_of_exe#431:
find_home_of_exe () --- Found getfattr at
/usr/bin/getfattr
                        [TH=5582]
libmondo-archive.c->create_afio_files_in_background#1186:

[5582:1] - EXATing 1...
                        [TH=5582]
libmondo-files.c->find_home_of_exe#431:
find_home_of_exe () --- Found getfattr at
/usr/bin/getfattr
                        [TH=5582]
libmondo-files.c->find_home_of_exe#431:
find_home_of_exe () --- Found getfacl at
/usr/bin/getfacl
        [TH=5582] libmondo-filelist.c->get_acl_list#620:
libmondo-filelist.c, get_acl_list, 620: getfacl
--all-effective -P //tmp.mondo.114/filelist.1 2>>
/var/log/mondo-archive.log | gzip -c1 >
//tmp.mondo.114/acl_list.1.gz 2>> /var/log/mondo-archive.log
getfacl: Removing leading '/' from absolute path names
                        [TH=5582]
libmondo-archive.c->create_afio_files_in_background#1195:
[5582:1] - archiving 1...
afio: "//tmp.mondo.114/tmpfs/1.afio.bz2" [offset 349m+768k+0]: No
space left on device

df confirms, /dev/shm is mounted at 350 megs and is full. I've seen several posts about this on sourceforge, but know one seems to have a solution.

Any ideas?

The box has 2G of ram.

fstab contains:

none                    /dev/shm                tmpfs   noexec,nosuid
 0 0

mount verifies it is mounted and rw:

none on /dev/shm type tmpfs (rw,noexec,nosuid)

df says:

none                 1015M     0 1015M   0% /dev/shm

Change History (4)

comment:1 Changed 13 years ago by Bruno Cornec

>  For some reason, mondo mounts /dev/shm to a tmp.mondo.[0-9] directory
>  at only 350 megs.

True. I think it was usedd at a time where machine did not have that
amount of memory they have now.

>  fstab contains:
>  none                    /dev/shm                tmpfs   noexec,nosuid
>   0 0

You could try to remove it from fstab, that way mondo won't use it.
Slower but safer. Workaround only, I added a trac entry #102 to solve it
more efficiently in future.

Bruno.
-- 
Linux Profession Lead EMEA  / Open Source Evangelist \        HP C&I EMEA IET
http://www.mondorescue.org / HP/Intel Solution Center \  http://hpintelco.net
Des infos sur Linux?  http://www.HyPer-Linux.org      http://www.hp.com/linux
La musique ancienne?  http://www.musique-ancienne.org http://www.medieval.org

comment:2 Changed 13 years ago by Jon

The solution was already posted in the devel group.  It requires
logging in via another shell and remount /dev/shm to a much large size
(in my case 3gig).

Perhaps mondorescue could have an option to set the  /dev/shm size?
Or maybe it does and I missed it.

--
Regards,
Jon

On Fri, November 17, 2006 02:39, MondoRescue wrote:
> #102: /dev/shm Problem
> ---------------------------------+------------------------------------------
>  Reporter:  groups@ez15loan.com  |       Owner:  bruno
>      Type:  defect               |      Status:  new
>  Priority:  normal               |   Milestone:  2.2.2
> Component:  mondo                |     Version:  2.2.0
>  Severity:  normal               |    Keywords:
> ---------------------------------+------------------------------------------
>  I'm running Mondo 2.2.0-2 on a modded RH linux 9 box (2.6.17.13
> kernel)
>
>  For some reason, mondo mounts /dev/shm to a tmp.mondo.[0-9]
> directory
>  at only 350 megs.
>
>  {{{
>  ...ran just fine. :-)
>  Archiving regular files to media
>  Archiving regular files
>                          [TH=5563]
>  libmondo-archive.c->create_afio_files_in_background#1186:
>
>  [5563:0] - EXATing 0...
>                          [TH=5563]
>  libmondo-files.c->find_home_of_exe#431:
>  find_home_of_exe () --- Found getfattr at
>  /usr/bin/getfattr
>                          [TH=5582]
>  libmondo-archive.c->create_afio_files_in_background#1186:
>
>  [5582:1] - EXATing 1...
>                          [TH=5582]
>  libmondo-files.c->find_home_of_exe#431:
>  find_home_of_exe () --- Found getfattr at
>  /usr/bin/getfattr
>                          [TH=5582]
>  libmondo-files.c->find_home_of_exe#431:
>  find_home_of_exe () --- Found getfacl at
>  /usr/bin/getfacl
>          [TH=5582] libmondo-filelist.c->get_acl_list#620:
>  libmondo-filelist.c, get_acl_list, 620: getfacl
>  --all-effective -P //tmp.mondo.114/filelist.1 2>>
>  /var/log/mondo-archive.log | gzip -c1 >
>  //tmp.mondo.114/acl_list.1.gz 2>> /var/log/mondo-archive.log
>  getfacl: Removing leading '/' from absolute path names
>                          [TH=5582]
>  libmondo-archive.c->create_afio_files_in_background#1195:
>  [5582:1] - archiving 1...
>  afio: "//tmp.mondo.114/tmpfs/1.afio.bz2" [offset 349m+768k+0]: No
>  space left on device
>  }}}
>  df confirms, /dev/shm is mounted at 350 megs and is full.  I've seen
>  several posts about this on sourceforge, but know one seems to have
> a
>  solution.
>
>  Any ideas?
>
>  The box has 2G of ram.
>
>  fstab contains:
>  {{{
>  none                    /dev/shm                tmpfs
> noexec,nosuid
>   0 0
>  }}}
>
>  mount verifies it is mounted and rw:
>  {{{
>  none on /dev/shm type tmpfs (rw,noexec,nosuid)
>  }}}
>
>  df says:
>  {{{
>  none                 1015M     0 1015M   0% /dev/shm
>  }}}
>
> --
> Ticket URL: <http://trac.mondorescue.org/ticket/102>
> MondoRescue <http://www.mondorescue.org>
> GPL disaster recovery solution

The solution was already posted in the devel group.  It requires
logging in via another shell and remount /dev/shm to a much large size
(in my case 3gig).

Perhaps mondorescue could have an option to set the  /dev/shm size?
Or maybe it does and I missed it.

--
Regards,
Jon


comment:3 Changed 13 years ago by Bruno Cornec

Milestone: 2.2.23.0.1
Status: newassigned

comment:4 Changed 11 years ago by Bruno Cornec

Milestone: 3.0.12.2.7
Resolution: fixed
Status: assignedclosed

Duplicate of #252

Note: See TracTickets for help on using tickets.