Changeset 588 in MondoRescue for trunk/mondo/distributions/debian/rules
- Timestamp:
- May 29, 2006, 11:47:20 AM (19 years ago)
- File:
-
- 1 edited
Legend:
- Unmodified
- Added
- Removed
-
trunk/mondo/distributions/debian/rules
r302 r588 3 3 # Sample debian/rules that uses debhelper. 4 4 # GNU copyright 1997 to 1999 by Joey Hess. 5 # 6 # $Id$ 7 # 5 8 6 9 # Uncomment this to turn on verbose mode. … … 14 17 DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE) 15 18 DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE) 16 17 19 18 20 CFLAGS = -Wall -g … … 86 88 # - start with upstream make install 87 89 $(MAKE) install prefix=$(CURDIR)/debian/$(PACKAGE_NAME)/usr mandir=$(CURDIR)/debian/$(PACKAGE_NAME)/usr/share/man 88 # - fix library permissions 89 chmod 644 debian/$(PACKAGE_NAME)/usr/lib/libmondo.so.2.0.3 \ 90 debian/$(PACKAGE_NAME)/usr/lib/libmondo-newt.so.1.0.0 \ 91 debian/$(PACKAGE_NAME)/usr/lib/libmondo.la \ 92 debian/$(PACKAGE_NAME)/usr/lib/libmondo-newt.la 93 # - remove library symlinks only relevant for development 94 rm -f debian/$(PACKAGE_NAME)/usr/lib/libmondo.so \ 95 debian/$(PACKAGE_NAME)/usr/lib/libmondo-newt.so 96 # - fix autorun script permissions 97 chmod 755 debian/$(PACKAGE_NAME)/usr/lib/mondo/autorun 98 # - relocate manual to temporary location because package directory mondo-doc doesn't exist yet 90 # - copy html manual to temporary location for renaming 99 91 mkdir -p debian/doc-temp 100 mv debian/$(PACKAGE_NAME)/usr/share/doc/mondo-2.11debian/doc-temp/html92 cp -a docs/en/mondorescue-howto debian/doc-temp/html 101 93 102 94 dh_install -s … … 118 110 dh_installchangelogs ChangeLog 119 111 dh_installdocs 120 dh_installexamples121 112 dh_installman 122 113 dh_link … … 124 115 dh_compress 125 116 dh_fixperms 126 dh_makeshlibs127 117 dh_installdeb 128 dh_shlibdeps -l debian/$(PACKAGE_NAME)/usr/lib118 dh_shlibdeps 129 119 dh_gencontrol 130 120 dh_md5sums
Note:
See TracChangeset
for help on using the changeset viewer.