Changeset 1043 in MondoRescue for trunk/mindi-busybox/distributions/debian/rules
- Timestamp:
- Jan 8, 2007, 11:31:22 PM (18 years ago)
- File:
-
- 1 edited
Legend:
- Unmodified
- Added
- Removed
-
trunk/mindi-busybox/distributions/debian/rules
r823 r1043 9 9 PACKAGE_NAME = mindi-busybox 10 10 11 configure: 12 # Nothing to configure in this package. 11 # Don't set any compiler flags - busybox does that just fine 13 12 14 build: 15 # Nothing to build in this package. 13 configure: configure-stamp 14 15 configure-stamp: 16 dh_testdir 17 touch configure-stamp 18 19 # Build both architecture dependent and independent 20 build: build-stamp 21 22 build-stamp: configure-stamp 23 dh_testdir 24 25 # Compile the package. 26 mv .config .config.sav 27 $(MAKE) distclean 28 mv .config.sav .config 29 $(MAKE) oldconfig 30 $(MAKE) busybox 31 32 touch build-stamp 16 33 17 34 clean: 18 35 dh_testdir 19 36 dh_testroot 37 rm -f build-stamp configure-stamp 38 # Clean temporary document directory 39 rm -rf debian/doc-temp 40 # Clean up. 41 -mv .config .config.sav 42 -$(MAKE) distclean 43 -mv .config.sav .config 44 -rm -f busybox 45 20 46 dh_clean 21 47 22 install: 48 # Install architecture dependent and independent 49 install: build 23 50 dh_testdir 24 51 dh_testroot 25 52 dh_clean -k 26 53 dh_installdirs 27 # Build the installation tree:28 ( export RPMBUILDMINDI=true && export PREFIX=$(CURDIR)/debian/$(PACKAGE_NAME)/usr && export CONFDIR=$(CURDIR)/debian/$(PACKAGE_NAME)/etc && ./install.sh )29 54 30 # Build architecture-independent files here. 31 binary-indep: install 32 # We have nothing to do by default. 55 # Install the package files into build directory: 56 # - start with upstream make install 57 $(MAKE) install PREFIX=$(CURDIR)/debian/$(PACKAGE_NAME)/usr/lib/mindi/rootfs 58 # - copy doc 59 mkdir -p debian/doc-temp 60 cp -a ChangeLog INSTALL LICENSE AUTHORS README TODO changelog svn.log debian/doc-temp 33 61 34 # Build architecture-dependent files here. 35 binary-arch: install 62 dh_install -s 63 64 # Build architecture independant packages using the common target. 65 binary-indep: build install 66 # None 67 68 # Build architecture dependant packages using the common target. 69 binary-arch: build install 36 70 dh_testdir 37 71 dh_testroot 38 dh_installchangelogs ChangeLog39 72 dh_installdocs 40 dh_installexamples41 dh_link42 73 dh_strip 43 74 dh_compress … … 48 79 dh_builddeb 49 80 50 binary: binary- indep binary-arch81 binary: binary-arch binary-indep 51 82 .PHONY: build clean binary-indep binary-arch binary install configure
Note:
See TracChangeset
for help on using the changeset viewer.