source: MondoRescue/branches/stable/mindi/distributions/gentoo/mindi.ebuild@ 1591

Last change on this file since 1591 was 1591, checked in by Bruno Cornec, 17 years ago
  • Improve tape support doc (Tilman Schmidt <tilman_at_imap.cc>)
  • mdadm.conf files added to deplist
  • Fix gentoo issues again (Francesco Talamona ti.liame_at_email.it)
  • Fix bug #187 (Scott Cummings rsc_at_usfamily.net)

(merge -r1579:1590 $SVN_M/branches/2.2.5)

File size: 1.3 KB
RevLine 
[572]1# Copyright 1999-2004 Gentoo Foundation
[308]2# Distributed under the terms of the GNU General Public License v2
[572]3# $Header: $
4
[543]5# $Id$
[308]6
7DESCRIPTION="A program that creates emergency boot disks/CDs using your kernel, tools and modules."
8HOMEPAGE="http://www.mondorescue.org"
[732]9SRC_URI="ftp://ftp.mondorescue.org/src/${P}.tar.gz"
[308]10
11LICENSE="GPL-2"
12SLOT="0"
[1591]13KEYWORDS="~x86 ~ia64 ~amd64 -*"
[308]14IUSE=""
15
16DEPEND="virtual/libc"
17RDEPEND=">=app-arch/bzip2-0.9
18 sys-libs/ncurses
19 sys-devel/binutils
20 sys-fs/dosfstools
[1464]21 sys-apps/parted
[308]22 sys-apps/gawk"
23
24src_unpack() {
[781]25 unpack ${A} || die "Failed to unpack ${A}"
[308]26}
27
28src_install() {
[936]29 export HEAD="${D}"
30 export PREFIX="/usr"
31 export CONFDIR="/etc"
[1513]32 export CACHEDIR="/var/cache/mindi"
[936]33 export MANDIR="${PREFIX}/share/man"
34 export DOCDIR="${PREFIX}/share/doc"
35 export LIBDIR="${PREFIX}/lib"
[556]36 export DONT_RELINK=1
[1513]37 export PKGBUILDMINDI="true"
[781]38 "${WORKDIR}"/"${P}"/install.sh
[308]39}
40
41pkg_postinst() {
42 einfo "${P} was successfully installed."
43 einfo "Please read the associated docs for help."
44 einfo "Or visit the website @ ${HOMEPAGE}"
45 echo
46 ewarn "This package is still in unstable."
47 ewarn "Please report bugs to http://bugs.gentoo.org/"
48 ewarn "However, please do an advanced query to search for bugs"
49 ewarn "before reporting. This will keep down on duplicates."
50 echo
51}
Note: See TracBrowser for help on using the repository browser.