source: MondoRescue/branches/stable/mindi/distributions/rpm/mindi.spec@ 699

Last change on this file since 699 was 699, checked in by bcornec, 18 years ago

Manages Obsoletes for mindi

  • Property svn:keywords set to Id
File size: 1.4 KB
RevLine 
[35]1#
2# $Id: mindi.spec 699 2006-07-21 23:07:06Z bcornec $
3#
[313]4%define mrel RRR
[554]5%define tag TTT
[388]6
[1]7Summary: Mindi creates emergency boot disks/CDs using your kernel, tools and modules
[550]8Name: mindi
9Version: VVV
10Release: %mrel
[1]11License: GPL
[550]12Group: GRP
[542]13Url: http://www.mondorescue.org
[550]14Source: SSS
[542]15BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -u -n)
[550]16Requires: bzip2 >= 0.9, mkisofs, ncurses, binutils, gawk, dosfstools DDD
[699]17OBS
[20]18# Not on all systems
19#Conflicts: bonnie++
[1]20
21%description
22Mindi takes your kernel, modules, tools and libraries, and puts them on N
23bootable disks (or 1 bootable CD image). You may then boot from the disks/CD
24and do system maintenance - e.g. format partitions, backup/restore data,
25verify packages, etc.
26
27%prep
[555]28%setup -n %name-%{version}-%{tag}
[1]29
30%build
31%ifarch ia64
[50]32%{__make} -f Makefile.parted2fdisk clean
33%{__make} -f Makefile.parted2fdisk
[1]34%endif
35
36%install
[542]37%{__rm} -rf $RPM_BUILD_ROOT
[50]38export DONT_RELINK=1
39
[235]40export PREFIX=${RPM_BUILD_ROOT}%{_exec_prefix}
41export CONFDIR=${RPM_BUILD_ROOT}%{_sysconfdir}
[179]42export RPMBUILDMINDI="true"
[50]43
[179]44./install.sh
[50]45
[1]46%clean
47%{__rm} -rf $RPM_BUILD_ROOT
48
49%post
[179]50if [ -f /usr/local/sbin/mindi ]; then
51 echo "WARNING: /usr/local/sbin/mindi exists. You should probably remove your manual mindi installation !"
52fi
53
[1]54%files
[542]55%config(noreplace) %{_sysconfdir}/mindi/deplist.txt
[315]56%doc ChangeLog INSTALL COPYING README TODO README.ia64 README.pxe README.busybox svn.log
[423]57%{_mandir}/man8/*
[200]58%{_libdir}/mindi
[564]59%{_sbindir}/*
[1]60
61%changelog
Note: See TracBrowser for help on using the repository browser.