source: MondoRescue/branches/stable/mindi/distributions/rpm/mindi.spec@ 719

Last change on this file since 719 was 719, checked in by Bruno Cornec, 18 years ago

Re-introduce defattr to have correct uid/gid for RPMS (Bishop.Clark_at_gov.bc.ca)

  • Property svn:keywords set to Id
File size: 1.4 KB
Line 
1#
2# $Id: mindi.spec 719 2006-07-28 19:24:21Z bruno $
3#
4%define mrel RRR
5%define tag TTT
6
7Summary: Mindi creates emergency boot disks/CDs using your kernel, tools and modules
8Name: mindi
9Version: VVV
10Release: %mrel
11License: GPL
12Group: GRP
13Url: http://www.mondorescue.org
14Source: SSS
15BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -u -n)
16Requires: bzip2 >= 0.9, mkisofs, ncurses, binutils, gawk, dosfstools DDD
17OBS
18# Not on all systems
19#Conflicts: bonnie++
20
21%description
22Mindi takes your kernel, modules, tools and libraries, and puts them on N
23bootable disks (or 1 bootable CD image). You may then boot from the disks/CD
24and do system maintenance - e.g. format partitions, backup/restore data,
25verify packages, etc.
26
27%prep
28%setup -n %name-%{version}-%{tag}
29
30%build
31%ifarch ia64
32%{__make} -f Makefile.parted2fdisk clean
33%{__make} -f Makefile.parted2fdisk
34%endif
35
36%install
37%{__rm} -rf $RPM_BUILD_ROOT
38export DONT_RELINK=1
39
40export PREFIX=${RPM_BUILD_ROOT}%{_exec_prefix}
41export CONFDIR=${RPM_BUILD_ROOT}%{_sysconfdir}
42export RPMBUILDMINDI="true"
43
44./install.sh
45
46%clean
47%{__rm} -rf $RPM_BUILD_ROOT
48
49%post
50if [ -f /usr/local/sbin/mindi ]; then
51 echo "WARNING: /usr/local/sbin/mindi exists. You should probably remove your manual mindi installation !"
52fi
53
54%files
55%defattr(-,root,root)
56%config(noreplace) %{_sysconfdir}/mindi/deplist.txt
57%doc ChangeLog INSTALL COPYING README TODO README.ia64 README.pxe README.busybox svn.log
58%{_mandir}/man8/*
59%{_libdir}/mindi
60%{_sbindir}/*
61
62%changelog
Note: See TracBrowser for help on using the repository browser.