Last change
on this file since 1634 was 572, checked in by bcornec, 19 years ago |
gentoo build continued
mindi bug found due to a previous bug corrected (5.6 MB disks generated systematically):
- when a disk less than 2.8 MB can be built,
not enough modules are put on it to support SCSI cds
(use of FLOPPY_MODS only). I added most CDROMs modules
in order to support them.
|
File size:
1.1 KB
|
Line | |
---|
1 | # Copyright 1999-2004 Gentoo Foundation
|
---|
2 | # Distributed under the terms of the GNU General Public License v2
|
---|
3 | # $Header: $
|
---|
4 |
|
---|
5 | # $Id$
|
---|
6 |
|
---|
7 | DESCRIPTION="A program that creates emergency boot disks/CDs using your kernel, tools and modules."
|
---|
8 | HOMEPAGE="http://www.mondorescue.org"
|
---|
9 | SRC_URI="ftp://ftp.mondorescue.org/src/${P}.tgz"
|
---|
10 |
|
---|
11 | LICENSE="GPL-2"
|
---|
12 | SLOT="0"
|
---|
13 | KEYWORDS="~x86 -*"
|
---|
14 | IUSE=""
|
---|
15 |
|
---|
16 | DEPEND="virtual/libc"
|
---|
17 | RDEPEND=">=app-arch/bzip2-0.9
|
---|
18 | >=sys-apps/mindi-kernel-1.0-r1
|
---|
19 | sys-libs/ncurses
|
---|
20 | sys-devel/binutils
|
---|
21 | sys-fs/dosfstools
|
---|
22 | sys-apps/gawk"
|
---|
23 |
|
---|
24 | src_unpack() {
|
---|
25 | unpack ${A} || die "Failed to unpack ${A}"
|
---|
26 | }
|
---|
27 |
|
---|
28 | src_install() {
|
---|
29 | export PREFIX="/usr"
|
---|
30 | export CONFDIR="/etc"
|
---|
31 | export RPMBUILDMINDI="true"
|
---|
32 | ./install.sh
|
---|
33 | }
|
---|
34 |
|
---|
35 | pkg_postinst() {
|
---|
36 | einfo "${P} was successfully installed."
|
---|
37 | einfo "Please read the associated docs for help."
|
---|
38 | einfo "Or visit the website @ ${HOMEPAGE}"
|
---|
39 | echo
|
---|
40 | ewarn "This package is still in unstable."
|
---|
41 | ewarn "Please report bugs to http://bugs.gentoo.org/"
|
---|
42 | ewarn "However, please do an advanced query to search for bugs"
|
---|
43 | ewarn "before reporting. This will keep down on duplicates."
|
---|
44 | echo
|
---|
45 | }
|
---|
Note:
See
TracBrowser
for help on using the repository browser.