source: MondoRescue/branches/stable/mindi-kernel/distributions/gentoo/mindi.ebuild@ 551

Last change on this file since 551 was 543, checked in by bcornec, 18 years ago

stable is now at same level as 2.0.8 (r538)

File size: 1.1 KB
Line 
1# Copyright 1999-2005 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2
3# $Id$
4
5DESCRIPTION="A program that creates emergency boot disks/CDs using your kernel, tools and modules."
6HOMEPAGE="http://www.mondorescue.org"
7SRC_URI="ftp://ftp.mondorescue.org/src/${P}.tgz"
8
9LICENSE="GPL-2"
10SLOT="0"
11KEYWORDS="~x86 -*"
12IUSE=""
13
14DEPEND="virtual/libc"
15RDEPEND=">=app-arch/bzip2-0.9
16 >=sys-apps/mindi-kernel-1.0-r1
17 sys-libs/ncurses
18 sys-devel/binutils
19 sys-fs/dosfstools
20 sys-apps/gawk"
21
22src_unpack() {
23 unpack ${A} || die "Failed to unpack ${A}"
24}
25
26src_install() {
27 export PREFIX="/usr"
28 export CONFDIR="/etc"
29 export RPMBUILDMINDI="true"
30 ./install.sh
31}
32
33pkg_postinst() {
34 einfo "${P} was successfully installed."
35 einfo "Please read the associated docs for help."
36 einfo "Or visit the website @ ${HOMEPAGE}"
37 echo
38 ewarn "This package is still in unstable."
39 ewarn "Please report bugs to http://bugs.gentoo.org/"
40 ewarn "However, please do an advanced query to search for bugs"
41 ewarn "before reporting. This will keep down on duplicates."
42 echo
43}
Note: See TracBrowser for help on using the repository browser.