Changeset 3733


Ignore:
Timestamp:
Nov 18, 2019, 1:44:18 AM (4 months ago)
Author:
Bruno Cornec
Message:

Really use unsupported versions of grub when they exist

File:
1 edited

Legend:

Unmodified
Added
Removed
  • branches/3.3/mondo/src/restore-scripts/mondo/mr-grub

    r3699 r3733  
    109109    if [ -x $MNT_RESTORING/usr/sbin/grub-install.unsupported ]; then
    110110        echo "Now I'll use OpenSuSE/SLES new grub-install in chroot" >> $LOGFILE
    111         chroot $MNT_RESTORING /usr/sbin/grub-install >> $LOGFILE 2>> $LOGFILE
     111        chroot $MNT_RESTORING /usr/sbin/grub-install.unsupported >> $LOGFILE 2>> $LOGFILE
    112112        res=$?
    113         echo "grub-install in chroot returned $res" >> $LOGFILE
     113        echo "grub-install.unsupported in chroot returned $res" >> $LOGFILE
    114114    fi
    115115else
    116116    if [ -x /usr/sbin/grub-install.unsupported ]; then
    117117        echo "Now I'll use OpenSuSE/SLES new grub-install locally" >> $LOGFILE
    118         /usr/sbin/grub-install >> $LOGFILE 2>> $LOGFILE
     118        /usr/sbin/grub-install.unsupported >> $LOGFILE 2>> $LOGFILE
    119119        res=$?
    120         echo "grub-install returned $res" >> $LOGFILE
     120        echo "grub-install.unsupported returned $res" >> $LOGFILE
    121121    fi
    122122fi
Note: See TracChangeset for help on using the changeset viewer.