source: MondoRescue/branches/stable/mindi/distributions/gentoo/mindi.ebuild@ 1529

Last change on this file since 1529 was 1529, checked in by Bruno Cornec, 17 years ago
  • ChangeLogs updated for upcoming 2.2.4
  • Attempt to fix #177 by removing first headers and repodata directory before regenerating them.
  • Fix a problem in directory link handling in mindi (seen on gentoo 64) with the precious help of Francesco Talamona ti.liame_at_email.it
  • Gentoo ebuild are now unmasked on my side
  • usb-storage instead of usb_storage as a module name for Virtual CD support seems better
  • Document support for Proliant Virtual Media with mindi
  • Mandriva packages go first to contrib/testing not backport
  • Size of DVD is 4482 (or more surely 4480 to avoid problems). Fixed everywhere.
  • Fix a bug in Mandriva official package creation

(merge -r1519:1528 $SVN_M/branches/2.2.4)

File size: 1.3 KB
Line 
1# Copyright 1999-2004 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2
3# $Header: $
4
5# $Id$
6
7DESCRIPTION="A program that creates emergency boot disks/CDs using your kernel, tools and modules."
8HOMEPAGE="http://www.mondorescue.org"
9SRC_URI="ftp://ftp.mondorescue.org/src/${P}.tar.gz"
10
11LICENSE="GPL-2"
12SLOT="0"
13KEYWORDS="x86 ia64 -*"
14IUSE=""
15
16DEPEND="virtual/libc"
17RDEPEND=">=app-arch/bzip2-0.9
18 sys-libs/ncurses
19 sys-devel/binutils
20 sys-fs/dosfstools
21 sys-apps/parted
22 sys-apps/gawk"
23
24src_unpack() {
25 unpack ${A} || die "Failed to unpack ${A}"
26}
27
28src_install() {
29 export HEAD="${D}"
30 export PREFIX="/usr"
31 export CONFDIR="/etc"
32 export CACHEDIR="/var/cache/mindi"
33 export MANDIR="${PREFIX}/share/man"
34 export DOCDIR="${PREFIX}/share/doc"
35 export LIBDIR="${PREFIX}/lib"
36 export DONT_RELINK=1
37 export PKGBUILDMINDI="true"
38 "${WORKDIR}"/"${P}"/install.sh
39}
40
41pkg_postinst() {
42 einfo "${P} was successfully installed."
43 einfo "Please read the associated docs for help."
44 einfo "Or visit the website @ ${HOMEPAGE}"
45 echo
46 ewarn "This package is still in unstable."
47 ewarn "Please report bugs to http://bugs.gentoo.org/"
48 ewarn "However, please do an advanced query to search for bugs"
49 ewarn "before reporting. This will keep down on duplicates."
50 echo
51}
Note: See TracBrowser for help on using the repository browser.