source: MondoRescue/branches/2.2.4/mindi/distributions/gentoo/mindi.ebuild@ 1443

Last change on this file since 1443 was 1443, checked in by Bruno Cornec, 17 years ago

mindi depends on mindi-busybox for gentoo

File size: 1.2 KB
Line 
1# Copyright 1999-2004 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2
3# $Header: $
4
5# $Id$
6
7DESCRIPTION="A program that creates emergency boot disks/CDs using your kernel, tools and modules."
8HOMEPAGE="http://www.mondorescue.org"
9SRC_URI="ftp://ftp.mondorescue.org/src/${P}.tar.gz"
10
11LICENSE="GPL-2"
12SLOT="0"
13KEYWORDS="~x86 -*"
14IUSE=""
15
16DEPEND="virtual/libc"
17RDEPEND=">=app-arch/bzip2-0.9
18 sys-libs/ncurses
19 sys-devel/binutils
20 sys-fs/dosfstools
21 sys-apps/mindi-busybox
22 sys-apps/gawk"
23
24src_unpack() {
25 unpack ${A} || die "Failed to unpack ${A}"
26}
27
28src_install() {
29 export HEAD="${D}"
30 export PREFIX="/usr"
31 export CONFDIR="/etc"
32 export MANDIR="${PREFIX}/share/man"
33 export DOCDIR="${PREFIX}/share/doc"
34 export LIBDIR="${PREFIX}/lib"
35 export DONT_RELINK=1
36 export RPMBUILDMINDI="true"
37 "${WORKDIR}"/"${P}"/install.sh
38}
39
40pkg_postinst() {
41 einfo "${P} was successfully installed."
42 einfo "Please read the associated docs for help."
43 einfo "Or visit the website @ ${HOMEPAGE}"
44 echo
45 ewarn "This package is still in unstable."
46 ewarn "Please report bugs to http://bugs.gentoo.org/"
47 ewarn "However, please do an advanced query to search for bugs"
48 ewarn "before reporting. This will keep down on duplicates."
49 echo
50}
Note: See TracBrowser for help on using the repository browser.